PDA

View Full Version : Security Settings in Slimserver Webinterface



Vreneli
2007-08-22, 13:12
Ciao all
I have set in the Security tab of the Slimserver webinterface such settings, that I am not anymore able to log in with http://myserver:9000
Is there a solution to this problem?
Thanks for your help
V

Ross L
2007-08-22, 14:00
You could stop SlimServer and delete C:\program files\slimserver\server\slimserver.pref

Then restart SlimServer. I believe you can just delete the password in that file, if you prefer.

Vreneli
2007-08-22, 14:14
Hi again
Thanks for the quick reply.
I have installed my Slimserver on QNAP TS-102, meaning under Linux.
I don't understand Linux. How can I find this file on my QNAP?

Ross L
2007-08-22, 15:20
Theres a good question. I'm not sure where the file is stored, I've actually never used a QNAP. You might want to consider trying in the 3rd party hardware forum.

Are there any options in the administration interface to re-move and re-install SlimServer, or something like that? I know that the ReadyNAS has an option like this.

Vreneli
2007-08-23, 05:14
Hi again
There is this option and I have tried it, but it didn't help. I have the impression, that the .conf file has not been overwritten. I try in the third party forum...

Siduhe
2007-08-23, 08:36
A previous post on a similar topic suggested the following - assuming you are using Windows on your PC?

If you haven't already done so, you will need SSH installed on the QNAP from http://www.progressiveav.com/ts101_update/ or an updated version for a 201?

Get a copy of WinSCP: http://winscp.net/eng/index.php
Just the Standalone Application (.exe) will do.

Login via WinSCP,
username: root
password: admin

[Hostname will probably be slimserver-01 but I can't confirm this for a TS201]

When the WinSCP runs it will give you a split window as default, on one side your default PC folder.

On the other the QNAP linux install.

Navigate to the previously mentioned folder and double click on the slimserver.pref file.

This will open an editor.

Somewhere near the bottom is an entry for security settings, or just delete the file (but you will lose all your settings).

If you change anything, don't forget to save before exiting the editor.

Vreneli
2007-08-23, 13:15
Hi Siduhe
Thanks for the hints.
Done all, but what is the "previously mentioned directory"?
Thanks
V

Ross L
2007-08-23, 13:24
what is the "previously mentioned directory"?


Who are you quoting?

Siduhe
2007-08-23, 13:30
I would try searching the forums for the post I referenced, from memory it was:

/home/slimserver/slimserver.pref

Vreneli
2007-08-23, 22:59
Good day Siduhe
I installed and runned WinSCP but I can't access the linux part of the drive, I can only see the drives I installed in the QNAP installation process.
This also didn't work after having installed SSH on QNAP.
Do you have an idea what the reason could be?

Vreneli
2007-08-24, 14:12
Hi Siduhe
I found the file, though at a different place:

/share/HDA_DATA/ubuntu/home/slimserver

I deleted it and I could access Slimserver Webinterface again.
Thanks for your help.