PDA

View Full Version : Slimserver not 'seeeing' the same as iTunes



jmaynard
2007-08-19, 01:32
I am running Slimserver 6.2.4 on Win XP.
The music list disagrees with the list that iTunes provides: some tracks display a different Genre and/or a different Album name and/or different Artist name.
To try to fix this I removed all ver 3.1 tags but I still get differences.
For example, I have a Leo Sayer album that iTunes (and MP3tag and MP3Collector and Windows Explorer) report as having the genre 'Easy Listening' whereas Slimserver insists it is 'Pop'.
I have checked some of the other anomalies and all are correct in iTunes, MP3Tag and MP3 Collector.
Any suggestions as to why Slimserver is different and/or how to fix it?
Thanks

moley6knipe
2007-08-20, 04:05
If you've changed the genre since SS did a scan, it may not have picked up the change for some reason

First thing to try is a "Clear everything and rescan" and then if still no joy stop SS, delete the folder called "Cache" in your SS directory and then restart.

If that doesn't work I would think you've got two genre entries for your tag somehow - I take it you've tried right-clicking and selecting "View extended tags" from within mp3tag? That should show you EVERY tag, I think?!

jmaynard
2007-08-20, 09:16
thanks for the suggestion:
I stopped SS, deleted both caches and rescanned the music - no change!! (ie the files that are displaying the wrong genre still do so and there are five files that SS says have no genre, no artist, no album and no title but all are present in MP3tag and iTunes) - MP3tag display all tags shows only ID3v3.2 and the correct info...

Thanks

Ur[s]uS
2007-08-21, 02:27
thanks for the suggestion:
I stopped SS, deleted both caches and rescanned the music - no change!! (ie the files that are displaying the wrong genre still do so and there are five files that SS says have no genre, no artist, no album and no title but all are present in MP3tag and iTunes) - MP3tag display all tags shows only ID3v3.2 and the correct info...

Thanks

you can change MP3Tag to look for ID3v1 or Ape (also or instead)
suggest scanning for all
also - try Tag & Rename or The Godfather for another way to view tags that can be useful for identifying rogues
suggest uploading errant file (with the dupe genres) and i'll take a look

Siduhe
2007-08-21, 03:36
Also, just double check that you are pointing Slimserver to the right Itunes .xml file. Someone had a similar problem with Slimserver not picking up changes to his Itunes library and discovered that an upgrade to Itunes had changed his cache filename. On the description below, I think it's much more likely that you have inconsistent tags (as others have mentioned) but worth double checking.

I believe the easiest way to do this is to make a change in your Itunes library, and then check that the .xml file you have pointed slimserver at shows a recent "last modified" timestamp.

jmaynard
2007-08-21, 09:06
I am not using iTunes (managing SS files manually); all Id tags before v3v2.3 have been removed.
I'd lioke to upload an example of an errant file but the upload size limit is too low (97K).
If you can PM I can email you a file or put it on an FTP site for you to download.
Would really appreciate someone else taking a look at one of teh 'funny' files
thanks

Siduhe
2007-08-21, 10:52
I think you've disabled the ability to send you PM's? Will happily take a look if you load one up to an ftp site and send me a PM.

jmaynard
2007-08-21, 13:26
sent you a PM with details of the FTP site where I uploaded two 'funny' files
thanks

Siduhe
2007-08-22, 02:10
I took a brief look at these last night with mixed success:

The problem with the Leo Sayer song was simply resolved by removing the APE tag which was also present. However, I needed to open it up in Mp3tag to see the presence of the APE tag, you wouldn't have seen it in Itunes or Foobar. What also worked was deleting all of the tag info using Tag&Rename and then re-adding either an ID3v1 or ID3v2 tag (or both) either manually, from the song title or with MusicBrainz Picard.

The other song, I experienced the same as you. Mp3tag reports Id3v1 and Id3v2 tags. I tried to delete just the Id3v1 tag but was unable to for some reason. When imported into a test library in Slimserver, I also saw the No Album, No Artist, No Genre behaviour that you see. I could resolve the problem by deleting all tag data and then running the song through MusicBrainz Picard - this seemed to overwrite whatever is causing the problem and the song then showed as expected in Slimserver. I will play around with this track a bit more and see if I can narrow down what is causing this - there must be something in the header info - possibly something is corrupted.

The short answer is that these problems can be corrected, but the easiest way is to delete all the tag info and reapply it. This could be a big job, depending on how many files you have affected. I would definitely look at something like MusicBrainz Picard which can semi-automate the process for you.

jmaynard
2007-08-24, 00:35
OK, good news, bad news...
The files with a genre that differed between iTunes and SS are fixed - did this by removing the APE tags*.
The files (such as the sample I FTP'd) showing no genre, no album, no artist etc (even though iTunes shows all fields) are still wrong - I suspect now the files are corrupted??

* removing the APE tags proved a bigger job than I imagined (and not just because there are 9000-ish files in my library). None of the software I have or was mentioned in this thread seemed able to delete this particular tag so I needed a trial version of Helium to do it (and it took almost a whole day!)

Anyway, thanks for all the support and suggestions...