PDA

View Full Version : Fedora 7



BlackWidower
2007-08-18, 22:53
I recently installed SlimServer on Fedora 7 and I have a major problem. I can't turn it on! I have tried 'service slimserver start' but the 'service' command don't exist, and I have tried 'slimserver.pl --daemon' but SE Linux blocks it even after I opened port 9000, which I understand is the SlimServer port.

So what do I do? Do I have to open more ports or is there something else?

Robin Bowes
2007-08-19, 04:28
BlackWidower wrote:
> I recently installed SlimServer on Fedora 7 and I have a major problem.
> I can't turn it on! I have tried 'service slimserver start' but the
> 'service' command don't exist, and I have tried 'slimserver.pl
> --daemon' but SE Linux blocks it even after I opened port 9000, which I
> understand is the SlimServer port.
>
> So what do I do? Do I have to open more ports or is there something
> else?

A search for SELinux on the wiki brings up this link:

http://wiki.slimdevices.com/index.cgi?RPM

This is the key paragraph:

configure selinux to allow the server to run:

# /usr/bin/chcon -R -t texrel_shlib_t /usr/local/slimserver/CPAN/arch


R.

Mark Miksis
2007-08-19, 09:09
I have tried 'service slimserver start' but the 'service' command don't exist

/sbin is probably not in your path. Try:
/sbin/service slimserver start

Robin Bowes
2007-08-19, 09:47
Fletch wrote:
> BlackWidower;221556 Wrote:
>> I have tried 'service slimserver start' but the 'service' command don't
>> exist
>
> /sbin is probably not in your path. Try:
> /sbin/service slimserver start

If service is not in your path, you are probably trying to run it as
non-root user.

Try logging in as root and running the "service slimserver start"
command again (after fixing up the SELinux thing)

R.

Mark Miksis
2007-08-19, 10:37
If service is not in your path, you are probably trying to run it as non-root user.

Or probably running "su" instead of "su -", or sudo without the -i option.

BlackWidower
2007-08-19, 13:12
Thanks a bunch yous guys. Your advice worked wonders.

MarkL
2007-10-21, 12:09
I recently installed SlimServer on Fedora 7

Same here, except I could already see slimserver was running with the "ps" command (and have now added /sbin to my path to get "service" to work [SE Linux is disabled]).

What I'm stuck on is the UI. After the Windows install the UI 'magically' appears in my browser, but I can't figure out how to get teh equivalent page on my Fedora system.

Any help?

MarkL
2007-10-21, 12:51
Can we get a dope slap over here? ;-)