View Full Version : SB3 developed a firmware problem ?

2007-08-15, 22:47
My SB3 has been running fine for a couple of years. In the last few days its stuck with the "Connecting to..." message and never completes boot. Nothing has changed on the server, no software upgrade and no firmware upgrade on the SB. (Its currently running firmware v28 as far as I can tell).

tcpdump on the server shows that it actually does establish a TCP connection and runs a lot of traffic over it, but the message on the screen doesn't change. Strangely, the server believes that the SB3 is up and running, and lets me control it, send tracks to be played, etc. Obviously, the SB3 ignores them and remains stuck.

I tried the latest stable server on a vanilla debian box, just in case my server is somehow corrupted. The server detected that the player was running an old firmware (28) and suggested that I upgrade it by pressing the brightness button, but the button did nothing and the display remained stuck with the "Connecting..." message, just like it does with the old server.

I also tried to connect it to SqueezeNetwork and got a similar result: It establishes a connection to (squeezenetwork) and runs a lot of traffic but remains frozen with the "Connecting..." message.

Anyone experienced a similar problem or has a suggestion on debugging it ?

2007-08-17, 18:07
Is there a way to completely reset the SB3 unit and get everything back to the factory defaults ?

2007-08-18, 01:17
Unplug the squeezebox, count to 3 (because I am superstitious), plug it back in, and hold the ADD button on the remote.

That will reset it to factory defaults.

2007-08-18, 12:33
Thanks for the ADD tip. In the meantime, I found the problem and have a workaround. Apparently, its a strange network problem. I noticed that the SB traffic has a lot of retransmits so I tried to lower the MTU on the server's side and the problem disappears when MTU<650. With 650<MTU<800, I get a varying percent of packet-loss, and with MTU>800 it loses so many packets it fails to finish initializing. Strangely, I don't have that problem between other hosts on my network so it may be a connector problem on the SB side, creating noise that messes long packets. (Already changed the cable). For now I'll just use MTU=600 and be able to listen to some music (delivered in the form of somewhat short TCP packets). :)