PDA

View Full Version : Scanning Music



glen66
2007-08-13, 12:55
Hi All

Been a Slimserver user for a while, and just taken the plunge in to Linux.

I've got a directory with music in it, with varying owner permission and groups. Slimserver does not want to scan it.

How does slimserver run under linux, and how do I get it to read all the directories in a tree?

I'm pretty sure it's the group settings on the tree, but I don't want to change them as they are set up for samba.

Thanks in advance

Glen

snarlydwarf
2007-08-13, 13:13
On most systems it runs as the user named 'slimserver'.

What I do: all music is owned by me ('bem'), and I can mangle it as I see fit.

Samba is set to save things so that anyone local can read it:


[homes]
...
writable = yes
create mask = 0755
directory mask = 0755


That makes it so that new files and directories are readable by others (but not writeable), including the Slimserver user.

With a setup like this you can draganddrop files from windows and Slimserver will be happy with it, but it can't alter them (which is fine, since it shouldn't do that anyway).

You would have to change the permissions on your music directory:

find music-directory -type f -exec chmod 644 {}\;
find music-directory -type d -exec chmod 755 {}\;

That will make files under music-directory readable by all, and directories read/exec by all (you need the exec bit set on directories).

glen66
2007-08-13, 13:28
Hi

Thanks for the help, fixed it by adding the user slimserver to the existing music group.

Still learning the ins and outs of linux!

Cheers

Glen

TimK
2007-08-18, 18:47
I'm having the same problem as glen66. Unfortunately, the fix is not so simple for me: my music is in FLAC format and lives in a directory on a USB-attached external hard drive, which is formatted as FAT32/VFAT/whatever the heck (I can't keep them straight). A look at permissions suggests that that may well be the problem, but there is no way to set permissions on VFAT files and directories. Any suggestions, short of moving the music (it's over 200 GB and I don't have anywhere else to put it)?

Thanks,
Tim

SlowBart
2007-09-16, 21:12
A look at permissions suggests that that may well be the problem, but there is no way to set permissions on VFAT files and directories. Any suggestions, short of moving the music (it's over 200 GB and I don't have anywhere else to put it)?

Thanks,
Tim

You can set permission for the VFAT partition when you mount it. Have a look at the umask option for the mount command. You should be able to included that in your /etc/fstab entry.

Sorry I can't give you the exact command, been years since I did it ...

Cheers,
Matt.