View Full Version : Wireless IP address

2007-08-11, 18:08
Have a wireless connection problem. Have a SB2 which was up & running OK on wireless.

Was having a connection problem elsewhere on my network & swithched from static IP to DCHP. Once problem was resolved, I changed back to static IP.

Now SB won't connect. Tried with cable & static IP & all OK. When connect wirelessly no ball. Tried factory reset but basically it never connects to the specified network.

Am baffled as can't see anything that has changed.

One thing I am unsure of: when I connect with cable I can specify an IP address. When I connect by wireless (even after factory reset) I get no option to enter IP address....how do I get this option to appear again...?

All help appreciated!

2007-09-06, 13:39
Does noone use static IP with wireless connection?

2007-09-06, 13:44
Sure, a lot of people use static IPs and wireless. Try pressing and holding the left arrow button. That should take you into network setup, where you can specify the required network info such as server IP, player IP, DNS server, gateway, etc.

2007-09-06, 14:44
Thanks for reply....

As the tone of my second post above might imply, I have been pulling my hair out over this one!

Finally got things working again this evening....quite by chance.

I went back to square one, turning off encryption, turning on SSID etc all to no avail. Then I happened to be reading an earlier post regarding what is written on the base of the SB re: SB1 / SB2.

Then......went back looking through the info page on my SB2 which was refusing to connect, and saw the MAC address. Now having just looked at the label on the base of my SB, I realised it was not the same address. I changed it & hey presto all the problems have gone away.

I have no idea how it changed originally (didn't even know it could be -thought this was hard coded into a device?).

So posted this info in case anyone has similar symptoms: i.e. SB appears to simply not connect with the wireless connection. I don't understnd why the MAC address would prevent a connection anyway -maybe someone else can explain!! Suffice to say I now have my SB1, SB2 and SB3 all up & running again.....!!

Note: I am NOT using any fancy security i.e. restricting access through the router by MAC address

2007-09-06, 17:54
Glad to hear you got it sorted out. From time to time Squeezeboxes do forget their MAC addresses, which can cause various problems. Why this happens still seems to be a bit of a mystery.