PDA

View Full Version : Linking to a networked drive



Nick Walker
2004-01-13, 03:15
Have you tried mapping a drive ?

Instead of the UNC map a drive letter and try that.

... Nick

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Ken Veasey
Sent: 12 January 2004 20:06
To: Slim Devices Discussion
Subject: [slim] Linking to a networked drive

Switched into my dayghter's user on the XP machine and had no problem
accessing the folder on the other system, but still no joy with
Slimserver from her user either.

Ken

On Mon, 12 Jan 2004 10:17:14 -0800, you wrote:

>Can you double check that any account can read the file?
>
>On Jan 12, 2004, at 9:58 AM, Ken Veasey wrote:
>
>> Thanks dean,
>>
>> I started out with a shortcut which didn't work. So I tried specifying
>> the directory as the location for my music folder and got the
>> following response:
>> New value for Your Music Folder rejected:
>>
>> Oops - "\\denise\slimware" doesn't seem to be a valid directory. Try
>> again.
>>
>> If I set up a shortcut on my XP desktop of \\denise\slimware it
>> happily opens up the folder on the networked system!!
>>
>> Ken
>>
>>
>> On Mon, 12 Jan 2004 09:20:40 -0800, you wrote:
>>
>>> Hi Ken,
>>>
>>> Did you create a shortcut or did you specify the shared path in the
>>> server settings directly?
>>>
>>> Whichever you did, can you try the other? Also, be sure to use UNC
>>> paths: \\server\share
>>>
>>> -dean
>>>
>>> On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:
>>>
>>>> Dean,
>>>>
>>>> Thanks for your speedy response. I have made sure that the folder on
>>>> the networked system is shared. The share is for all users and it
>>>> being on a W98 system I presume security is not a high level affair
>>>> anyway.
>>>>
>>>> If I browse my Music Folder in Slimserver I see the link to the
>>>> folder
>>>> on the remote drive but when I click on the link I get the following
>>>> message: You need to specify a path to your directory containing
>>>> your
>>>> MP3 files.
>>>>
>>>> Any more ideas?
>>>>
>>>> Ken
>>>>
>>>>
>>>> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>>>>
>>>>> This kind of problem is usually caused by permissions not being
>>>>> correct
>>>>> on the shared folder. The SlimServer runs, by default, as the
>>>>> System
>>>>> user, not as your personal account. Make sure that the shared
>>>>> folder
>>>>> can be read by everyone and that should fix your issue.
>>>>>
>>>>> -dean
>>>>>
>>>>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>>>>
>>>>>> I'm having trouble setting up a working link to a networked drive.
>>>>>>
>>>>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>>>>> build from 26 December .The bulk of my music files are on the D
>>>>>> drive
>>>>>> which is just a partition on the main disc. In addition I have some
>>>>>> music on the C drive and shortcuts to these work fine when dropped
>>>>>> into the Music Folder on the D drive.
>>>>>>
>>>>>> But with my expanding collection I wanted for at least the short
>>>>>> term
>>>>>> to store some music on a separate PC which is running W98 SE. I
>>>>>> have
>>>>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>>>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>>>>> folder on that drive to work in slimserver. I have tried both
>>>>>> styles
>>>>>> of specifying the directory i.e Z:\path and \\Server\path and
>>>>>> whilst
>>>>>> within windows the link works, slimserver doesn't like it.
>>>>>>
>>>>>> Equally, attempts, as an experiment to specify the directory on the
>>>>>> networked drive as the music folder met with no luck whichever of
>>>>>> the
>>>>>> two formats of pathname I use. This is a bit disconcerting as I was
>>>>>> thinking about getting a snap server to store my music on, but
>>>>>> will I
>>>>>> be able to successfully map to it in a way that satisfies
>>>>>> slimserver.
>>>>>>
>>>>>> Any ideas?
>>>>>>
>>>>>>
>>>>>> Ken Veasey
>>>>>>
>>>>>>
>>>>>>

Bob Myers
2004-01-13, 09:57
I have this problem too. "This problem" being that SlimServer refuses
to accept a music directory on a machine other than where the server is
running.

I've tried all possible combinations:

* UNC paths
* drive-mapped paths
* back slashes and forward slashes, doubling and quadrupling the back
slashes for extra fun
* place symbolic link ("shortcut") to network location in a local
folder

etc. etc.

The folder I am attempting to use is fully shared, and completely
accessible from the machine in question by other means such as Windows
Explorer.

This is not an urgent problem for me since currently I'm fine with the
server and music directory on the same machine, but perhaps it will help
track down Ken's problem.

--
Bob Myers

Nick Walker wrote on Tuesday, January 13, 2004 2:15 AM:

> Have you tried mapping a drive ?
>
> Instead of the UNC map a drive letter and try that.
>
> .. Nick
>

Ron Thigpen
2004-01-13, 10:11
Bob Myers wrote:

> I have this problem too. "This problem" being that SlimServer refuses
> to accept a music directory on a machine other than where the server is
> running.

I believe this problem is a result of the account under which the
SlimServer is running. The LocalSystem account cannot access any
resource, no matter how "fully shared", that is outside the bounds of
that physical box. To access any network resource, the SlimServer must
be run under a user account created for this purpose.

I'd imagine most users would want to run the SlimServer as a service.

A recipe:
================================================== =============
Create User Account for SlimServer
Edit SlimServer service properties to log in to this account
Create share for music directory
Set share permissions such that the SlimServer account can read
Optionally, for convenience, map a network drive to the share
Optionally, log in to OS using SlimServer account and test share access
Stop and restart the SlimServer service
Test results
================================================== =============

--rt
--

T
2004-01-13, 11:17
> A recipe:
> ================================================== =============
> Create User Account for SlimServer
> Edit SlimServer service properties to log in to this account
> Create share for music directory
> Set share permissions such that the SlimServer account can read
> Optionally, for convenience, map a network drive to the share
> Optionally, log in to OS using SlimServer account and test share access
> Stop and restart the SlimServer service
> Test results
> ================================================== =============

Thanks, Ron.

I've been running it as a program rather than a service due to problems
finding the shared folders, so I followed your recipe, it it's now working
fine as a service.

So, for those others running XP, this is what I did:

Go to Settings>ControlPanel>UserAccounts and create a user 'SlimServer'.

Settings>ControlPanel>AdministrativeTools>Services

Double-click on service 'SlimServer'

Click on LogOn tab.

'Log on as:' check 'this account', and set account to the newly created
'SlimServer'.

Reboot.

Done.


Tom