PDA

View Full Version : Squeezebox Halts Playing Large File



robbiex
2007-08-07, 15:15
We have SlimServer 6.5.4 - 12487 running under Windows Server 2008 build 6001 on a Dell PowerEdge 1800.
SlimServer installed without problems and a music library with .wav or .flac files plays properly using SoftSqueeze. We have one long file that is about 1 GB in size with .wav and about 550MB with .flac encoding. This file plays perfectly with SoftSqueeze, but consistently fails with the Squeezebox after about 10 minutes of playing the music. The Squeezebox is directly Ethernet connected (no wireless) and all other functions work properly including playing albums ripped from CDs and encoded as .wav or .flac. Internet radio also works properly.
Thank you very much for your assistance.
Robert Robinson

Mark Lanctot
2007-08-08, 06:25
This file plays perfectly with SoftSqueeze, but consistently fails with the Squeezebox after about 10 minutes of playing the music.

"Fails" in what way? The music stops or an error message comes up on the screen or the screen goes blank and the player reboots?

robbiex
2007-08-08, 08:16
Hi Sean,
Thank you very much for the reply.
The Squeezebox just displayed the message "Stop".
No error messages were seen in the computer's event log at the time that the Squeezebox stopped playing the audio. Pressing Play on the Squeezebox resulted in the audio resuming from the start of the file.
Ripped CD music and Internet streams play properly on the Squeezebox and the 550MB FLAC file that repeatedly stops at about 10 minutes into the recording plays properly with SoftSqueeze, VLC and Samplitude on the server.
The audio file was originally recorded and edited using Samplitude and it is possible that there is something in the edited audio that results in the Squeezebox stop. There are no known problems with the hardwired Ethernet. It works properly with multiple other applications.
Robbie

Mark Lanctot
2007-08-08, 08:49
Sounds like the FLAC file might have a stream error. Does it stop in the same place?

foobar will indicate when there's a stream error.

In SlimServer, go to Server Settings - Debugging - d_source. Play the file until it stops. Then go to the last word "here" of the paragraph at the top of the Debugging page, copy and paste the log here.

robbiex
2007-08-08, 10:47
Hi Mark,

Thank you very much for your assistance.
Foobar plays the file with no errors.
FLAC FrontEnd "test" also reports no errors.
A portion of the SlimServer log is attached. I didn't include the whole file because it is lengthy.

Robbie

robbiex
2007-08-08, 17:37
The problem appears to have been resolved. There was an intermittent IP conflict. Resolving this seems to have eliminated the Squeezebox halts. No halts occurred with two loops through the 90 minute long stream so hopefully the system is now functioning properly.
My thanks to all for your assistance.
Robbie