View Full Version : No sound out of asx stream Need Help!

2007-08-04, 00:56
I am trying to get www.god.tv to stream audio to my squeezebox 3. I am running the latest slim software and filmware. The url is http://www.god.tv/Media/GODTV-USA.asx Squeezebox recognizes it, but no audio. I tried URL snooper and got this link. mms://godtv.streamsvr.com/godtv-usa and still no audio. Can someone help me out on this? Thanks

2007-08-04, 01:54
It's a video stream so SB3 cannot handle by itself - under Server Setting/Filetypes - uncheck "wma (built-in)" and then try again. The stream plays (eventually) on my Linux systems - don't know about Windows.

If you are on a Linux, OSX or NAS platforms - then you may need to install additional s/w/ to decode the WMA stream on the slimserver.

2007-08-04, 08:50
When I uncheck "wma" (built in) squeezebox tries to connect, but stops eventually. When I enable "wma" I get an error message for trying to open the file. Any more options can I try? Do I need to install a plugin? I am running Windows XP by the way. Thanks

2007-08-04, 12:02
How did you get the stream to work on your linux system? Do you know what software is needed to make it work? Thanks

2007-08-04, 12:39
I use mplayer on Linux because there are no Windows libraries. On Windows the normal Windows support app is wmadec which uses MS Windows libraries.

One solution for you would be to update the slimserver conf setting to use mplayer instead of wmadec and uncheck "wma (built-in)" - however this has side effects such as possible problems with some file names of WMA files, extra load decoding WMA in the server.

Awhile back I created a plugin for SS 6.3 to enable users to use mplayer for specific streams and bypass the Slimserver parsing. If I can resurrect it and make it work under 6.5, it would be a better solution for you as all your WMA files and streams would be handled normally and mplayer would only be used for designated streams such as Godtv.

Before I do anything - are you sure the video stream is the one you want to play as audio only ? Does the station not have an audio only stream ?

2007-08-04, 13:19
GodTV only has a video stream and also a TVU video stream that only works in Internet Explorer. I really only care about the audio aspect not the video. If you could make this work that would be great. Thanks a bunch.

2007-08-04, 15:28
This is a Windows only install for Slimsever 6.5.x.

Attached is a zip file called Generic. Unzip and drop the Generic folder into the Plugins directory so that in Plugins there is a folder called Generic.

Restart Slimserver - check under Server Setting / File Types and you should have 3 entries for Mplayer.

Install mplayer executable in the Slimserver Bin directory - such as the default:
C:\Program Files\Slimserver\server\Bin\MSWin32-x86-multi-threadBin/
Any easy way to install mplayer in the right play is to install AlienBBC using this installer

To use:
prefix any desired URL by "mply://" and the URL (stripped of mply://) will be passed to mplayer bypassing any processing by Slimserver. Example to play the GodTV URL paste the following URL into the Tune-in box.

The settings in the custom-convert.conf means that playlists cannot be used.

Be aware - when playing mplayer will download both video and audio streams so there will be large amount of data on your internet link.

FYI - On the UK GodTV site there is an audio only stream.

2007-08-04, 16:46
When I try BBC stations I get the message "error no item found in the playlists" I copied and pasted mply://mms://godtv.streamsvr.com/godtv-usa and got a message "error can't connect to retrieve playlists" Do I need to disable the playlist? Is there something that I left out?

2007-08-04, 17:07
Nothing else needs to be done.

The error message sounds like you have a network problems.

Can you get a debug log with d_source, d_plugins and d_parse and then try the mply:// URL.

2007-08-04, 18:35
I realize now that I never had three entries for mplayer, so I uninstalled slim devices and reinstalled the folder and alienBCC, but I am running into the same problems. Do I need to restart the computer in order for mplayer to be recognized? The command prompt shows that mplayer works just fine for alienbcc. I will come back to this later tonight. Thanks for your time bpa. Much appeciated.

2007-08-04, 22:25
You were right! It was a network problem. I had the DNS server set manually instead of automatic. This fixed the problem. The stream sounds great and I couldn't be happier. Thanks a bunch!