View Full Version : AlienBBC

2007-07-31, 06:57

I've just installed AlienBBC, and can't get it to play a stream. It tries to ceonnect and then I get the message "error: no file found in playlist". Having looked through the settings the only thing I can find is that there are no entries for rtsp on the file types settings page. I've looked in the convert.conf, and there are no entries for rtsp. In custom-convert.conf there is the following:

# Default for mplayer pre7 or later (note: -bandwidth 10000000 only works on recent pre8 builds)
rtsp wav * *
[mplayer] -really-quiet -vc null -vo null -bandwidth 10000000 -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$
rtsp mp3 * *
[mplayer] -really-quiet -vc null -vo null -bandwidth 10000000 -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
rtsp flc * *
[mplayer] -really-quiet -vc null -vo null -bandwidth 10000000 -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -

Anyone able to help?


2007-07-31, 07:14
It looks like you are using Windows ? Which version ?
What version of Slimserver are you running ?
Did you use the self-installed ".exe" or the zip file to install ?
Did you use the correct version of AlienBBC for the Slimserver you are running ? Check by examining the filename of the file you used to install AlienBBC.

The custom-convert.conf file is only applicable for slimserver 6.5.x and it should be in the Plugins/Alien folder. Is it ?

2007-07-31, 07:20
I'm running XP SP2, slimserver 6.5.3. I've installed AlienBBC 1.06 for 6.5/7.0 using the install file (exe) version. The custom.convert.conf is in the correct folder


2007-07-31, 07:23
AlienBBC doesn't get installed until you restarted Slimserver. Have you restarted Slimserver ?

Is there an AlienBBC menu on the main webpage or under Internet Radio on the SB ?

2007-07-31, 07:32
I've restarted slimserver and AlienBBC shows up where it should on both the SB and the slim server web interface. It all appears to work fine until I get the error message on the SB "no items found in playlist" I've followed the instructions on the AlienBBC site, including testing mplayer which worked fine, but it still doesn't play through the SB


2007-07-31, 07:38
Do you have the RTSP entries under Server/Filetypes ?
Are you playing to an SB2/3 or some other player ?

The BBC have been having some problems recently with their servers. Check by playing a live station such as R1 or R4.

2007-07-31, 07:40
I've been trying to play Radio 1 live mainly, but it also doesn't work for other stations. Haven't tried playing a listen again one yet. I'm playing to an SB3. The entries aren't there on the file tyes settings page

2007-07-31, 07:53
Missing RTSP entries means something wrong with installation. The most usual cause is the wrong version of .exe.
What is the name of the file you used to install AlienBBC ?

If it is OK then can you stop slimserver and then start Slimserver from the command prompt with the --d_plugins option enabled.

2007-07-31, 07:56
I used the file alienBBC-v1.06_6.5.exe. Will have to do the next bit tomorrow after work. Thanks for your help so far

2007-08-01, 02:13
I've restarted slimserver as you said, nothing appears to have changed.

2007-08-01, 02:20
To find out what is happening at startup, can you open a command prompt window, cd to the slimserver directory and start slimserver with the --d_plugins option.

2007-08-01, 02:43
I've done that, the output is in the attached txt file. Thanks

2007-08-01, 03:20
I can't see anything obviously wrong - so here are my suggestions.

1. Do startup again but with --d_source and --d_parse as well. This will give more specific info about filetype which should include RTSP

2. Re-run AlienBBC install .exe again - just in case something odd happened first time.

3. Perhaps there is something odd with 6.5.3 - I'd have to check this out but I can't do it now.

2007-08-01, 04:07
I've now re-installed alienbbc, and the rtsp entries now show up on the file types page. The Flac and Wav options are checked, but if I check the mp3 option I get the following error message:

Required binary was not found: [mplayer] -really-quiet -vc null -vo null -bandwidth 10000000 -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -

When I try and use Alien BBC on the SB it now doesn't say "no items foind in playlist", but instead says "(connecting...)" and doesn't go any further or play anything.

The other 2 outputs are attached. Thank you

2007-08-01, 04:48
Good that the re-install fixed the missing RTSP problem although it is odd that it happened in the first place.

The first "error" is because you haven't "lame" installed but don't worry about this unless you are streaming to an SB1 or similar. Slimserver will use the RTSP->Flac which is fine.

The "connecting" problem is usually either
(i) socketwrapper.exe is not defined as trusted in your security app such as McAfee, Norton. For NOD32 you need to add it to the IMON page.
(ii) Increase the radio timeout value from 5 to about 40 under Server Setting/Network.

2007-08-01, 05:11

Not meaning to undermine bpa's comments, I had a very similar sounding issue as yours omk, and found that having lame.exe in the right place was indeed the answer.


2007-08-01, 05:35
bpa - I'd already put socketwrapper in as an exception on the IMON page of NOD32. I've increased the timeout, but it's made no difference

Simon - where does lame.exe need to be?



2007-08-01, 06:27
lame.exe is only required when sending as MP3 for example if you enable bit rate limiting.

lame.exe goes in the same directory as mplayer.exe.

Can you run slimserver from a command prompt. Then enable from slimserver web page d_source and d_parse and then select BBC R4 live from AlienBBC menu.

Copy the command prompt window log.

2007-08-01, 06:55
Here's the output from radio 4

2007-08-01, 07:13
For some reason you seem to be running an old version of socketwrapper and not the version shipped with final 6.5.3.

If you run socketwrapper.exe from a command prompt you will get a banner. Check that it is version 1.8 and has the "-d" Debug option.

If it is not version 1.8 - then you can replace by the latest version (1.10beta) below or else re-install 6.5.3

Don't forget to delete the NOD32 socketwrapper IMON entry and re-entry the new version.


2007-08-01, 07:45
Finally it's working! Thanks for all your help


2007-08-03, 05:30
Rather than start a new thread, I thought I'd post in here...

Whenever I try to open the BBC podcasts option within AlienBBC, I get a "No podcasts found" message, or something similar. I'm assuming it's a BBC problem (maybe they've moved or something) but can anyone let me know if it's working for them?


2007-08-03, 06:39
It might have been quicker to do a search first
This thread has the title
"Default AlienBBC Podcast No Programmes Found"

Try the patch in post #4

2007-08-03, 07:16
*hangs head in shame*