PDA

View Full Version : Linking to a networked drive



Ken Veasey
2004-01-12, 04:36
I'm having trouble setting up a working link to a networked drive.

I'm running the slimserver on XP Home Edition. I am using a nightly
build from 26 December .The bulk of my music files are on the D drive
which is just a partition on the main disc. In addition I have some
music on the C drive and shortcuts to these work fine when dropped
into the Music Folder on the D drive.

But with my expanding collection I wanted for at least the short term
to store some music on a separate PC which is running W98 SE. I have
no trouble seeing the remote drive in Network Neighbourhood or in
Explorer if I map the drive, but I can't get a shortcut to a music
folder on that drive to work in slimserver. I have tried both styles
of specifying the directory i.e Z:\path and \\Server\path and whilst
within windows the link works, slimserver doesn't like it.

Equally, attempts, as an experiment to specify the directory on the
networked drive as the music folder met with no luck whichever of the
two formats of pathname I use. This is a bit disconcerting as I was
thinking about getting a snap server to store my music on, but will I
be able to successfully map to it in a way that satisfies slimserver.

Any ideas?


Ken Veasey

dean
2004-01-12, 09:26
This kind of problem is usually caused by permissions not being correct
on the shared folder. The SlimServer runs, by default, as the System
user, not as your personal account. Make sure that the shared folder
can be read by everyone and that should fix your issue.

-dean

On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:

> I'm having trouble setting up a working link to a networked drive.
>
> I'm running the slimserver on XP Home Edition. I am using a nightly
> build from 26 December .The bulk of my music files are on the D drive
> which is just a partition on the main disc. In addition I have some
> music on the C drive and shortcuts to these work fine when dropped
> into the Music Folder on the D drive.
>
> But with my expanding collection I wanted for at least the short term
> to store some music on a separate PC which is running W98 SE. I have
> no trouble seeing the remote drive in Network Neighbourhood or in
> Explorer if I map the drive, but I can't get a shortcut to a music
> folder on that drive to work in slimserver. I have tried both styles
> of specifying the directory i.e Z:\path and \\Server\path and whilst
> within windows the link works, slimserver doesn't like it.
>
> Equally, attempts, as an experiment to specify the directory on the
> networked drive as the music folder met with no luck whichever of the
> two formats of pathname I use. This is a bit disconcerting as I was
> thinking about getting a snap server to store my music on, but will I
> be able to successfully map to it in a way that satisfies slimserver.
>
> Any ideas?
>
>
> Ken Veasey
>
>
>

Ken Veasey
2004-01-12, 09:53
Dean,

Thanks for your speedy response. I have made sure that the folder on
the networked system is shared. The share is for all users and it
being on a W98 system I presume security is not a high level affair
anyway.

If I browse my Music Folder in Slimserver I see the link to the folder
on the remote drive but when I click on the link I get the following
message: You need to specify a path to your directory containing your
MP3 files.

Any more ideas?

Ken


On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:

>This kind of problem is usually caused by permissions not being correct
>on the shared folder. The SlimServer runs, by default, as the System
>user, not as your personal account. Make sure that the shared folder
>can be read by everyone and that should fix your issue.
>
>-dean
>
>On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>
>> I'm having trouble setting up a working link to a networked drive.
>>
>> I'm running the slimserver on XP Home Edition. I am using a nightly
>> build from 26 December .The bulk of my music files are on the D drive
>> which is just a partition on the main disc. In addition I have some
>> music on the C drive and shortcuts to these work fine when dropped
>> into the Music Folder on the D drive.
>>
>> But with my expanding collection I wanted for at least the short term
>> to store some music on a separate PC which is running W98 SE. I have
>> no trouble seeing the remote drive in Network Neighbourhood or in
>> Explorer if I map the drive, but I can't get a shortcut to a music
>> folder on that drive to work in slimserver. I have tried both styles
>> of specifying the directory i.e Z:\path and \\Server\path and whilst
>> within windows the link works, slimserver doesn't like it.
>>
>> Equally, attempts, as an experiment to specify the directory on the
>> networked drive as the music folder met with no luck whichever of the
>> two formats of pathname I use. This is a bit disconcerting as I was
>> thinking about getting a snap server to store my music on, but will I
>> be able to successfully map to it in a way that satisfies slimserver.
>>
>> Any ideas?
>>
>>
>> Ken Veasey
>>
>>
>>

dean
2004-01-12, 10:20
Hi Ken,

Did you create a shortcut or did you specify the shared path in the
server settings directly?

Whichever you did, can you try the other? Also, be sure to use UNC
paths: \\server\share

-dean

On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:

> Dean,
>
> Thanks for your speedy response. I have made sure that the folder on
> the networked system is shared. The share is for all users and it
> being on a W98 system I presume security is not a high level affair
> anyway.
>
> If I browse my Music Folder in Slimserver I see the link to the folder
> on the remote drive but when I click on the link I get the following
> message: You need to specify a path to your directory containing your
> MP3 files.
>
> Any more ideas?
>
> Ken
>
>
> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>
>> This kind of problem is usually caused by permissions not being
>> correct
>> on the shared folder. The SlimServer runs, by default, as the System
>> user, not as your personal account. Make sure that the shared folder
>> can be read by everyone and that should fix your issue.
>>
>> -dean
>>
>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>
>>> I'm having trouble setting up a working link to a networked drive.
>>>
>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>> build from 26 December .The bulk of my music files are on the D drive
>>> which is just a partition on the main disc. In addition I have some
>>> music on the C drive and shortcuts to these work fine when dropped
>>> into the Music Folder on the D drive.
>>>
>>> But with my expanding collection I wanted for at least the short term
>>> to store some music on a separate PC which is running W98 SE. I have
>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>> folder on that drive to work in slimserver. I have tried both styles
>>> of specifying the directory i.e Z:\path and \\Server\path and whilst
>>> within windows the link works, slimserver doesn't like it.
>>>
>>> Equally, attempts, as an experiment to specify the directory on the
>>> networked drive as the music folder met with no luck whichever of the
>>> two formats of pathname I use. This is a bit disconcerting as I was
>>> thinking about getting a snap server to store my music on, but will I
>>> be able to successfully map to it in a way that satisfies slimserver.
>>>
>>> Any ideas?
>>>
>>>
>>> Ken Veasey
>>>
>>>
>>>

Ken Veasey
2004-01-12, 10:58
Thanks dean,

I started out with a shortcut which didn't work. So I tried specifying
the directory as the location for my music folder and got the
following response:
New value for Your Music Folder rejected:

Oops - "\\denise\slimware" doesn't seem to be a valid directory. Try
again.

If I set up a shortcut on my XP desktop of \\denise\slimware it
happily opens up the folder on the networked system!!

Ken


On Mon, 12 Jan 2004 09:20:40 -0800, you wrote:

>Hi Ken,
>
>Did you create a shortcut or did you specify the shared path in the
>server settings directly?
>
>Whichever you did, can you try the other? Also, be sure to use UNC
>paths: \\server\share
>
>-dean
>
>On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:
>
>> Dean,
>>
>> Thanks for your speedy response. I have made sure that the folder on
>> the networked system is shared. The share is for all users and it
>> being on a W98 system I presume security is not a high level affair
>> anyway.
>>
>> If I browse my Music Folder in Slimserver I see the link to the folder
>> on the remote drive but when I click on the link I get the following
>> message: You need to specify a path to your directory containing your
>> MP3 files.
>>
>> Any more ideas?
>>
>> Ken
>>
>>
>> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>>
>>> This kind of problem is usually caused by permissions not being
>>> correct
>>> on the shared folder. The SlimServer runs, by default, as the System
>>> user, not as your personal account. Make sure that the shared folder
>>> can be read by everyone and that should fix your issue.
>>>
>>> -dean
>>>
>>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>>
>>>> I'm having trouble setting up a working link to a networked drive.
>>>>
>>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>>> build from 26 December .The bulk of my music files are on the D drive
>>>> which is just a partition on the main disc. In addition I have some
>>>> music on the C drive and shortcuts to these work fine when dropped
>>>> into the Music Folder on the D drive.
>>>>
>>>> But with my expanding collection I wanted for at least the short term
>>>> to store some music on a separate PC which is running W98 SE. I have
>>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>>> folder on that drive to work in slimserver. I have tried both styles
>>>> of specifying the directory i.e Z:\path and \\Server\path and whilst
>>>> within windows the link works, slimserver doesn't like it.
>>>>
>>>> Equally, attempts, as an experiment to specify the directory on the
>>>> networked drive as the music folder met with no luck whichever of the
>>>> two formats of pathname I use. This is a bit disconcerting as I was
>>>> thinking about getting a snap server to store my music on, but will I
>>>> be able to successfully map to it in a way that satisfies slimserver.
>>>>
>>>> Any ideas?
>>>>
>>>>
>>>> Ken Veasey
>>>>
>>>>
>>>>

dean
2004-01-12, 11:17
Can you double check that any account can read the file?

On Jan 12, 2004, at 9:58 AM, Ken Veasey wrote:

> Thanks dean,
>
> I started out with a shortcut which didn't work. So I tried specifying
> the directory as the location for my music folder and got the
> following response:
> New value for Your Music Folder rejected:
>
> Oops - "\\denise\slimware" doesn't seem to be a valid directory. Try
> again.
>
> If I set up a shortcut on my XP desktop of \\denise\slimware it
> happily opens up the folder on the networked system!!
>
> Ken
>
>
> On Mon, 12 Jan 2004 09:20:40 -0800, you wrote:
>
>> Hi Ken,
>>
>> Did you create a shortcut or did you specify the shared path in the
>> server settings directly?
>>
>> Whichever you did, can you try the other? Also, be sure to use UNC
>> paths: \\server\share
>>
>> -dean
>>
>> On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:
>>
>>> Dean,
>>>
>>> Thanks for your speedy response. I have made sure that the folder on
>>> the networked system is shared. The share is for all users and it
>>> being on a W98 system I presume security is not a high level affair
>>> anyway.
>>>
>>> If I browse my Music Folder in Slimserver I see the link to the
>>> folder
>>> on the remote drive but when I click on the link I get the following
>>> message: You need to specify a path to your directory containing
>>> your
>>> MP3 files.
>>>
>>> Any more ideas?
>>>
>>> Ken
>>>
>>>
>>> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>>>
>>>> This kind of problem is usually caused by permissions not being
>>>> correct
>>>> on the shared folder. The SlimServer runs, by default, as the
>>>> System
>>>> user, not as your personal account. Make sure that the shared
>>>> folder
>>>> can be read by everyone and that should fix your issue.
>>>>
>>>> -dean
>>>>
>>>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>>>
>>>>> I'm having trouble setting up a working link to a networked drive.
>>>>>
>>>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>>>> build from 26 December .The bulk of my music files are on the D
>>>>> drive
>>>>> which is just a partition on the main disc. In addition I have some
>>>>> music on the C drive and shortcuts to these work fine when dropped
>>>>> into the Music Folder on the D drive.
>>>>>
>>>>> But with my expanding collection I wanted for at least the short
>>>>> term
>>>>> to store some music on a separate PC which is running W98 SE. I
>>>>> have
>>>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>>>> folder on that drive to work in slimserver. I have tried both
>>>>> styles
>>>>> of specifying the directory i.e Z:\path and \\Server\path and
>>>>> whilst
>>>>> within windows the link works, slimserver doesn't like it.
>>>>>
>>>>> Equally, attempts, as an experiment to specify the directory on the
>>>>> networked drive as the music folder met with no luck whichever of
>>>>> the
>>>>> two formats of pathname I use. This is a bit disconcerting as I was
>>>>> thinking about getting a snap server to store my music on, but
>>>>> will I
>>>>> be able to successfully map to it in a way that satisfies
>>>>> slimserver.
>>>>>
>>>>> Any ideas?
>>>>>
>>>>>
>>>>> Ken Veasey
>>>>>
>>>>>
>>>>>

Ken Veasey
2004-01-12, 13:06
Switched into my dayghter's user on the XP machine and had no problem
accessing the folder on the other system, but still no joy with
Slimserver from her user either.

Ken

On Mon, 12 Jan 2004 10:17:14 -0800, you wrote:

>Can you double check that any account can read the file?
>
>On Jan 12, 2004, at 9:58 AM, Ken Veasey wrote:
>
>> Thanks dean,
>>
>> I started out with a shortcut which didn't work. So I tried specifying
>> the directory as the location for my music folder and got the
>> following response:
>> New value for Your Music Folder rejected:
>>
>> Oops - "\\denise\slimware" doesn't seem to be a valid directory. Try
>> again.
>>
>> If I set up a shortcut on my XP desktop of \\denise\slimware it
>> happily opens up the folder on the networked system!!
>>
>> Ken
>>
>>
>> On Mon, 12 Jan 2004 09:20:40 -0800, you wrote:
>>
>>> Hi Ken,
>>>
>>> Did you create a shortcut or did you specify the shared path in the
>>> server settings directly?
>>>
>>> Whichever you did, can you try the other? Also, be sure to use UNC
>>> paths: \\server\share
>>>
>>> -dean
>>>
>>> On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:
>>>
>>>> Dean,
>>>>
>>>> Thanks for your speedy response. I have made sure that the folder on
>>>> the networked system is shared. The share is for all users and it
>>>> being on a W98 system I presume security is not a high level affair
>>>> anyway.
>>>>
>>>> If I browse my Music Folder in Slimserver I see the link to the
>>>> folder
>>>> on the remote drive but when I click on the link I get the following
>>>> message: You need to specify a path to your directory containing
>>>> your
>>>> MP3 files.
>>>>
>>>> Any more ideas?
>>>>
>>>> Ken
>>>>
>>>>
>>>> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>>>>
>>>>> This kind of problem is usually caused by permissions not being
>>>>> correct
>>>>> on the shared folder. The SlimServer runs, by default, as the
>>>>> System
>>>>> user, not as your personal account. Make sure that the shared
>>>>> folder
>>>>> can be read by everyone and that should fix your issue.
>>>>>
>>>>> -dean
>>>>>
>>>>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>>>>
>>>>>> I'm having trouble setting up a working link to a networked drive.
>>>>>>
>>>>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>>>>> build from 26 December .The bulk of my music files are on the D
>>>>>> drive
>>>>>> which is just a partition on the main disc. In addition I have some
>>>>>> music on the C drive and shortcuts to these work fine when dropped
>>>>>> into the Music Folder on the D drive.
>>>>>>
>>>>>> But with my expanding collection I wanted for at least the short
>>>>>> term
>>>>>> to store some music on a separate PC which is running W98 SE. I
>>>>>> have
>>>>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>>>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>>>>> folder on that drive to work in slimserver. I have tried both
>>>>>> styles
>>>>>> of specifying the directory i.e Z:\path and \\Server\path and
>>>>>> whilst
>>>>>> within windows the link works, slimserver doesn't like it.
>>>>>>
>>>>>> Equally, attempts, as an experiment to specify the directory on the
>>>>>> networked drive as the music folder met with no luck whichever of
>>>>>> the
>>>>>> two formats of pathname I use. This is a bit disconcerting as I was
>>>>>> thinking about getting a snap server to store my music on, but
>>>>>> will I
>>>>>> be able to successfully map to it in a way that satisfies
>>>>>> slimserver.
>>>>>>
>>>>>> Any ideas?
>>>>>>
>>>>>>
>>>>>> Ken Veasey
>>>>>>
>>>>>>
>>>>>>

Ken Veasey
2004-01-13, 07:03
Hi Nick,

Yes I've tried that with a similar lack of success.

But could it be that as the slimserver runs as a system task, this
being on XP, and runs under the Local System user that the local
system user is not permitted to access stuff not on the home system.
If that is the case one option is to not run the server as a system
task but to instead run it under my user, but if that is the answer,
how do I persuade the server not to run as a system task?

Ken

On Tue, 13 Jan 2004 10:15:14 -0000, you wrote:

>Have you tried mapping a drive ?
>
>Instead of the UNC map a drive letter and try that.
>
>.. Nick
>
>-----Original Message-----
>From: discuss-bounces (AT) lists (DOT) slimdevices.com
>[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Ken Veasey
>Sent: 12 January 2004 20:06
>To: Slim Devices Discussion
>Subject: [slim] Linking to a networked drive
>
>Switched into my dayghter's user on the XP machine and had no problem
>accessing the folder on the other system, but still no joy with
>Slimserver from her user either.
>
>Ken
>
>On Mon, 12 Jan 2004 10:17:14 -0800, you wrote:
>
>>Can you double check that any account can read the file?
>>
>>On Jan 12, 2004, at 9:58 AM, Ken Veasey wrote:
>>
>>> Thanks dean,
>>>
>>> I started out with a shortcut which didn't work. So I tried specifying
>>> the directory as the location for my music folder and got the
>>> following response:
>>> New value for Your Music Folder rejected:
>>>
>>> Oops - "\\denise\slimware" doesn't seem to be a valid directory. Try
>>> again.
>>>
>>> If I set up a shortcut on my XP desktop of \\denise\slimware it
>>> happily opens up the folder on the networked system!!
>>>
>>> Ken
>>>
>>>
>>> On Mon, 12 Jan 2004 09:20:40 -0800, you wrote:
>>>
>>>> Hi Ken,
>>>>
>>>> Did you create a shortcut or did you specify the shared path in the
>>>> server settings directly?
>>>>
>>>> Whichever you did, can you try the other? Also, be sure to use UNC
>>>> paths: \\server\share
>>>>
>>>> -dean
>>>>
>>>> On Jan 12, 2004, at 8:53 AM, Ken Veasey wrote:
>>>>
>>>>> Dean,
>>>>>
>>>>> Thanks for your speedy response. I have made sure that the folder on
>>>>> the networked system is shared. The share is for all users and it
>>>>> being on a W98 system I presume security is not a high level affair
>>>>> anyway.
>>>>>
>>>>> If I browse my Music Folder in Slimserver I see the link to the
>>>>> folder
>>>>> on the remote drive but when I click on the link I get the following
>>>>> message: You need to specify a path to your directory containing
>>>>> your
>>>>> MP3 files.
>>>>>
>>>>> Any more ideas?
>>>>>
>>>>> Ken
>>>>>
>>>>>
>>>>> On Mon, 12 Jan 2004 08:26:07 -0800, you wrote:
>>>>>
>>>>>> This kind of problem is usually caused by permissions not being
>>>>>> correct
>>>>>> on the shared folder. The SlimServer runs, by default, as the
>>>>>> System
>>>>>> user, not as your personal account. Make sure that the shared
>>>>>> folder
>>>>>> can be read by everyone and that should fix your issue.
>>>>>>
>>>>>> -dean
>>>>>>
>>>>>> On Jan 12, 2004, at 3:36 AM, Ken Veasey wrote:
>>>>>>
>>>>>>> I'm having trouble setting up a working link to a networked drive.
>>>>>>>
>>>>>>> I'm running the slimserver on XP Home Edition. I am using a nightly
>>>>>>> build from 26 December .The bulk of my music files are on the D
>>>>>>> drive
>>>>>>> which is just a partition on the main disc. In addition I have some
>>>>>>> music on the C drive and shortcuts to these work fine when dropped
>>>>>>> into the Music Folder on the D drive.
>>>>>>>
>>>>>>> But with my expanding collection I wanted for at least the short
>>>>>>> term
>>>>>>> to store some music on a separate PC which is running W98 SE. I
>>>>>>> have
>>>>>>> no trouble seeing the remote drive in Network Neighbourhood or in
>>>>>>> Explorer if I map the drive, but I can't get a shortcut to a music
>>>>>>> folder on that drive to work in slimserver. I have tried both
>>>>>>> styles
>>>>>>> of specifying the directory i.e Z:\path and \\Server\path and
>>>>>>> whilst
>>>>>>> within windows the link works, slimserver doesn't like it.
>>>>>>>
>>>>>>> Equally, attempts, as an experiment to specify the directory on the
>>>>>>> networked drive as the music folder met with no luck whichever of
>>>>>>> the
>>>>>>> two formats of pathname I use. This is a bit disconcerting as I was
>>>>>>> thinking about getting a snap server to store my music on, but
>>>>>>> will I
>>>>>>> be able to successfully map to it in a way that satisfies
>>>>>>> slimserver.
>>>>>>>
>>>>>>> Any ideas?
>>>>>>>
>>>>>>>
>>>>>>> Ken Veasey
>>>>>>>
>>>>>>>
>>>>>>>

T
2004-01-13, 07:22
> But could it be that as the slimserver runs as a system task, this
> being on XP, and runs under the Local System user that the local
> system user is not permitted to access stuff not on the home system.
> If that is the case one option is to not run the server as a system
> task but to instead run it under my user, but if that is the answer,
> how do I persuade the server not to run as a system task?

Go to ControlPanel>AdministrativerTools>Services and set service SlimServer
to 'disabled'.

I never could get SlimServer to recognize all of my shared directories when
run as a service, so I run it as a normal program.

Tom

Ken Veasey
2004-01-13, 07:36
Thanks Tom,

Once the service was started under my own user it recognised the link
to the music on the networked drive.

Thanks to everyone for their assistance.

Ken


On Tue, 13 Jan 2004 15:22:42 +0100, you wrote:

>> But could it be that as the slimserver runs as a system task, this
>> being on XP, and runs under the Local System user that the local
>> system user is not permitted to access stuff not on the home system.
>> If that is the case one option is to not run the server as a system
>> task but to instead run it under my user, but if that is the answer,
>> how do I persuade the server not to run as a system task?
>
>Go to ControlPanel>AdministrativerTools>Services and set service SlimServer
>to 'disabled'.
>
>I never could get SlimServer to recognize all of my shared directories when
>run as a service, so I run it as a normal program.
>
>Tom
>
>
>