View Full Version : Can't access web interface - '404 Not found'...

2007-07-22, 14:35
Hi all,

After a fresh install of Ubuntu 7.04 and Slimserver 6.5.3, my Squeezebox sees the SS software, but I can't open the web interface!

I have tried the usual http://mypc:9000/ and also the ip address to no avail... Does anyone have any other ideas??



2007-07-22, 23:17
> After a fresh install of Ubuntu 7.04 and Slimserver 6.5.3, my
> Squeezebox sees the SS software, but I can't open the web interface!

If you've enabled the firewall in Ubuntu, make sure it doesn't lock port



http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

2007-07-23, 05:58
Thanks for the advice Michael, but I don't have a firewall installed.

It's so strange, as I was dual-booting 2 days ago with SS running fine on 7.04, I decided to go 'Ubuntu-solo' (ie get rid of XP) and after a whole new install (of doing everything exactly as it was before) it doesn't work. Weird eh?


2007-07-23, 08:40
can you access the web interface from a browser on the same box?

2007-07-23, 08:49
Nope, still get the 404 Not Found...

If I open system monitor, Slimserver is sitting there happily, my Squeezebox is displaying the time and date as usual, but I can't play music on it yet as I need to tell SS where the music is.

Doesn't make sense to me!


2007-07-23, 08:52
Ah, weird...

This is what happens when I run slimserver stop command in terminal:

2007-07-23 16:51:31.2653 ERROR: There is already another copy of the SlimServer running on this machine. (Address already in use)


2007-07-23, 09:22
This error message is associated with port 3483 being in use or slimserver cannot open it.

Is port 3483 TCP and UDP open in the firewall ?

Otherwise use netstat to see if there is another user of 3483 ?
I found sometime port 3483 are kept open if a Squeezebox or SoftSqueeze is still connected to PC - shut them down before starting slimserver next time.

2007-07-23, 11:09
Wow, thanks so much, thats sorted it.

I pulled the plug from the back of the Squeezebox and in the router settings re-allocated that port and after a reboot it has sorted itself out!

Thanks again, you guys really do know your stuff. I would still be messing around removing and reinstalling stuff right now if this forum wasn't here!!

MANY thanks,


2007-07-24, 12:15
I'm actually getting this exact problem, but I have not been able to fix it.

When I run slimserver (updated svn trunk) as myself, slimserver complains that it can't open a socket to 10002

[14:03:45.7921] Slim::Formats::RemoteStream::open (96) Can't open socket to [localhost:10002]: 111: Connection refused

Everything else seems to load properly, but I get a 404 error when trying to connect to the web interface.

So, I tried running slimserver as root (through sudo), but it bails with a permission problem

[14:09:05.9025] Slim::Utils::MySQLHelper::createConfig (184) Warning: /tmp/Cache/my.cnf: Permission denied at /usr/share/slimserver/Slim/Utils/MySQLHelper.pm line 184.

So, I tried changing permissions on the my.cnf file in /tmp/Cache, but then it doesn't work either, showing a bunch of these errors repeated:

Warning: World-writable config file '/tmp/Cache/my.cnf' is ignored

So, I tried pulling back the permissions and just changing ownership of the /tmp/Cache files to root, but that also failed.

I finally wiped /tmp/Cache and created the /tmp/Cache dir with 777 permissions, and then ran slimserver as sudo, but it's behavior is back to where I started-- a line complaining about getting a connection refused on port 10002, everything else appearing to load okay, but no web interface.

Anyone got any ideas where I'm screwing this up?