PDA

View Full Version : Slimserver is transcoding formats squeezebox should support natively



markjanssen
2007-07-22, 07:49
Hello,

I have a SB3 and I'm running slimserver 6.5.3 on debian. It all seems to work nicely, but I noticed that the slimserver is transcoding flac/ogg files to mp3 before streaming them to my Squeezebox. Is this 'normal' behaviour. I understood the SB was able to natively decode flac/ogg/wma/wav, so why is slimserver transcoding these files (wasting cpu-cycles, and reducing audio-quality).

What can I do to prevent this/make slimserver just transfer the on-disk flac/ogg files ?

Mark Lanctot
2007-07-22, 08:28
Server Options - File Types, uncheck FLAC -> MP3 and Ogg -> Mp3.

Also Player Settings - Audio - Bitrate Limiting, make sure it's set to "No Limit".

markjanssen
2007-07-22, 08:47
The bitrate-limiting change did the trick :)

WilCox
2007-07-22, 12:14
It all seems to work nicely, but I noticed that the slimserver is transcoding flac/ogg files to mp3 before streaming them to my Squeezebox.

Just curious -- how does one detect that files are being transcoded?

moley6knipe
2007-07-22, 12:24
you can't fast-forward or rewind them

kdf
2007-07-22, 12:33
The now playing section of the web interface should be showing
"converted to..." in the bitrate field.

You can also go into server settings -> debugging and select d_source,
then watch the log as you play files (there is a link at the end of the
block of text at the top of the debugging page.

-kdf

haunyack
2007-07-22, 14:06
The now playing section of the web interface should be showing
"converted to..." in the bitrate field.

-kdf

???
Don't see that, is there a switch somewhere to use that option?
I am using the default browser.


.

kdf
2007-07-22, 15:07
On 22-Jul-07, at 2:06 PM, haunyack wrote:

>
> kdf;216392 Wrote:
>> The now playing section of the web interface should be showing
>> "converted to..." in the bitrate field.
>>
>> -kdf
>
> ???
> Don't see that, is there a switch somewhere to use that option?
> I am using the default browser.

There is no switch. I think it may not show on the default skin, since
it doesn't show the bitrate. Fishbone skin is one that does.

Best place to look at WHY and when conversion is happening is the
d_source debugging. Make sure you have the right file type options
selected under server settings->file types, make sure the player
settings->audio is set for "no limit" on the bitrate limiting. Also,
make sure your "squeezebox" is SB2 or 3 as SB1 was only able to support
WAV and MP3, thus requiring transcoding from ogg.

-kdf

haunyack
2007-07-22, 15:12
On 22-Jul-07, at 2:06 PM, haunyack wrote:

>
> kdf;216392 Wrote:
>> The now playing section of the web interface should be showing
>> "converted to..." in the bitrate field.
>>
>> -kdf
>
> ???
> Don't see that, is there a switch somewhere to use that option?
> I am using the default browser.

There is no switch. I think it may not show on the default skin, since
it doesn't show the bitrate. Fishbone skin is one that does.

Best place to look at WHY and when conversion is happening is the
d_source debugging. Make sure you have the right file type options
selected under server settings->file types, make sure the player
settings->audio is set for "no limit" on the bitrate limiting. Also,
make sure your "squeezebox" is SB2 or 3 as SB1 was only able to support
WAV and MP3, thus requiring transcoding from ogg.

-kdf

Thanks.

.