View Full Version : unable to launch slimserver under mac osx

2007-07-20, 15:53
i'm gettign the following message :
/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim Launcher.app/Contents/Resources/Start Slim Server.sh: line 13: 100 Segmentation fault ./slimserver.pl --daemon --d_server --logfile ~/Library/Logs/slimserver.log >>~/Library/Logs/slimserver.log 2>&1
Jul 20 23:47:40 Patrick-2 ntpdate[117]: can't find host time.euro.apple.com\n
Jul 20 23:47:40 Patrick-2 ntpdate[117]: no servers can be used, exiting
Jul 20 23:47:42 Patrick-2 mDNSResponder: Adding browse domain local.
/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim Launcher.app/Contents/Resources/Start Slim Server.sh: line 13: 254 Segmentation fault ./slimserver.pl --daemon --d_server --logfile ~/Library/Logs/slimserver.log >>~/Library/Logs/slimserver.log 2>&1
any idea ? my internet connection works. thanks in advance

2007-07-21, 00:01
What version of OS X, what variety of Mac, what version of SlimServer?

And how are you starting SlimServer?

You have evidently got it set up run for all users. I have it set to run for one user only, and I am not sure of the options when it is set for all users.

But a quick guess from looking at the log (though I do not fully understand it) suggests to me that you have SlimServer set to run at startup and that it is doing so before an internet connection is set up (so you can't get date and time).

This might be a bug in SS, as I'm sure it should not worry about this.

But try setting it to run differently, say when a user logs in, and see what happens.

2007-07-21, 00:03
> i'm gettign the following message :

What SlimServer version, OS version, any additional plugins installed, did
anything work before, what have been the changes, etc.?


2007-07-21, 00:49
I've tried starting it up manually as well and that doesn't solve the problem

2007-07-21, 00:53
plugins : AlienBBC, LazySearch. all have been installed for a while. Slimserver started crashing down a couple of months ago, but now doesn't even start up. no changes to slimserver; but since I install the the Apple updates as they come, i don't know if one of these messed up slimserver (although I've reinstalled slimserver a couple of times since then to try and solve the problem). Maybe what's messed up is my Perl install, do you know how I can change that ? thanks a lot for trying to help.

2007-07-21, 02:48
/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim Launcher.app/Contents/Resources/Start Slim Server.sh: line 13: 243 Segmentation fault ./slimserver.pl --daemon --d_server --logfile ~/Library/Logs/slimserver.log >>~/Library/Logs/slimserver.log 2>&1
Jul 21 10:45:14 Patrick-2 crashdump[250]: perl crashed
Jul 21 10:45:14 Patrick-2 crashdump[250]: crash report written to: /Users/pictures/Library/Logs/CrashReporter/perl.crash.log

this report says :

Command: perl
Path: /usr/bin/perl
Parent: sh [237]

Version: ??? (???)

PID: 243
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xc2bcf3af

Thread 0 Crashed:
0 libperl.dylib 0x96c8262e Perl_pp_entersub + 2050
1 libperl.dylib 0x96c0bd72 Perl_call_sv + 1814
2 libperl.dylib 0x96c0c02d Perl_call_list + 640
3 libperl.dylib 0x96c46663 Perl_newATTRSUB + 3497
4 libperl.dylib 0x96c47326 Perl_utilize + 874
5 libperl.dylib 0x96c340f0 Perl_yyparse + 5428
6 libperl.dylib 0x96c09df8 S_parse_body + 3548
7 libperl.dylib 0x96c0cb65 perl_parse + 1084
8 perl 0x0000206a 0x1000 + 4202
9 perl 0x00001f56 0x1000 + 3926
10 perl 0x00001e71 0x1000 + 3697

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x0180de70 ebx: 0x96c81e3d ecx: 0x0180b324 edx: 0x0180263c
edi: 0x0180b330 esi: 0x01802a50 ebp: 0xbffff308 esp: 0xbffff230
ss: 0x0000001f efl: 0x00010202 eip: 0x96c8262e cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037

Binary Images Description:
0x1000 - 0x2fff perl /usr/bin/perl
0x8fe00000 - 0x8fe4afff dyld 46.12 /usr/lib/dyld
0x90000000 - 0x90171fff libSystem.B.dylib /usr/lib/libSystem.B.dylib
0x901c1000 - 0x901c3fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
0x90bd2000 - 0x90bd9fff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib
0x96c05000 - 0x96d19fff libperl.dylib /System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE/libperl.dylib

that doesn't say much to me ;-)

2007-07-21, 09:25
> that doesn't say much to me ;-)

To me neither. Remove the two plugins mentioned and try again.


2007-07-21, 10:00
I've removed the plugins and the server still doesn't start. I've removed slimserver entirely following another post's instructions, reinstalled without any plugins, no change.