PDA

View Full Version : Browse Years



SlimChances
2007-07-16, 08:26
Recently I tried to browse my collection using the Browse Year selection and found less than 50% of my MP3 tagged correctly with both ID 1 and 2 tags were recognized. I rescanned the hard drive and this made no difference. I then made a playlist of the albums I knew were of that year including ones not previously recognized. When I went back inot the Year the all the albums were there including ones not previously found. I would like to use the Browse year artist genre etc feaqure but if I can't find all my albums I don't see the use of these features. Is there any remedial action I can take.
I did do a search on the forum but after a few pages of non related threads gave up. Sorry if this has already been posted.

Siduhe
2007-07-16, 08:43
What is the format of your "YEAR" tag? TORY (Original release year) or TYER (Year) or TDRC (also Year).

If TDRC and you are using a Year value which is greater than 4 digits, then you may have the problem described here:

http://forums.slimdevices.com/showthread.php?t=36676&highlight=yyyy

Also, if your Id3v1 and Id3v2 year values are different in any way, that may cause Slimserver not to display the info. Maybe try finding an album that has this problem, open it up in a tagger with advanced options (like Mp3tag) and make sure it is a 4 figure value and the info is the same in both id3v1 and id3v2?

erland
2007-07-16, 08:45
Some questions:
1. Are you saying that the music files that are part of a playlist is recognised correctly and visible under Year, but a music file that isn't part of a playlist isn't recognised ?

2. Did you perform a rescan with "Clear library and rescan everything" or did you just rescan with "Look for new and changed music" ?

3. How does your SlimServer setup look, like ? More specifically how have you in "Server Settings" configured the parameters:
- MUSIC FOLDER
- ITUNES
- MUSICMAGIC

4. Which SlimServer version and operating system are you running SlimServer on ?

SlimChances
2007-07-16, 15:00
Al my years are entered as 4 digit entries unless by mistake otherwise. Not sure about how I discern the 3 different date formats although I use Dr. Tag to enter all tag info except for a few FLAC recordings(almost all of my collection is VBR MP3s)
In answer to erland:
1) I browsed by year for 1967 and found about 20 albums listed. I then rescanned my library and same result. I then made a playlist of nearly 40 albums I knew to be from 1967 (and did not alter any tags) the result was once the playlist was made and I returned to browse year 1967 all 40 albums appeared even though no changes to the tags were made. It is as though unless the album has been played before or identified by slimserver by some other means(ie playlist) than browsing by year they will not appear under browse year.
2)MUSIC FOLDER--F:\My Music
ITunes -- deselected
MusicMagic ---deselected
don't use the later 2 services
most of the server settings are default settings although I do have a few plugins (Lyrics,Superdate,Time (in words), Biography.
However I seem to recall the browse feature never seemed to bring up all entries even before I had 3rd party plugins

3)Win XP Pro
SlimServer Version: 6.5.1 - 11206 - Windows XP - EN - cp1252
Server IP address: 192.168.0.101
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt

erland
2007-07-16, 23:23
1. Is all your music stored somewhere below: F:\My Music ?
If setup like you have done, SlimServer will only detect music that is either:
- Found below F:\My Music
- Part of a playlist

2. Is it just the "Browse by Year" that doesn't work or do you have the same problem with "Browse by Genres" and "Browse by Artist" ?

3. When you perform a rescan in SlimServer it is possible to select tree different options:
- "Clear library and rescan everything"
- "Look for new and changed music"
- "Only rescan playlists"
The latter two can cause problems if your timestamps in the music files aren't updated correctly. So to be completely sure, unless you have already done so, I would perform a rescan with "Clear library and rescan everything"

SlimChances
2007-07-18, 12:42
Thank you for your reply.
Yes all my MP3s are located under F:\My Music. I classify within this by Artist, Genre, then album then song. I have always used my own file trees to find music because I have had trouble finding my music under slimserver's Browse options (artist, genre, year etc). I am right now clearing and rescanning and I will let you know my results later.
Thanks for your interest.

SlimChances
2007-07-18, 13:06
Erland
Yes you were quite right the recan had been set at "Look for new and changed music". I had assumed that any changes to tags would be reflected in this recan. The clear and rescan appears to be resolving my issues.
Thanks again,

I will give your plugin for Browsing a shot also, it looks to be very useful for tasks such as playing songs in a decade