PDA

View Full Version : Does not advance to next song in list



gcooper263
2007-07-15, 06:20
SlimServer Version: 6.5.3 - 12135 - Windows XP

Periodically my player will play to the end of a song and will not advance to the next song in the list. If I press stop and then play, it will replay the current song and then continue the current playlist properly, but later it might repeat this same behavior.

Rangdo
2007-07-15, 06:23
Couldn't be related to pausing near the end of the track at all, could it?

I get similar symptoms if I pause roughly 30 seconds before the end of a track, when I resume it'll play the rest of the track then nothing without skipping forward or stop/play.

btcompute
2007-07-15, 06:47
I get this same behavior. The current song ends, but the next one does not play.

Wireless signal strength seems fine.

It can happen when I'm home alone, so I know it is not caused by something that someone else in the house is doing.

My nearest neighbor is at least 200 feet away. It seems unlikely anything coming from that house (cordless phone, garage door opener, etc) would be causing this to occur.

SS version 6.5.3 - 12301 Windows XP

This has occured with a each of the more recent nightly updates I have installed.

Anyone have any thoughts about what might be causing this behavior?

Brian

Jeff52
2007-07-16, 06:40
Sounds similar to the problems noted in these threads:

http://forums.slimdevices.com/showthread.php?t=22963

http://forums.slimdevices.com/showthread.php?t=35969

I have experienced similar problems with the last few releases. My problem has always been solved by reverting to firmware v. 67 after installing the new releases. I have no idea why this hasn't been fixed.

luga00
2007-07-17, 04:25
Yes, this is now happening on our SB3 system and seems to have been introduced after installing 6.5.3.

Can someone tell me how to revert to an earlier firmware but keep 6.5.3?

I've searched but can't seem to find anything.

R

bpa
2007-07-17, 06:40
If you provide more details people may be able to try to reproduce the problem. I found some small bugs (bug #5094 & 5103) in relation to Pause near the end of track but they have been fixed in 6.5.3.

Information that would be useful:
- Slimserver version and build if a nightly build.
- format of the file being played
- what type of player ? wired/ wireless player ? wired or wireless server ?
- specific details such as long/short playlist, long/short files, first pause/ mulitple pauses, stop within x secs of end of track

luga00
2007-07-18, 01:56
6.5.3 - not sure what nightly.
Flac files
Usually happens on my daughters nursery rhyme album - around 24 songs quite short in length.
I can't tell when or where it stops as usually I come to the player and find it has already stopped somewhere in the album. Could be any track. Not sure if it's in the middle of a song or if it's just a track advance problem.
All my SB3's are wired using homeplugs.

bpa
2007-07-18, 02:47
luga00,

If they are v. short track (probably less then 1 min for flac) then it could be bug 5103 fixed in build 12211. You should check your build and if it is earlier - update.

luga00
2007-07-18, 03:32
Thanks, that's very good of you to let me know.

I'll give it a shot although I'm not sure the tracks are quite that short.

Luga

bpa
2007-07-18, 03:46
As I understand it, the issue was that SB cannot hold more than 2 track regardless of memory usage but I think Slimserver tries to push as many as possible.

Memory is usually the limiting factor but with small size tracks the 2 track limit can be breached. Your nursery rhymes may be highly compressed tracks with small memory requirement so so short time may not be the best measure.

btcompute
2007-07-18, 11:14
"If you provide more details people may be able to try to reproduce the problem. I found some small bugs (bug #5094 & 5103) in relation to Pause near the end of track but they have been fixed in 6.5.3."


When this problem occurs with my SB3, I am usually playing one album, usually 10 - 20 songs, all flac format.

I'm using SS version 6.5.3 - 12301 - Windows XP - EN - cp1252.

Never the result of pausing during a song. I rarely pause during a song, and the problem has not occured when I have.

The SB3(about 4 months old), is wirelessly connected via a Netgear wireless router.

Signal strength is consistantly 65% - 75%.

When the problem occurs, it always happens at the end of a song, and the next song does not start, but the playlist does show that there are more songs to be played.

As I have already mentioned, this can occur when nobody else is in the house, and I am not doing anything that might interefere with the signal. My closest neighbor is at least 200 feet from my house, and at least on a couple occasions, not home at the time.

I hope this provides enough info.

Thanks,

Brian

bpa
2007-07-18, 15:24
When playing next time - you could enable d_source debugging (server Setting/Debugging). When the unexpected track stop occurs - open the debug log window (use hyperlinked word "here" in the top LHS oif Setting/Debugging panel) and copy the last section of the log to a post.

d_source will give details about track starting and ending. The log should then give info why slimserver decided to stop playing the list.

btcompute
2007-07-18, 15:54
Thanks bpa,

I have turned on d_source logging.
Next time I experience the problem I'll post the log as you suggest.


Brian