View Full Version : Invalid Directory and other weirdness

2007-07-12, 09:44
I'm having all kinds of weird problems. Any insight or suggestions would be most appreciated.

There are a couple issues here, but they are all related ...

I just bought an Infrant ReadyNAS NV+. I have a library of about 15,000 files - mostly mp3 and m4a - that takes up about 120GB of space. The library is "owned" by an instance of iTunes running on a G4 Powerbook. I use iTunes on the Mac to manage the addition of new music to the file directory, to maintain the meta data and manage iPods.

Initially, I had thought I would run the embedded Slimserver on the ReadyNAS NV+ ... which I tried, but the menus were very sluggish and the lag to start up each track was painful. Rescans - which I do frequently to reflect changes made to the file directory by the Mac - were also painfully slow.

I decided to use a spare XP machine (older thinkpad with 1GB of memory and a 1.8 GHZ Pentium M) as the slimserver ... connected to the same GB switch as the NAS.

Problem 1 ... I updated the slimserver on the XP laptop to version 6.5.2 ... it had an older slimserver version installed that had previously scanned the network drives successfully, but was not being used. Slimserver had been set to scan the NAS directly via a mapped network drive. Following the update to 6.5.2, the first rescan after the update failed and threw an error that started "Oops, that directory is invalid." Since then, every instance of slimserver put on that machine refuses to accept any directory paths as valid that start with a drive letter.

Problem 2 ... so ... I decided to try and install iTunes on the laptop ... which went just fine. I scanned my files over the network (which - BTW - iTunes seemed to do MUCH faster than slimserver) and created a new iTunes library to which I successfully pointed the slimserver.

It was all working great. In fact, following the successful integration of the new iTunes library into slimserver, slimserver then even accepted my directory path for my playlists.

I should have quit ... but I didn't.

Because I wanted the slim library to reflect any changes to the file directory made daily, I needed a way to keep this new iTunes instance in sync with the directory ... I downloaded an app called iTunes Library Updater.exe (http://itlu.ownz.ch/wordpress/) ... I tested it out on a different instance of itunes on a different machine using the same file directory ... successfully. So I tried it out on the new instance of iTunes on the XP Laptop. It ran successfully, but at the end, it failed to save the iTunes library due to what looked like a memory error. I checked my system settings, and I had the memory set to prioritize system cache over programs. I had switched this because I thought it would help the slimserver performance on that box. Perhaps a mistake ... but I switched back to programs and iTunes was happy again and successfully saved its library.

BUT ... now Slimserver doesn't pick up anything when it scans the iTunes library.

So now I am at a total loss ... the slimserver refuses to recognize any directories as valid and when it scans the iTunes library it comes back with zero songs found ...

Any suggestions or assistance would be most appreciated!

2007-07-12, 11:29
Un-installed everything ... iTunes, QT, Slimserver ... deleted all directories ... deleted all registry keys related to all three ... un-mapped all network drives ...

Started over. Reinstalled slim first ... 6.5.3

Still refuses to recognize any directory as valid. Tried mapped drive. Tried UNC path with both IP address and server name ... no luck.

All I get is "Oops ... invalid directory".

Next tried iTunes. Rebuilt new library using UNC path and IP address successfully in iTunes. I point Slimserver at the new iTunes library. Scans and returns 0 albums.


2007-07-12, 14:10
So ... if I state that the music folder is a folder on my C: drive, that is acceptable as a valid directory.

If I put real files in there, it works and brings them into the library ... but that's no good as there is only 10GB free on the laptop.

If I put a shortcut to a file on the network drive into that folder, that also works ... but making and maintaining 15K shortcuts seems daunting.

Guess I'm talking to myself ...

2007-07-12, 14:17
New value for Music Folder rejected:

Oops - "// The Music In One Place" doesn't seem to be a valid directory. Try again.

Oh well.

2007-07-12, 14:33
The slashes go the other way on Windows.

Why? For arcane reasons, DOS used "/" as an option separator. (Like "dir /w" I think worked.) So the / was taken when DOS3.0 came out so they use backslashes for directory separators.

2007-07-12, 14:49
The slashes go the other way on Windows.

I believe SlimServer automatically changes them to backslashes when running on Windows.

2007-07-12, 14:57
I've tried everything ...

** Drive letters
** //name
** \\name
** //IP
** \\IP

I tried allowing the service to interact with the desktop.

I'm stumped.

2007-07-12, 15:08
Oops - "// The Music In One Place" doesn't seem to be a valid directory. Try again.

Been a long time since I messed with my Infrant NAS... I wonder if you're running into permission problems.

Whatever path you use in SlimServer should also work in Windows Explorer. Try entering the same path there first and see if you can access it. You should be able to browse around within the folder in Explorer almost as if it were a local folder. If it doesn't work, it might give you a little more information about why not.

2007-07-12, 15:27
I can access the Infrant using windows.

I can get there using the mapped drive or by opening the UNC path with start/run and poke around no problem.

Even weirder ... if I declare a folder on C: to be the music folder and put a shortcut to a file on the network drive, that gets read and put in the library. When I go look into the detailed info on such a file from within Slim web interface, it tells me it is located on the network and uses the drive letter to describe it.

The Infrant has no permissioning set. There is no user accounts or passwords on that volume at all.

Other instances of slimserver on the network - both XP and Vista and Mac have all successfully gotten to the NAS.

This XP box used to be able to get there ... until the upgrade to 6.5.2. The valid addresses were still in there from before the upgrade ... it was the first rescan after the upgrade that started the problems ...

2007-07-12, 15:35
What's even weirder is that it won't read the iTunes XML file anymore either.

I'd be happy to let iTunes do the scanning and then just read the results, but it comes back with zero results.

2007-07-12, 16:20
I went back and reread your original post. The big monkey wrench for me is that you're using iTunes, which I've never used, so I don't fully understand how SlimServer integrates with it. The way I thought it worked was that you left the SlimServer Music Folder blank, since all the data is picked up from the iTunes library.

What happens if you turn off iTunes integration altogether and then restart SlimServer? Will it allow the Infrant network path?

2007-07-12, 16:23
... I've tried both ways.

With iTunes - and there the problem is that it scans and comes back empty.

Without iTunes/Direct Scan - there the problem is that it won't accept the network path as valid.

I'm gonna try and install an older version of slimserver ... 6.3 or something.

2007-07-12, 16:31
Installing 6.3.1 had the exact same results.

Something is really wrong.

2007-07-13, 07:08
Is this anything to do with the fact that you have security setup on the NAS box. Slimserver runs as a local system service and will therefore get access denied when trying to view files on the NAS.

Have you tried configuring this to run with your account & password?

Not sure about ITunes interaction.

2007-07-13, 12:08
The NAS has no security setup ... and a different XP box was accessing it with slimserver just fine.

But I tried that anyway. I tried to set Slimserver to run as a Network service and also under my account.

When I set it as a network service, it started to startup and then would stop.

When I set it to run under my account it totally failed to start.