PDA

View Full Version : Album art - default behavior when there is no art...



st2000
2007-07-10, 16:35
Hi...
Was wondering if I am going mad. Trying to create a slimserver client that pulls album art. When slimserver finds a "cover.jpg" file in the same directory as the MP3s it all works very well :-)! However, I though the default behavior of slimserver was to pass along the default "cover.png" art work (a picture of a silver disk over a green field) when there was not any album artwork. But I don't think that is happening. I am not sure because my application doesn't take kindly to PNG files. Still, I don't think slimserver is giving me anything. So I turned my web browser at slimserver and asked for cover art. Well, what do you know. I randomly picked track IDs and not only pulled various album covers (as I expected) but also a default album cover call, of all things, "cover.jpg". What?? Not "cover.png"?? I don't get it. If it works with the web browser then it should work on my application. Can anyone explain this to me? I mean there isn't even a "cover.jpg" file on my computer.
...thanks

st2000
2007-07-10, 18:36
Hi...
Was wondering if I am going mad. Trying to create a slimserver client that pulls album art. When slimserver finds a "cover.jpg" file in the same directory as the MP3s it all works very well :-)! However, I though the default behavior of slimserver was to pass along the default "cover.png" art work (a picture of a silver disk over a green field) when there was not any album artwork. But I don't think that is happening. I am not sure because my application doesn't take kindly to PNG files. Still, I don't think slimserver is giving me anything. So I turned my web browser at slimserver and asked for cover art. Well, what do you know. I randomly picked track IDs and not only pulled various album covers (as I expected) but also a default album cover call, of all things, "cover.jpg". What?? Not "cover.png"?? I don't get it. If it works with the web browser then it should work on my application. Can anyone explain this to me? I mean there isn't even a "cover.jpg" file on my computer.
...thanks

Nasty nasty nasty... figured out why SlimServer does not work - but now the question: "Is this a SlimServer bug???"

Anyways, you do get the default album cover when you ask for a cover.jpg (well, at least with a web browser) using a track id tag that has no artwork associated with it. However, what appears to be a JPEG by name is really a PNG format image! Couldn't tell until I saved it and ran some tests on it.

So, is this a bug in SlimServer? Why does SlimServer even use PNG files? Can we switch to a JPEG default image file?

Here's the kicker - if you do ask for a file by the name "cover.png" you get back an error.