PDA

View Full Version : Problem w/ ffmpeg / WMA streams



flavor8
2007-07-08, 13:01
I tried to play both BBC World Service, and Air America, under Slim Picks / Genre / News & Talk. I get the following ffmpeg errors in /var/log/slimserver/slimserver.log.

----------
Encoding as 44.1 kHz 128 kbps stereo MPEG-1 Layer III (11x) qval=5
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-vorbis --enable-libogg --ena
ble-a52 --enable-dts --enable-libgsm --enable-dc1394 --disable-debug --enable-mp3lame --enable-faa
dbin --enable-faad --enable-faac --enable-xvid --enable-x264 --enable-amr_nb --enable-amr_wb --ena
ble-shared --prefix=/usr
libavutil version: 0d.49.0.0
libavcodec version: 0d.51.11.0
libavformat version: 0d.50.5.0
built on Mar 21 2007 14:14:05, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
: I/O error occured
Usually that means that input file is truncated and/or corrupted.
--------

I'm on Ubuntu feisty; in /etc/slimserver/custom-convert.conf, I have:

wma mp3 * *
[ffmpeg] -v 0 -i $FILES$ -f wave - | [lame] -x -m s -r -S -q 5 -s 44.1 - -


Slimserver is picking this up; before I had this line, I was getting WMA Convert errors on the player. Now, it just says "checking stream", pauses, and then switches back to the station name.

Any ideas? Thanks

bpa
2007-07-08, 13:08
The BBC WMA stations can take a very long time to connect - so increate the timeout (Server Setting/Network/Radio timeout I think) to something like 45 secs.

However, have you made sure that ffmpeg change works with a known good local WMA station.

In the US try a somafm station such as
http://somafm.com/groovesalad.asx

flavor8
2007-07-08, 13:46
Good ideas but unfortunately no dice. I get the same problems on both the groovesalad link and the BBC streams, even with the timeout increased.

bpa
2007-07-08, 14:27
I think ffmpeg only works with files and not streams. You should use mplayer instead but it needs different commands in the conf files.