View Full Version : More problems with Vista

2007-07-06, 00:42
My apologies for starting another thread but I have found wading through the stickied one unmanageable because of the volume of posts in it.

Anyway, I have just installed Vista Ultimate and I am having a lot of difficulty getting Slimserver to run. When I check services I find that SlimserverMySQL is running but slimsvc is shown as 'starting' and it never leaves this state.

I have set slim.exe, mysqld.exe, scanner.exe as having full privileges within my firewall (zonealarm btw).

I have worked my way through the stickied thread and have tried everything in there. But still the server is 'locked' in a starting state. I cannot even stop the service as Vista states that 'Access is denied'. Is there anything else I can try?

2007-07-06, 02:56
With the 6.5.2 and the latest 6.5.3 nightly releases you should not need to manipulate any of the service settings - the installer should do it. However I don't know how zonealarm impacts this.

Which version are you using? Have you tried to uninstall, leave for a minutes, then reinstall. [even after a service has been removed vista sometimes doesn't seem to like the same service to be reinstalled immediately]

2007-07-06, 14:15
Thanks for the reply, Triode.

I have tried uninstalling and then installing the latest nightly build, 20070706. The setup does not finish. I left it for about 30 minutes and the setup is showing a full progress bar but does not complete.

I load task manager and find that there are 3 program entries for the setup ... all listed as running. Under the services tab SlimserverMySql is showing as running but slimsvc is shown as starting. I get access denied messages if I attempt to prod the slimsvc service in any way.

I eventually killed the setup application. I will now try re-installing. I don't believe that will help. For some reason the server service appears to be hanging during startup. Is there some way to get diagnostics out of the server startup process so that we can try to identify the cause?

2007-07-06, 14:45
Does SlimTray have privileges for the firewall?

I would kill all applications / services and reboot. Then try to run SlimTray.exe (SlimServer from the menu). What happens?

If this does not work, open a cmd window cd to the directory containing slim.exe, run slim.exe manually and post any output it shows.

2007-07-07, 07:54
Things have got more confusing. As per my last post I tried re-installing ... without uninstalling first. Amazingly the installation routine ran through to completion when doing this and the server was shown as running when I checked it in task manager.

I still could not get slimtray to view the webpage nor my sb3's to access it. I have configured my firewall and router with all the settings I used under xp to allow access.

I then rebooted and the server was stuck at 'starting' again. After some hunting around I decided to switch off 'services and drivers' real-time protection in Windows Defender.

With that setting changed I can start and stop the server happily ... I just cannot access it. This is getting really frustrating now.

I will try starting slim.exe within a cmd window as you have suggested. I may also try disconnecting my router from the phone line and then switching off the firewall to see if that changes things.

2007-07-08, 02:49
Running slim.exe within a cmd window gives the following:

2007-07-08 10:44:44.4001 Use of uninitialized value in transliteration (tr///) a
t /<H:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 103, <DA
TA> line 164.
2007-07-08 10:44:44.4011 Use of uninitialized value in pattern match (m//) at /<
H:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 105, <DATA>
line 164.

It hangs without returning a command prompt and the server does not start.

2007-07-08, 03:36
Those messages can be ignored - I see them too.

Have you tried with the firewall disabled?

ok lets try some more debugging:

If you start the server with: slim.exe --perfwarn=0
Does it give a continuous list of activity (showing the server is running, its just you can't connect to it)

If so try starting the server with slim.exe --d_http
Do you see anything when you try to open a web browser to it.

Also what does starting with --d_mysql show?

2007-07-10, 06:52

Did this issue ever get resolved? I have an absolutely identical problem whereby initially the setup of Slimserver hung with the service in 'starting' mode. When I restarted setup (without uninstalling) it then completed and now appears to be running but I can't get to it with a web browser.

I am running Vista Ultimate on a Dell C521, tried to use 6.5.2 and 6.5.3 server software. I have tried it with ZoneAlarm and with Windows Firewall, all relevant ports are opened in TCP and UDP mode.

If I try to start the server from the command prompt as described, using the --perfwarn=0 switch I get the following:

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd \program files\slimserver\server

C:\Program Files\SlimServer\server>slim.exe --perfwarn=0
2007-07-10 09:49:18.0891 Use of uninitialized value in transliteration (tr///) a
t /<C:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 103, <DA
TA> line 164.
2007-07-10 09:49:18.0894 Use of uninitialized value in pattern match (m//) at /<
C:\Program Files\SlimServer\server\slim.exe>File/Spec/Win32.pm line 105, <DATA>
line 164.

...and nothing else.

Given that your thread stopped at this point, I was wondering if you had any further ideas? Using an XP machine is the obvious answer, but I would rather not rebuild my PC if I can help it!

Thanks for any help you can give a new and very frustrated user.


2007-07-10, 10:27
It should definately run fine on Vista (does for me)....

Can you run with --d_mqsql and --d_http what does it say?

2007-07-10, 18:08

I realise this isn't straightforward and really appreciate you taking the time to reply.

I am not sure the slim.exe --d_mysql is much help, posted here.

C:\Program File\SlimServer\server>slim.exe --d_mysql
2007-07-10 20:23:22.9313 Use of uninitialized value in transliteration (tr///) a
t /PerlApp/File/Spec/Win32.pm line 103, <DATA> line 164.
2007-07-10 20:23:22.9316 Use of uninitialized value in pattern match (m//) at /P
erlApp/File/Spec/Win32.pm line 105, <DATA> line 164.
2007-07-10 20:23:23.1835 MySQLHelper: createConfig() Creating config from file:
[C:\Program File\SlimServer\server\MySQL\my.tt] -> [C:\ProgramData\SlimServer\Ca

....after this it hung and did nothing. Actually I need to restart my machine as I can't even close the Command window using Task Manager! I can start and restart the Slimserver from the task tray icon, although gives me a timeout error. localhost:9000 gives me a 'not found' error, which is interesting, but given my rudimentary knowledge of such matters doesn't tell me much.

I will paste the output from the --d_http switch after the restart.


2007-07-10, 18:33
No update, it simply hangs when running with the --d_http switch after outputting those 'standard' two lines ending in 164.

There is clearly a massive conflict somewhere.

By the way I have tried installing the software in many different directories, not just Program Files. I have tried Program File and more recently ProgramData.

I totally understand if this falls into the 'too difficult' category!


2007-07-11, 00:24
You could try to start with --d_startup, --d_server and --d_plugins. The additional message may show if startup is somehow different on your system.

Before doing this I think you should uninstall Slimserver and delete ALL directories created for this and previous slimserver installations. Especially make sure the pref file and cache directories. Also delete any slimserver entries in the security s/w relating such as ports and slim.exe.

Then check if any other s/w is using port 9000 such as a UPNP server (e.g. Windows Media Player)

Then install slimserver 6.5.3 in default directory and then add if necessary port opening and slim.exe to security.

2007-07-11, 11:48
To make sure the default install is deleted from Vista:

Uninstall, then:

Open Vista Exporer, go to Organise, Folder and Search Options, View
and enable "show hidden files and folders"

Then ensure you delete:
C:\Program Files\SlimServer\
C:\Users\<your username>\AppData\Local\SlimServer

Reboot and try reinstalling.

2007-07-11, 17:04
Guys thanks again for the responses. OK, I deleted everything including stuff from the hidden ProgramData directory and rebooted. Unfortunately the setup just hangs at, seemingly, the very end and the only way to get out of it is to terminate it. I can see that it has inserted Slimserver into Windows Firewall but it hasn't tried to start Slimserver.

Despite having rebooted, in Task Manager I do see two "slim.exe" entries (one for user Marc and one for SYSTEM) and a SlimServer_6_5_v2007-07-10.exe entry. In services slimsvc is 'Starting' and SlimServerMySQL is running.

Stop Press. After stopping the process slim.exe running under 'Marc' the setup completed. However slimsvc is stuck in 'Starting" and whilst the tray icon says it is connected, when I try to stop it, it tells me it is stopping it but it doesn't shut down.

I don't want you guys to spend days responding to my posts, but any further advice before I try a XP machine would be great, if there is any to give. Just fyi I have already had SlimServer running on my Powerbook with no problem at all, but I want it to run on my desktop....

Thanks again

2007-07-12, 10:57
I have got it working!

Unfortunately the solution was to uninstall slimserver. Then uninstall Zonealarm and re-instate the vista firewall.

Upon re-installing Slimserver everything worked first time!

Under XP Pro I was using Slimserver through Zonealarm without any issues so there must be a conflict somewhere with the Vista version of Zonealarm. Before anyone asks I did make sure that everything was configured within Zonealarm in the same way as I had it working under XP, e.g. open ports etc.

Has anyone out there got Slimserver working with a third party firewall?


2007-07-14, 05:11
Phew, me too, ZoneAlarm was the problem. As soon as I did what you suggested and uninstalled ZA it worked.

Many thanks to everyone...


2007-07-14, 12:38
For now I have decided to do without Zone Alarm and instead rely upon the Vista Firewall. To back this up I have just invested in Kaspersky AV which I have read good reviews about.

What I am really not sure about is how good/bad the Vista firewall is. My gut feeling is that there is probably a better third party option out there. Does anyone have a recommendation for one that works with Slimserver? Is the Vista firewall good enough?

At the moment I am tempted to wait for the vista version of Comodo firewall to be developed ... but I really don't want to wait that long if the Vista one has any serious holes in it.

Thanks in advance for any advice,

2007-07-14, 14:46
What version of ZoneAlarm are you running ?

I am not familiar with the Vista version but on XP there was a Slimserver related problem with the suite which I pinned down to the IM secure module.

If the Vista version has many modules - try just installing one at a time and see the problem is related to a single module.

2007-07-15, 00:47
I had a similar problem with Zone Alarm on Vista, and fixed it by just uninstalling Zone Alarm.

I was running SlimServer perfectly for a few months on Vista with the default Vista firewall.

Then (yesterday) I installed the new Vista version of Zone Alarm, and I then couldn't get SlimServer to work.

I imagine that it may have been possible to fix it with some jiggling of "zones", etc. but I decided just to uninstall Zone Alarm, and SlimServer started working again.

2007-07-15, 10:57
bpa, I did try re-installing zone alarm on top of the working install with the minimum options available. As soon as the re-boot after install was completed I was back into the problem of slimserver stuck in a starting state.

To be honest with you I do not have enough patience to try and track down what is causing the problem between the two applications. All I know is that uninstalling ZA caused SS to work again following a re-boot.

I am glad to find that I am not alone in having this conflict. It suggests that there is a genuine issue between the two and not a problem unique to my setup. If someone works out a way to resolve the conflict then I will happily start using ZA again. In the meantime I would be interested to hear from anyone that has got SS working with a third party firewall. Or are all Vista based SS users using the Vista firewall?

2007-07-21, 00:55
Hi All

I have just run into this as well. I bought a new Vista PC last week. SS runs fine with the trial McAfee security product. Zonealarm was my preferred firewall/AV setup under XP, which worked well with SS, so I installed the latest Vista version, and immediately hit the problem. SS would'nt start. All the relevant ports and permissions were set up OK, as they used to be on my XP PC. I removed Zonealarm and all is back to normal.

Only problem is I now have to learn a new firewall/av product. If zonealarm wont work, any other suggestions? - at least I know McAfee works with SS


PS Kapersky appears to work OK

2007-10-13, 21:48
This just plain sucks.

I'm a Systems Admin for a large company dealing with thousands of managed PCs. I've been running SlimServer for a couple of years and it is by far one of my greatest joys at home! However, after installing Vista Enterprise at home a couple of months ago, I've been racking my brain (and almost downgraded to XP on my main desktop) to (1) try to get SS to complete installation [I have to shut it down after endless inactivity during install] and (2) just to get the SS service to start as has been stated by others.

FINALLY, against my better judgement, I uninstalled both McAfee ViruScan Enterprise and the latest version (as of this post) of ZoneAlarm (free). SS finally starts but... Ugh!!! I can't take this Windows Firewall!!! It's really, really bad - particularlly the one way notifications. I like granular control over data coming in and out of my computers like ZoneAlarm gives me. A "problem with True Vector Service????" No! I had the same version of ZA and SS together on my XP machine with no issues...!!!!

Please, PLEASE come up with a fix so I can re-install ZA. Has anyone else tried any other (hopefully free) ZA-type firewalls????

I'm not happy...

2007-10-15, 17:25
Similar problems to above: I am running Vista Premium, Zone Alarm, and installed Slim Server 6.5.4. SlimServer appears in my system tray and quick launch, but when I click on it to open, I just get Internet Explorer saying it cannot connect to the Internet. Have granted all Slim Server programs full permissions in Zone Alarm.

Is there any simple way to deal with these problems? I am not able to uninstall Zone Alarm because it's a required install for remote access to my work network.

2008-01-01, 04:30
Did anyone manage to get this working with ZoneAlarm on Vista?

Further to my post (http://forums.slimdevices.com/showpost.php?p=214656&postcount=19) back in July last year, I just tried installing ZoneAlarm again, and it still won't work.

As before, I get stuck at the "SqueezeCenter starting..." phase (with one key difference being that I'm using the new 7.0 server software).

Any help would be much appreciated :-)

2008-01-30, 06:54
I'm with you - I never got slimserver working with Vista. Spent ages rebuilding, playing with firewalls etc. I thought that Squeeze Centre was the answer and duly installed it the other day. Same probem; "Squeeze Centre Starting" forever.

C'mon Slim Devices, Logitech. You need to pull your finger out and get a RELIABLE installation on Vista.

Meanwhile, I'm busy buring CO2 by keeping my old XP machine running just for my Squeezebox...

2008-01-30, 09:52
I'm with you - I never got slimserver working with Vista. Spent ages rebuilding, playing with firewalls etc. I thought that Squeeze Centre was the answer and duly installed it the other day. Same probem; "Squeeze Centre Starting" forever.

C'mon Slim Devices, Logitech. You need to pull your finger out and get a RELIABLE installation on Vista.

Meanwhile, I'm busy buring CO2 by keeping my old XP machine running just for my Squeezebox...

I think we need to put everything into perspective here.

Microsoft update their operating system, so Logitech have to update their software to work with updated operating system. Logitech then charge for updated software.

NO...Logietch do not charge for updated sofgtware...so let us all get off Logitechs back and let them provide updated software for free.

Personally I get really hacked off with the upgrade policy of Microsft in particular but there are others involved, what would we all say if the oil companies upgraded the fuel and forced us to change the engines in our cars....

Rant over