PDA

View Full Version : Slimserver - Starts then Stops



bytheedge
2007-07-04, 12:23
Hi,

I've just installed 6.5.2 on Mac OS X, can start server ok but trying to connect via http stops the server. Error log text below.

------

sh: line 1: /usr/bin/defaults: No such file or directory
Use of uninitialized value in chomp at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Unicode.pm line 95.
Use of uninitialized value in subroutine entry at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Unicode.pm line 102.
sh: line 1: /usr/bin/defaults: No such file or directory
Use of uninitialized value in chomp at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Unicode.pm line 110.
Use of uninitialized value in substitution (s///) at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Unicode.pm line 112.
Use of uninitialized value in split at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Unicode.pm line 113.
2007-07-04 20:13:51.8349 SlimServer OSDetect init...
2007-07-04 20:13:51.8354 SlimServer OS Specific init...
2007-07-04 20:13:51.8362 SlimServer daemonizing...
2007-07-04 20:13:51.8846 SlimServer settings effective user and group if requested...
2007-07-04 20:13:51.8874 SlimServer settings init...
2007-07-04 20:13:51.9128 SlimServer saving pid file.
2007-07-04 20:13:51.9167 Got to the END.
There was an error reading your SlimServer configuration file - it might be corrupted!: [Modification of non-creatable array value attempted, subscript -1 at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Prefs.pm line 1140, <NUPREFS> line 79.
]
2007-07-04 20:13:52.0344 Got to the END.

-----

Any help most welcome.

Thanks

bte

mherger
2007-07-04, 12:53
> I've just installed 6.5.2 on Mac OS X, can start server ok but trying
> to connect via http stops the server. Error log text below.

has this been an update from an earlier version?

> There was an error reading your SlimServer configuration file - it
> might be corrupted!: [Modification of non-creatable array value
> attempted, subscript -1 at

Could you try to get rid of your Library/SlimDevices/slimserver.pref (not
sure this is the right location) and try again?

Michael

bytheedge
2007-07-04, 13:02
Deleting the .pref file has sorted it, thanks.

bte