PDA

View Full Version : Ubuntu 7.04 - Softsqueeze not working



Ron F.
2007-07-02, 19:14
I would certainly like to see this resolved.

I am running Slimserver 6.5.2 on Ubuntu 7.04. I am attempting to run Softsqueeze 3.4 on the same machine. I have not been able to keep Softsqueeze running for more than a few minutes, before it freezes up with the message that it has lost connection with the server. That's silly - the server is right there on the same machine - and it is definitely running. If focus is removed from Softsqueeze, it looks like the program simply hangs or goes to sleep. I have tried several different JRE versions, and that does not seem to make any difference.

This is very frustrating, because Softsqueeze seems to work fine under Michael's SlimCD - so what is going on?

-Ron

Ron F.
2007-07-03, 19:53
Well, I could sure use some ideas here.

I have installed Ubuntu 7.04, and then installed the Debian package for Slimserver. Slimserver works fine but I cannot get Softsqueeze 3.4 to work properly on this machine - connecting to 127.0.0.1 - it is in a constant struggle to keep from locking up:

Problem: lost contact with Slim Server.
Check the software is running.

This happens after a few minutes of play, although Softsqueeze was not responsive once it began to play to begin with. When it is playing, the display does not update very often, and the buttons are non-responsive - it is extremely sluggish, and disconnects frequently.

It is as if it is hardly running at all! I set the priority in the system monitor for Java to -10, but that makes no difference.

I have tried JRE 1.6.0 and 1.6.0.1 - no difference.

The problem might be with the running of Slimserver rather than Softsqueeze, because I have noticed that this problem is worse when I am streaming an internet station using proxied streaming as opposed to direct streaming.

However, I can use Softsqueeze on another computer, connect to Slimserver on this Ubuntu platform, and it will play everything without a glitch.

Any suggestions? - I am stuck. Softsqueeze is the ONLY thing I have not been able to get to work properly under Ubuntu.

-Ron

scotsghost
2007-07-08, 10:59
Ron,

I've just installed Ubuntu 7.04 on my server as well but haven't quite gotten SlimServer back up on the box. Your problem smells like a network issue, assuming your JRE is functioning properly. If none of the below helps, maybe try a 1.5.x JRE?

I had a lot of network trouble with Fiesty out of the box, which only cleared up once I disabled IPv6. It's a one-line change to /etc/modprobe.d/aliases (change "alias net-pf-10 ipv6" to "alias net-pf-10 off") OR /etc/modprobe.d/blacklist (add "blacklist ipv6" as a separate line).

Also, you may want to modify /etc/hosts so that the hostname of your system is included as an alias for localhost (ie change "127.0.0.1 localhost" to "127.0.0.1 localhost myhostname"). If you do disable IPv6, you should probably comment out or delete the ip6-* lines there as well.

--s

Ron F.
2007-07-08, 19:05
Scotsghost,

Thank you very much for the suggestions - greatly appreciated.

I was wondering about the ipv6 stuff and wondering myself if it could be involved, but I had not figured out yet how to turn it off.

I will try turning off ipv6, modifying the host file, and then as a last resort try JRE 1.5. I will report back.

-Ron

BrownDogFin
2007-07-10, 09:44
Running CentOS5 on Opterons FWIW. I tried 1.5 and 1.6 JVMs, both 32 and 64 versions and I kept getting "lost connection to server" errors after a song or maybe too if I was lucky.

I added:

alias net-pf-10 off

to /etc/modprobe.conf, which disables loading IPv6 and fixes the problem for me. It's been running for 1/2 an hour now and it looks like things are improved.

Ron F.
2007-07-10, 13:20
No luck so far. I disabled IPv6, but Softsqueeze still fails to work for more than a minute on my new Ubuntu 7.04 system. I still get the "lost connection to server message."

I will try loading 1.5.X JRE, to see if that makes any difference.

-Ron

Ron F.
2007-07-11, 16:16
I think I have it working!

I installed the 1.5.0_11 JRE from the Ubuntu repository and now Softsqueeze stays connected to Slimserver via localhost. I also upgraded Slimserver to 6.5.3. I still have IP v6 disabled, but possibly that was not related to the problem. I could restart IP v6 support and see if Softsqueeze continues to work.

My guess is that on Ubuntu 7.04, Softsqueeze has a problem with the current 1.6 JRE.

-Ron

th00ht
2008-12-07, 04:33
My SqueezeCenter runs on a GNU-Linux distro Ubuntu 7.04 . I'm starting the SoftSqueeze on my Vista PC (to test if it could play 5.1 FLAC). I had it connect correctly for 3 min. Now when I start it the "display" keeps flashing that it lost the connection.