PDA

View Full Version : faad2 problems



kfritz
2007-07-01, 10:20
I have a rather large library of music ripped with iTunes, and want to play them on my new squeezebox. I followed the instructions in the wiki for streaming aac files, and it plays a few seconds of the song, then stops.

I think I've isolated the problem to faad2. I've attached an edited dump of output from faad2 when I run the following:
faad2 -w -f2 test.m4a > /dev/null
It ends in segmentation fault.

Other Details:
- I'm running Slackware 11.0 on some rather ancient hardware.
- I wasn't able to compile faad2, so I picked up a package from linuxpackages.net. It's 2.5.

Has anyone seem similar problems? Any suggestions?

Thanks!

bpa
2007-07-01, 10:59
if mplayer is available for Slackware 11.0, you can use mplayer as an alternative to faad2 but there are different lines needed for convert.conf.

There are posts in the forum about using mplayer

kfritz
2007-07-01, 22:03
OK, I installed mplayer and the 12 other packages it depends on. It's worse than faad now (faad continues to spew within mplayer then crashes). Now it requires a restart of SlimServer!

Has anyone running Slackware had luck with this?

Are there any alternatives to faad and mplayer?

bpa
2007-07-02, 00:20
What processor is in your system ?

Where did you get the mplayer - it is usually a standalone app with all libraries linked in and no special dependencies. Have you have installed a GUI version which will not work with AlienBBC or built mplayer with too many options.

There are two build options of mplayer for processing AAC - one build uses faad library and the other build uses a library from ffmpeg. You should use the mplayer which does not use the faad library.

kfritz
2007-07-03, 21:05
Thank you for your continued interest...

Here's my /proc/cpuinfo:
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Celeron (Coppermine)
stepping : 6
cpu MHz : 631.302
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips : 1258.29

Now, I realize that this is a real dog of a machine, but I have a Pentium II 450 at work where this runs fine!!!

Since I've had trouble compiling the faad2 source code, I just tried the packages available off linuxpackages.net. But I've now successfully compiled the 2.0 code now on my system, with the same results.

I'll investigate the ffmpeg suggestion...

Thanks!

bpa
2007-07-04, 00:17
What sort of exception are you getting ?

Some of the Celeron processor confuse some "confgure" scripts and cannot run because of missing some FPU instructions.

If your exception is an FPU one then this could be happening. You can create an FAAD which does not use floating point by configuring and compiling FAAD with –without-fp –nfp. If this does not work in libfaad/config.h uncomment #DEFINE FIXED_POINT

kfritz
2007-07-05, 22:48
OK, I've solved my problem now. Somehow, in moving my iTunes library from Windows to Linux, and playing around with various tagging software, every single one of my iTunes files has been corrupted.

Files are the same size, MD5 different. A fresh copy works just fine.

Wiping the egg off my face...