PDA

View Full Version : Errors in SuSE



geoff_17
2007-06-29, 01:59
Hi guys,

I am really new to this stuff. I am trying to get slimserver to run on SuSE 10.2. I have followed the advice on the Wiki but I get the error: /etc/init.d/slimserver.init start returned 126 (unspecified error), when I run it in System services (Runlevel).

Does anyone have any ideas what is going on? I would be very grateful.

Cheers,

Geoff_17
P.S. I think I put this in thw wrong forum - sorry

Mark Miksis
2007-06-29, 08:09
I have no idea what error 126 is. What happens when you run (as root) "/etc/init.d/slimserver.init start" from a shell?

geoff_17
2007-07-02, 00:53
I have no idea what error 126 is. What happens when you run (as root) "/etc/init.d/slimserver.init start" from a shell?

Thanks for this. It said: "Permission denied". Is this something to do with the group permissions?

erland
2007-07-02, 01:12
Thanks for this. It said: "Permission denied". Is this something to do with the group permissions?

Does it have execution rights ?
ls -l /etc/init.d/slimserver.init

It should return something like this:
-rwxr-xr-x 1 root root 2048 2007-06-30 10:38 /etc/init.d/slimserver.init

The problem is the execution rights if the first part doesn't contain the 'x', for example:
-rw-r--r-- 1 root root 2048 2007-06-30 10:38 /etc/init.d/slimserver.init

To correct this you will need to run (as root):
chmod +x /etc/init.d/slimserver.init

geoff_17
2007-07-02, 01:50
Thanks to both of you as I have now changes the security which was the problem.

Many Thanks indeed. Geoff