View Full Version : SB3 wireless just isn't happening!

2007-06-27, 05:55
Got my SB3 a few weeks ago, best money I have spent in a long time, however I do have one annoying problem, I just can't get the SB3 to work with wireless.

My first installation attempt was wireless slimserver and wireless SB3. The SB3 menu was horrible to use scroll 3 items then freeze for 10 seconds then often blank screen and trying to connect to slimserver, music would play for a reasonable amount of time and then stop working when I tried to scroll through SB3 menu's.

So I thought ok maybe 2 wireless jumps is the problem, so I hard wired my slimserver to my vigor 2800 wireless router. I had exactly the same problems with the SB3. I ran some ping tests from my pc to the SB3 and it seemed that every 5-10 seconds the SB3 was unreachable for a few seconds.

So next I try hard wired slimserver and hardwired SB3..... problem fixed all works correctly so now I have a patch lead running around my room from router to SB3, not exactly what I had in mind.

My current setup is wireless slimserver and hardwired SB3 so I know it isn't my router that is causing a problem with the slim communication as my slimserver is wireless.

Slimserver version is 6.5.2 and SB3 firmare is 81, i do not use encryption on my wireless network and I have tried the SB3 wireless with mac filtering off with no difference also I have tried switching off all wireless turbo options. The SB3 is only located <10 meters from the wireless access point.

I really want to get another SB3 for another room in the house and I really can't hard wire that one :(

Any suggestions on what is going on here?


2007-06-27, 06:52
If you search for Vigor, you will see there are a large number of reports of problems when using a Draytek Vigor router and an SB. One poor guy eventually got a custom firmware from Draytek support because they accepted their router wasn't compatible with the SB. Upgrading the firmware on the router to the latest version may sort it out.

I will try to find the thread, which isn't this one but it discusses the same problem.


That said, it could just be the configuration of your router as some people do have the Vigor 2800 working. A few more details would help:

Can you check the mac address of your SB matches the address printed on the bottom of the unit itself?

Do you have mac address filtering switched on in your wireless network?

What kind of wireless security are you using?

If you remove the wireless security entirely from your network, and reboot the router, can the SB connect ?

2007-06-27, 07:02
Thanks for the reply :)

However I do not use anyform of WEP/WPA on my network which seems to be what the linked post refer's to.

I can connect wirelessly it's just that the SB3 gets network dropouts when running wireless.

However I will update my router firmware and give it a go on the off chance that it fixes the issue.

To be honest, I'm really not sure if the wireless in the SB3 isn't faulty, I think I will see if I can borrow another brand wireless AP from somewhere and check to see if this is the case.


2007-06-27, 07:07
Just found this post.... looks indeed like a latest firmware update on the draytek will solve the problem....


Thanks for pointing me in the right direction.


2007-06-27, 07:25
That's the one I was looking for, glad you found it - and sorry not to notice the bit about the encryption earlier.

If it doesn't sort the problem out, there is one other issue you may want to look out for, which is the mac address on the SB getting corrupted. It's easy to check if this is your problem (does the mac address of the SB match that printed on the bottom) and even easier to fix (re-input the correct mac address).

2007-06-27, 13:15
Ok, upgraded my Draytek 2800 to firmware 2.7.2 and SB3 now works perfectly over wireless. Will try WPA over the weekend when I have more time to reconfigure all my wireless devices.

Wireless SB3 in another room here I come!!

Thanks again for the help!!