PDA

View Full Version : iTunes Album not in slim server?



mpc
2007-06-14, 03:12
Can anyone help,

I have a SB3 which is set up and running fine. I can view my music from iTunes but what I have noticed is that some of the albums do not appear on the SB3? They are not protected (that I am aware of) They have been imported in to iTunes from CD in the normal iTunes format. Other albums are there which are in the same format.
Can anyone tell me how to overcome this?
Thanks
Michael

Gildahl
2007-06-14, 04:23
There are a variety of reasons why this can happen, but one thing to check is to see whether the music in the album is tagged with the same artist and composer. There is a bug in recent versions that causes music so tagged not to appear in SlimServer. To workaround this, just change either the Artist or Composer name so that they are not the same. This *might* fix your problem.

mpc
2007-06-14, 04:30
There are a variety of reasons why this can happen, but one thing to check is to see whether the music in the album is tagged with the same artist and composer. There is a bug in recent versions that causes music so tagged not to appear in SlimServer. To workaround this, just change either the Artist or Composer name so that they are not the same. This *might* fix your problem.

Hi thanks for your reply. How do I check if the music in the album is tagged?
Thanks

Mark Lanctot
2007-06-14, 07:30
http://wiki.slimdevices.com/index.cgi?BeginnersGuideToTagging

mpc
2007-06-15, 02:40
In addition to the original message above, I checked again last night and browsed under 'Genre' instead of 'Artists' for the required album and it did appear that way!!??? Does anyone know why this would be?

MelonMonkey
2007-06-15, 08:03
I had two albums added two nights ago and one of them was appearing in with Various Artists. Both albums by the same artist and tagged the same way. Verified up and down there were no composer tags, etc.

The missorted one had "Soundtrack" in the title, which I suppose could have been interpreted by SlimServer, but I'd expect this isn't normal behavior. In the end I had to delete the Slim database and re-index all over for everything to be sorted out. No mater what tags were changed in the music Slim was not correcting the contents of its DB.

matt24
2007-06-15, 19:46
Thanks Gildahl,

I also had this anoying problem after I switched over to using iTunes. I almost had decided to switch back.

Matt
SlimServer Version: 6.5.2 - 12047 - Mac OS X 10.4.7 (8J2135)