PDA

View Full Version : Problem with Windows Media ripped files



bullgod
2007-06-10, 18:09
I've got a problem where albums I've ripped using Windows Media don't appear under the artist.

For example if a rip Pink Floyd's "Meddle" and "Animals", the former using Real Player and the latter WM, only Meddle is listed under Artist-> Pink Floyd. Although both albums are listed under "Albums". Although if I only have WM ripped albums by an Artist the Artist is missing from the Artist list.

This would appear to be because the contibutor is listed as role=1 after being produced by Real Player and role=2 for the WM produced file.

Editing the tags of a WM produced file using RP does not get round the problem.

Is this a [known] genuine bug?

I'm using 6.5.2 on linux, and setting "List Album by Band".

I can get round the problem by hacking the SQL but this gets reset if I but a full rescan.

Spies
2007-06-11, 15:43
Have you tried the latest nightly? There were a number of changes to contributer handling that missed the 6.5.2 release.
Here is is a link to one of the bugs:
http://bugs.slimdevices.com/show_bug.cgi?id=4882

watersuper
2007-06-11, 15:53
I have the same problem with some WMP titles and would like to correct. Once you open the nightly link that was posted, what then?

bullgod
2007-06-12, 09:18
I have replaced the Schema.pm file pointed to in the bug reference with the ...../Slim/Schema.pm and run a fresh build of my library.
The missing albums have now reappeared.

I appriciate that the this isn't the way one should go about patching, but as a quick and dirty test, I do appear to be suffering from this bug, rather than a new one. Cheers.