PDA

View Full Version : SB2 turned Chinese



agentsmith
2007-06-06, 05:30
Just bought my new Lenovo R61 laptop with English Windows Vista. Installed SlimServer 6.52 and found that my SB2 shows the date in Chinese.

So I tried changing all system languages and region settings to English, stopped and restarted SLimServer. Now the date for "Month" and "Day" on the LED shows up as gibberish.

Anyone knows how to make SLimserver to display everything in English?

mherger
2007-06-06, 05:41
Hi Agent

> Just bought my new Lenovo R61 laptop with English Windows Vista.
> Installed SlimServer 6.52 and found that my SB2 shows the date in
> Chinese.

Did you run 6.5.2 before? Could you please give us the information given
on the first settings page, at the bottom (it should contain some
information about your language settings, the system etc.).

> Anyone knows how to make SLimserver to display everything in English?

Is there anything in your system which could make SlimServer think it's
Chinese? (besides that fact that it was produced in China) You're living
in Hongkong, aren't you? Is this an English Windows version or an
international version configured to be run in English?

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

agentsmith
2007-06-06, 07:08
Hi Agent

> Just bought my new Lenovo R61 laptop with English Windows Vista.
> Installed SlimServer 6.52 and found that my SB2 shows the date in
> Chinese.

Did you run 6.5.2 before? Could you please give us the information given
on the first settings page, at the bottom (it should contain some
information about your language settings, the system etc.).

> Anyone knows how to make Slimserver to display everything in English?

Is there anything in your system which could make SlimServer think it's
Chinese? (besides that fact that it was produced in China) You're living
in Hongkong, aren't you? Is this an English Windows version or an
international version configured to be run in English?

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

I ran 6.5.1. in my older WinXP PC. This is a new English PC and I am running 6.5.2 for the first time. The bottom of the server setting says:

"SlimServer Version: 6.5.2 - 12047 - Windows Vista - EN - cp1252
Server IP address: 192.168.11.12
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt"

It is English Vista with Chinese fonts installed for Internet Explorer display etc. When I first took delivery of the machine it was set to displaying Chinese so many of the Windows system prompts were appearing in Chinese. And as I said, the SB2 clock was displaying in proper Chinese characters.

I have since changed everything, including region info, to display English only. But now SB2 clock is displayed in broken gibberish. Note that SlimServer has always been set to English only.

TO answer your last question, It is an English Windows Vista Premium PC.

mherger
2007-06-06, 07:25
> "SlimServer Version: 6.5.2 - 12047 - Windows Vista - EN - cp1252
> Server IP address: 192.168.11.12
> Perl Version: 5.8.8 MSWin32-x86-multi-thread
> MySQL Version: 5.0.22-community-nt"

Nothing special here.

> When I first took delivery of the machine it was set to
> displaying Chinese so many of the Windows system prompts were appearing
> in Chinese.

That's what I thought.

> I have since changed everything, including region info, to display
> English only. But now SB2 clock is displayed in broken gibberish.

Are you sure your _system's_ language is set to English as well? Even if
you change it for yourself, it could still be different for applications
run as a service (as eg. SlimServer).

See http://technet.microsoft.com/en-us/library/bb457003.aspx - the last
step might be necessary to change the language for services as well.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

agentsmith
2007-06-06, 08:12
> "SlimServer Version: 6.5.2 - 12047 - Windows Vista - EN - cp1252
> Server IP address: 192.168.11.12
> Perl Version: 5.8.8 MSWin32-x86-multi-thread
> MySQL Version: 5.0.22-community-nt"

Nothing special here.

> When I first took delivery of the machine it was set to
> displaying Chinese so many of the Windows system prompts were appearing
> in Chinese.

That's what I thought.

> I have since changed everything, including region info, to display
> English only. But now SB2 clock is displayed in broken gibberish.

Are you sure your _system's_ language is set to English as well? Even if
you change it for yourself, it could still be different for applications
run as a service (as eg. SlimServer).

See http://technet.microsoft.com/en-us/library/bb457003.aspx - the last
step might be necessary to change the language for services as well.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

Michael you are good! I stopped the Windows service and restart slim.exe from a DOS promopt and now my SB2 time is in English

Now I have to find out how to set _system_ to English. Your link is for XP so I will have to figure out how to do the same in Vista

thanks again

agentsmith
2007-06-06, 08:22
Michael, you found my problem! I found out how to do it in Vista. For the other Vista folks with similar issues:

1. Goto Control Panel - CLick, language and Region
2. Goto Change the Country or Region
3. make sure you change everytrhing to Engliah
4. After changing all default languages to English, Go to the Administrative tab
5. Click "Copy to Reserved Accounts"
6. You will see an option to copy regional and locale settings to system accounts

thanks again Michael, very quick and effecitve of you.