PDA

View Full Version : Streaming WMA not supported?



bevan11
2007-06-03, 09:48
Hi,

I'm periously close to getting my music sources working bar one.

I listen to www.whatson.com/kiss100 and the recorded programs, i've done an ethereal trace and got the URLs which work through WMP but when I tune to them with Slimserver it treats the .wma as a file and not a stream. Given that these are 2-3hour sets these will take this long to download and encode!

http://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma

Does anyone know how to get streaming WMA working?

Thanks,

Bevan.

bpa
2007-06-03, 10:24
WMA support will depend on the player - SB1, SB2/3 or Softsqueeze and if not an SB2/3 what OS is being used for slimserver.

What player are you using ?
What OS are you using ?

bevan11
2007-06-03, 10:38
Hi,

Currently I am only using iTunes to browse to the stream.mp3 on XP.

I don't have a SB just yet as i want to ensure that all of the music I listen to works.

Using the URL can you get it to stream through SB?

Thanks,

Bevan.

bpa
2007-06-03, 10:54
Using stream.mp3 may not be the best as I know there are restrictions within slimserver on transcoding streams to streams which do not apply when transcoding to a player.

To test Slimserver and SB3 capabilities - try SoftSqueeze.

Depending on the OS - it may be possible to suggest a solution to your current issues.

bevan11
2007-06-03, 14:49
Hi,

I've tried Softsqueeze and there is no option to tune into URL to give this is a go. From reading around and looking at the convert file I guess that it is trying to download the .wma file do wmadec then pass through lame to convert to mp3.

I'm currently running Windows XP and do have access to a Ubuntu installation as well.

I've attached the logtrace from d_parse, d_remotestream and d_source. Any ideas?

Bevan.


openSong on: mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma
openSong: URL is remote [mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma]
Trying to open protocol stream for mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma
Found handler for mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma - using Slim::Player::Protocols::MMS
Setting maxBitRate for 192.168.1.100 to: 128
Setting maxBitRate for 192.168.1.100 to: 128
undermax = 0, type = wma, http = 192.168.1.100
checking formats for: wma-mp3-http-192.168.1.100
checking formats for: wma-mp3-*-192.168.1.100
checking formats for: wma-mp3-http-*
checking formats for: wma-mp3-*-*
Checking to see if wma-mp3-*-* is enabled
enabled
Found command: [wmadec] -r 44100 -b 16 -n 2 $FILE$ | [lame] -x --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -
Setting maxBitRate for 192.168.1.100 to: 128
Setting maxBitRate for 192.168.1.100 to: 128
Matched Format: mp3 Type: wma Command: [wmadec] -r 44100 -b 16 -n 2 $FILE$ | [lame] -x --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -
Setting maxBitRate for 192.168.1.100 to: 128
Setting maxBitRate for 192.168.1.100 to: 128
Using command for conversion: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\wmadec.exe" -r 44100 -b 16 -n 2 "mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma" | "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe" -x --resample 44100 --silent -q 9 --abr 128 - -
Launching process with command: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\socketwrapper.exe" -d -w -o 2364 -c "\"C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\wmadec.exe\" -r 44100 -b 16 -n 2 \"mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma\" | \"C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe\" -x --resample 44100 --silent -q 9 --abr 128 - -"
openSong: remoteURL is a song : mms://mars.radica.com/emap/kissradioplayer/01-1900-2100-96.wma
Setting maxBitRate for 192.168.1.100 to: 128
Setting maxBitRate for 192.168.1.100 to: 128
undermax = 1, type = mp3, http = 192.168.1.100
checking formats for: mp3-mp3-http-192.168.1.100
checking formats for: mp3-mp3-*-192.168.1.100
checking formats for: mp3-mp3-http-*
checking formats for: mp3-mp3-*-*
Checking to see if mp3-mp3-*-* is enabled
enabled
Found command: -
Setting maxBitRate for 192.168.1.100 to: 128
Setting maxBitRate for 192.168.1.100 to: 128
Matched Format: mp3 Type: mp3 Command: -
openSong: remoteURL command - type mp3 format mp3
openSong: remoteURL stream format : mp3
192.168.1.100 New play mode: play
192.168.1.100: Current playmode: play
Pipeline reader connected

bpa
2007-06-03, 15:05
There is a restriction with Slimserver about stream - you were converting WMA to mp3 and then trying to reconvert again to send to stream.mp3. This doesn't work.

Your station plays fine with native WMA on an SB3.

To tune-in SoftSqueeze - use the Tune in menu on the web interface. You can save it as a favorites. Alternatively you can use MyPicks or a playlist fot the station URL.

bevan11
2007-06-03, 15:18
Excellent, that has worked for me. I saved the URL as a playlist and then used Softsqueeze.

Once I'm in the new house I shall be purchasing a SB!

Thanks for the help.