PDA

View Full Version : Time/Date Format in 6.5.2



Chris Marr
2007-05-28, 04:54
I've always had my SB1 display the Date/Time screensaver when not in use, displaying the time in a large font as h:mm. Since upgrading to 6.5.2 however the time shows as h:mm PM (or AM). There's no longer an option to not display the AM/PM symbols. Even if they could be displayed in a lower case font would be better.

Does anyone know of a tweak to remove the ugly AM/PM symbols and still retain the h:mm format?

Regards,
Chris.

JJZolx
2007-05-28, 08:31
I've always had my SB1 display the Date/Time screensaver when not in use, displaying the time in a large font as h:mm. Since upgrading to 6.5.2 however the time shows as h:mm PM (or AM). There's no longer an option to not display the AM/PM symbols. Even if they could be displayed in a lower case font would be better.

Does anyone know of a tweak to remove the ugly AM/PM symbols and still retain the h:mm format?

Are you looking in the right place? On the Server Settings > Plugins page there should be a 'Date and Time Screensaver Settings' section with date and time formats. I'm running the latest nightly and have at least 20 time formats to choose from.

Chris Marr
2007-05-28, 14:14
Are you looking in the right place? On the Server Settings > Plugins page there should be a 'Date and Time Screensaver Settings' section with date and time formats. I'm running the latest nightly and have at least 20 time formats to choose from.

You are right, there is a lot of choices, but there's no h:mm (12hr). You can only display h:mm pm (12hr). I want to remove the AM/PM symbols. I was able to do this in 6.5.1.

kdf
2007-05-28, 14:27
Quoting Chris Marr <Chris.Marr.2rbaqz1180386901 (AT) no-mx (DOT) forums.slimdevices.com>:


> You are right, there is a lot of choices, but there's no h:mm (12hr).
> You can only display h:mm pm (12hr). I want to remove the AM/PM
> symbols. I was able to do this in 6.5.1.

Are you certain that this was the case without modifying the code?
The date time settings are selected from a list that hasn't changed
for at least 13 months, well before the 6.5.1 release.
-kdf

Chris Marr
2007-05-30, 19:16
Are you certain that this was the case without modifying the code?The date time settings are selected from a list that hasn't changed for at least 13 months, well before the 6.5.1 release.
-kdf

Yes I am certain. I've never modified the code and 6.5.1 never showed the AM/PM symbols in h:mm 12 hour format.

JJZolx
2007-05-30, 19:37
Yes I am certain. I've never modified the code and 6.5.1 never showed the AM/PM symbols in h:mm 12 hour format.

Are you sure you weren't using a 24 hour format? There would have had to be additional format strings available, because I've always used the Date & Time screensaver and have always used a 12 hour format and it's always displayed AM or PM.

If you run the Perl code, it's easy to add additional format strings to the code. Another thing you can do is stop the server and edit the slimserver.pref file. Look for

screensaverTimeFormat: "|%I:%M %p"

and change it to

screensaverTimeFormat: "|%I:%M"

But... if you ever change anything on the plugins settings page you'll lose this setting.

mherger
2007-05-31, 01:14
> Yes I am certain. I've never modified the code and 6.5.1 never showed
> the AM/PM symbols in h:mm 12 hour format.

Ok, we did do a change to localize the time/date formatting. But I would
not have expected it to change anything if you're using SlimServer with
the language set to EN.

What's your OS, language settings in the OS and in SlimServer?

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

Chris Marr
2007-05-31, 03:14
What's your OS, language settings in the OS and in SlimServer?

--

Michael


OS in Mandriva Linux 2007.1 Region/Language is English/New Zealand. Language in SlimServer is set to English.

6.5.1 was working fine displaying h:mm with no AM/PM symbols on this same OS and locale. The problem only started when I upgraded to 6.5.2. Everything else works fine.

mherger
2007-05-31, 03:38
Oops, sorry, that was a red herring: I did that change in the trunk only,
haven't touched the 6.5.x branch. I therefore really don't see what should
have changed in SlimServer.

Didn't you by chance change the settings on the OS side?

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

Chris Marr
2007-06-01, 21:51
Didn't you by chance change the settings on the OS side?



Once again I repeat, I changed nothing. I just upgraded from 6.5.1 to 6.5.2. When the Squeezebox display came up again it was showing uppercase PM symbol, h:mm PM that is never showed before.

I just want to turn them off because they're ugly. Even lowercase would be better.

You must have changed something in the update.

ceejay
2007-06-02, 00:59
Well, whether something was changed in the update depends on how exactly it is that you managed to do (with 6.5.1) something that people think you shouldn't have been able to! So lets try focussing on that.

First, do you still have the 6.5.1 installation or have you wiped it out? If the latter, do you have a spare machine you could install it onto for test/comparison purposes? That would really help people diagnose what's going on here. Try setting it up and getting back to where you were with the time format display. This will also enable a positive confirmation that you can get the desired result without a tweak (deliberate or accidental) post installation.

Then: what version, exactly, of the server software do you have? ("6.5.1" is not a full answer - go to server settings and look at slimserver version).

Or, of course, you could just try Jim's suggested patch of the slimserver.pref file...

Ceejay

Chris Marr
2007-06-02, 19:08
Or, of course, you could just try Jim's suggested patch of the slimserver.pref file...

Ceejay

OK. in /etc/slimserver.conf there was nothing beside the screensaverTimeFormat: entry so I added "|%I:%M" which resolves the problem.

I also noticed that the timeFormat: "|%I:%M %p" entry so removed the "%p" part.

Obviously I'll have to edit this file anytime any config changes are made.

Note to developers. In future updates, please give us the option to not display AM/PM symbols.

Thanks for all your help.

mherger
2007-06-06, 12:55
Note to developers. In future updates, please give us the option to not display AM/PM symbols.

Chris, there's been a probably related thread:
http://forums.slimdevices.com/showthread.php?t=35883

As we stated earlier, there were no changes to the date/time display. _But_ there's been a change to have SlimServer always run as service (IMHO). Please make sure your regional settings really are what you want for the "default user" as well. See http://technet.microsoft.com/en-us/library/bb457003.aspx - the last step might be necessary to change the language for services as well.