PDA

View Full Version : Problem with retagged Flac-files after 6.5.2



nordvest
2007-05-25, 14:36
After I upgraded to 6.5.2. there seems to be a problem with some of my flac files. My squeezebox just wouldn`t play them even though they worked before. It was the case with ca. 5% of them and I couldn`t see why those files should pose a problem.

After some hard thinking I rembered that everyone of the files which wouldn`t play has previously been retagged either with Media Monkey or Foobar.
The strange thing (as if this wasn`t strange enough...) is that it doesn`t apply for all the flac files that`s been retagged but perhaps 80% of them.

And none of my retagged mp3-files poses a problem; all of them plays flawlessly?

Any idea for a quick fix or do i have to identify and rerip all the files that now will not play?

Ross L
2007-05-25, 14:41
What happens when you try to play them, do you get an error message? Could you go to server settings -> debugging and enable d_source, then try playing a file and post the log here?

nordvest
2007-05-25, 14:45
I get the name of the song etc. on the display but the timer is stuck on 0:00 but no error message or shutdown.
I`ll try to do as you suggest but I\ m new at his at not sure that I`ll get it to work...

Anoop M.
2007-05-25, 14:53
Nordvest,
Try isoloating one of these problem files and send it to me at support AT slimdevices DOT com. I'll take a look at your file and see if I can find out what's going on.

nordvest
2007-05-25, 14:54
This is the log message (or at least some of it; regarding the first song om one of the albums. I should probably also mention here that I transcode flac on the server side and not on the player...):

openSong on: file:///D:/Musikk/Bruce%20Springsteen/Tunnel%20Of%20Love/01%20-%20Ain't%20Got%20You.flac
openSong: duration: [131.027] size: [12669706] endian [] offset: [0] for file:///D:/Musikk/Bruce%20Springsteen/Tunnel%20Of%20Love/01%20-%20Ain't%20Got%20You.flac
undermax = 1, type = flc, squeezebox2 = 00:04:20:07:b4:67
checking formats for: flc-wma-squeezebox2-00:04:20:07:b4:67
checking formats for: flc-wma-*-00:04:20:07:b4:67
checking formats for: flc-wma-squeezebox2-*
checking formats for: flc-wma-*-*
checking formats for: flc-ogg-squeezebox2-00:04:20:07:b4:67
checking formats for: flc-ogg-*-00:04:20:07:b4:67
checking formats for: flc-ogg-squeezebox2-*
checking formats for: flc-ogg-*-*
checking formats for: flc-flc-squeezebox2-00:04:20:07:b4:67
checking formats for: flc-flc-*-00:04:20:07:b4:67
checking formats for: flc-flc-squeezebox2-*
checking formats for: flc-flc-*-*
Checking to see if flc-flc-*-* is enabled
There are 1 disabled formats...
Testing wav-flc-*-* vs flc-flc-*-*
Testing flc-flc-*-* vs flc-flc-*-*
!! flc-flc-*-* Disabled!!
checking formats for: flc-aif-squeezebox2-00:04:20:07:b4:67
checking formats for: flc-aif-*-00:04:20:07:b4:67
checking formats for: flc-aif-squeezebox2-*
checking formats for: flc-aif-*-*
checking formats for: flc-wav-squeezebox2-00:04:20:07:b4:67
checking formats for: flc-wav-*-00:04:20:07:b4:67
checking formats for: flc-wav-squeezebox2-*
checking formats for: flc-wav-*-*
Checking to see if flc-wav-*-* is enabled
There are 1 disabled formats...
Testing wav-flc-*-* vs flc-wav-*-*
Testing flc-flc-*-* vs flc-wav-*-*
enabled
Found command: [flac] -dcs --force-raw-format --endian=little --sign=signed --skip=$START$ --until=$END$ -- $FILE$
Matched Format: wav Type: flc Command: [flac] -dcs --force-raw-format --endian=little --sign=signed --skip=$START$ --until=$END$ -- $FILE$
openSong: this is an flc file: file:///D:/Musikk/Bruce%20Springsteen/Tunnel%20Of%20Love/01%20-%20Ain't%20Got%20You.flac
file type: flc format: wav inrate: 773.044 maxRate: 0
command: [flac] -dcs --force-raw-format --endian=little --sign=signed --skip=$START$ --until=$END$ -- $FILE$
Using command for conversion: "C:\Programfiler\SlimServer\server\Bin\MSWin32-x86-multi-thread\flac.exe" -dcs --force-raw-format --endian=little --sign=signed --skip=0 --until=-0 -- "D:\Musikk\Bruce Springsteen\Tunnel Of Love\01 - Ain't Got You.flac" |
Launching process with command: "C:\Programfiler\SlimServer\server\Bin\MSWin32-x86-multi-thread\socketwrapper.exe" -d -o 3654 -c "\"C:\Programfiler\SlimServer\server\Bin\MSWin32-x86-multi-thread\flac.exe\" -dcs --force-raw-format --endian=little --sign=signed --skip=0 --until=-0 -- \"D:\Musikk\Bruce Springsteen\Tunnel Of Love\01 - Ain't Got You.flac\" |"
openSong: Streaming with format: wav
00:04:20:07:b4:67 New play mode: play
00:04:20:07:b4:67: Current playmode: play
Pipeline reader connected
Read to end of file or pipe
end of file or error on socket, opening next song, (song pos: 0(tell says: . 0), totalbytes: 0)
Didn't stream any bytes for this song, so just mark it as played
opening next song...

Anoop M.
2007-05-25, 15:00
Nordvest,
If you open SlimServer-->Server Settings-->Change the top pull down menu to File Types.

Do you have FLAC->FLAC-->Build in disabled? If so put a check in the corresponding box and click change, try playing your file again. Does this help at all?

nordvest
2007-05-25, 15:01
Nordvest,
Try isoloating one of these problem files and send it to me at support AT slimdevices DOT com. I'll take a look at your file and see if I can find out what's going on.

Shall I send you the flac-file itself?

Also: I` ve just tried turning on flac-flac again and then some of those problem files I have tested suddenly works again so it seems that the problem lays in the transcodeing bit at the server`s side if you can understand what I mean...

nordvest
2007-05-25, 15:04
Yes; that works as I wrote before I saw your new post here. The problem is that I think wav transcoded from the server sounds a little better (please; don`t shoot me :) ) and I think it`s a bit strange that it`s only files which has been retagged that is acting up under the transcoding....

Anoop M.
2007-05-25, 15:10
What happens when you have just the FLAC-->WAV-->FLAC checked and nothing else? Yes please send me the file so I can try to reproduce your problem here on my end.

nordvest
2007-05-25, 15:13
Now i reripped one of the problematic cd`s and now the play flawlessly. So it seems that 6.5.2. and retagged flac-files played/streamed as wav is a bad combination (A bug here?)

The problem now is that I have ca. 1000 albums and i can`t remember which ones has been retagged... Uff (as we say here)!!

nordvest
2007-05-25, 15:15
What happens when you have just the FLAC-->WAV-->FLAC checked and nothing else? Yes please send me the file so I can try to reproduce your problem here on my end.

You mean if I exclude flac- flac and just use "FLAC WAV flac" (ticking that box as the only option for flac). Then there is silence....
I`ll send you one of the files right now.

nordvest
2007-05-26, 03:33
Anoop M:
My mail with the problematic file got returned because it was to big. I got this message:
<support@slimdevices.com>): message size 38085606 exceeds size limit
I don`t have a flac file that`s small enough to go trough your system so what do I do now?

wolfzell
2007-05-26, 06:13
This very much sounds like a known problem:

MediaMonkey is a fantastic software, but unfortunately there has been a problem with a certain MediaMonkey-Release, damaging Flac files while tagging them. The bug has been fixed with the latest relase and there is the possibility to repair the header.

For more information, see:

http://www.mediamonkey.com/forum/viewtopic.php?t=16331

bye
Wolfgang

nordvest
2007-05-26, 09:05
This very much sounds like a known problem:

MediaMonkey is a fantastic software, but unfortunately there has been a problem with a certain MediaMonkey-Release, damaging Flac files while tagging them. The bug has been fixed with the latest relase and there is the possibility to repair the header.

For more information, see:

http://www.mediamonkey.com/forum/viewtopic.php?t=16331

bye
Wolfgang

Thank you, Wolfgang!!
I`ll try the solution and fix script mentioned in that thread and see if that helps.

The strange thing is that the files worked under 6.5.1 of slimserver and would not work under the new 6.5.2