PDA

View Full Version : Scanner.exe hogs cpu



Cartmansdad
2007-05-24, 15:36
So when I play World of Warcraft and turn on ITunes, the scanner.exe starts to run and hogs all my cpu making WoW unplayable until I turn off scanner in task manager. Is there something to keep scanner.exe from popping up all the time?

Mark Lanctot
2007-05-24, 15:46
It shouldn't rescan unless you tell it to. Are you sure it completed the last time you told it to?

I thought I read somewhere that it can be scheduled to rescan, but I have never seen this on any SlimServer version I've ever used.

kdf
2007-05-24, 15:46
Quoting Cartmansdad
<Cartmansdad.2r400n1180046401 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> So when I play World of Warcraft and turn on ITunes, the scanner.exe
> starts to run and hogs all my cpu making WoW unplayable until I turn
> off scanner in task manager. Is there something to keep scanner.exe
> from popping up all the time?

Set the iTunes reload interval to 0 so that you disable the refresh of
iTunes data every time slimserver detects something has changed.

-kdf

Cartmansdad
2007-05-24, 16:30
I have never told it to scan, it just does it. The thing is it does this even when I have not done or added anything to ITunes. I already have all my latest added music on slimserver, it just keeps scanning.

Also, it has now just come on even tho I am not in ITunes.

How do I set that refresh rate to zero?

kdf
2007-05-24, 17:36
On 24-May-07, at 4:30 PM, Cartmansdad wrote:

>
> I have never told it to scan, it just does it.
>
> How do I set that refresh rate to zero?
>
server settings->itunes

Look for "Itunes Refresh Interval". Default should be 3600, but if you
want to turn it off then 0 should do it.
-kdf