PDA

View Full Version : How do I install LAME to enable remote Softsqueeze?



mr-b
2007-05-18, 15:58
I'm trying to get Softsqueeze 3.3 working in a usable fashion from my remote slimserver (6.5.1 on Vista) but it seems be very sluggish responding to remote commands and some albums suffer long dropouts.

I'm guessing this may be because the FLAC files are too big to stream at 400kbps (my SS upstream speed) although SQ doesn't display the playback file type. I've seen the SS Player Setting page's audio bitrate limiting option but it says that LAME is not installed and the link given does not give much helpful info. I eventually found LAME binary from another source and "installed" (saved) it into a directory.

However if I then try enabling the FLAC to mp3 checkbox under SS Filetypes I get rather a complex error:
"File Format Conversions 10:
Setting was changed.

Required binary was not found: [flac] -dcs --skip=$START$ --until=$END$ -- $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -"

So then I tried editing the convert.conf file (that was mentioned on that page) at the "flc mp3 * *" line and replaced $FILE$ with the LAME folder, but I get the same error.

Do I need to enable LAME for flac to mp3 conversion (and if so, how should I "install it") or is there something else that I need to do?

JJZolx
2007-05-18, 16:29
Do I need to enable LAME for flac to mp3 conversion (and if so, how should I "install it") or is there something else that I need to do?

You just drop the LAME binary (lame.exe) into the appropriate folder and restart SlimServer. For a Windows installation the folder is going to be:

(SlimServer root folder)\server\Bin\MSWin32-x86-multi-thread

Then after you restart SlimServer go to Server Settings > File Types and place a check in the Flac to Mp3 line, plus any other file formats you may want to stream to Mp3, such as Monkey's Audio and WAV.

Then (very important) find the player settings for the remote client - it will most likely be listed by IP address unless you've already renamed it. Find the Audio settings and set the LAME Quality Level (I generally use 2, but it will depend on the power of your server) and set Bitrate Limiting. I would guess you'll need something under 256kbps for your connection, but play with it and see what the connection will sustain without dropouts.

mr-b
2007-05-19, 04:55
Tx for all the details - it's working fine now!