PDA

View Full Version : Artist list never compiles correctly



VooDooD
2007-05-17, 20:24
Hi, bear with me... This may take a while.

My main machine which runs iTunes claims to have 945 artists and 590 albums. On a daily basis it synchronises the entire iTunes folder to my NAS device.

My server which is on all the time runs Slimserver as shown below

SlimServer Version: 6.5.2 - 11979 - Windows Server 2003 - EN - cp1252
Server IP address: 10.1.1.200
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt

and uses the NAS via a UNC path to connect to the iTunes folder.

Now, if I allow Slimserver to build the database without using iTunes I get 799 albums and 478 artists. So that's a lot more albums and a lot less artists.

If I take off Slimserver management and use iTunes I get 791 albums and 320 artists... Even worse!!

If I have both Slimserver scanning and iTunes on it doesn't get any better.

I followed the process in MP3TagGuide to remove all of the old crappy tags and replace them with v2.3 ones but if anything it's made the situation worse. I used to have more ov both artists and albums but after emptying the DB and starting again it's all going wrong.


Now the most confusing thing is that I can see the missing artists when I browse the albums. For example, if I browse to O there's an album called "On a Clear Night" by "Missy Higgins" and if I click on Missy Higgins I get a page that gives me a Various Artists Album that she featured on. It does not however show the two albums she's actually produced.

If I then browse to M in Artists, Missy Higgins does not exist!

I'm sure it's a tagging issue but I think that I've done everything that I should and still the Slimserver database ends up being totally wrong.


Can anyone suggest what the solution to my problem might be or point me in the direction of troubleshooting it?

VooDooD
2007-05-17, 22:43
Hmmm. I've just used MP3Tag to remove the comment and composer tags, done a rescan and it's picked up the missing artist field and correctly placed the albums..

Could it be the composer field that's causing the problems? I had tried enabling the add composer to artist option in settings and then I had about 11,000 artist so that was what caused me to try removing the field.

MP3tag is currently running through the entire list of files blanking the composer field. I'll rescan if and when it finishes and let you know how it goes.

JJZolx
2007-05-17, 23:00
Yes, the COMPOSER tag has been causing this type of issue. Do a forum search for a couple of recent threads.

Before wiping out all that good data by blanking or deleting the composer tag I'd use Mp3tag to RENAME the composer tag to something else so that the data can be recovered when the bug is fixed. Try something like XCOMPOSER or anything else that SlimServer won't recognize and the data will be ignored.

VooDooD
2007-05-18, 02:28
Too late! :)

A cleared the tag completely, rescanned and now I have 799 albums and 503 artists....

Still not quite there although from what you're saying, maybe I've now got tags with no Artist or Composer?!?!

Dammit!