PDA

View Full Version : Slimserver not seeing music files



BCModder
2007-05-16, 13:33
Hi Im having a problem, I installed slimserver on my ubuntu server and it seems to see the directory folders that my music is stored in but not the files stored in them. when I click on any of the album folders it loads the page but theres no file list.

Mark Lanctot
2007-05-16, 13:58
Did you rescan? Does it accept your music library path or do you get an "oops" message?

BCModder
2007-05-16, 14:03
it doesn't seem to have a problem with my directory path, Ive also tried rescanning a multitude of times aswell as restarting slimserver and its a no go so far. :S

if it helps my slimserver is on ubuntu dapper 6.06 LTS server

Mark Lanctot
2007-05-16, 14:15
A rescan shows no files? Or are you using Browse Music Folder?

BCModder
2007-05-16, 14:17
yeps, I rescan it and it doesn't seem to fix anything. it sees the file folders my music is stored in just not the files themselves.

Im browsing the music folder and my music directories are all in there but when I click on any of them it shows no files in them.

Mark Lanctot
2007-05-16, 14:21
yeps, I rescan it and it doesn't seem to fix anything. it sees the file folders my music is stored in just not the files themselves.

Could you be more specific? After a rescan, does it show "You have 0 albums with 0 songs by 0 artists"? Or does it show some reasonable numbers but you then can't browse?

Have you checked permissions?

BCModder
2007-05-16, 14:29
when I click rescan it just says this "The server is now rescanning your Music Library." and nothing more then that(when I go to anything but Music Folder it shows 0 albums and 0 artists), as for permissions if there were any I had to change I was unaware of it.

BCModder
2007-05-16, 15:20
ok part of my problem seems to have been the permissions on the directories, however since changing the directories despite the fact that its listing the music files now, when I click the music it just says empty.

Edit:
Sorry for botherin ya lol Ive got it fixed now, not only did the permissions on the directories need to be changed but the music files themselves apparently hadn't been effected along with them so I have to just change that but it works now though and thanks for the help. :D

Mark Lanctot
2007-05-17, 07:09
Sorry for botherin ya lol Ive got it fixed now, not only did the permissions on the directories need to be changed but the music files themselves apparently hadn't been effected along with them so I have to just change that but it works now though and thanks for the help. :D

Heh, I was just going to suggest you needed chmod -R. "-R" recursively changes all files within the directories. Without it, you can change the permissions on the directories but not the files in them. ;-)

See http://forums.slimdevices.com/showthread.php?t=35254