PDA

View Full Version : APE problem



steinwaytony
2007-05-14, 19:02
My APE files won't even play with APE-->FLAC or APE-->WAV.

When I enable ONLY APE-->MP3 (LAME), there is a terrible hissing / "white noise" sound and hardly any music is audible.

I've searched the forums for this problem, and found one thread, but it doesn't appear to have been solved.

I've upgraded to the latest Slimserver, as well as the latest LAME.

Any ideas would be appreciated.
Reply With Quote

kdf
2007-05-14, 19:24
On 14-May-07, at 7:02 PM, steinwaytony wrote:

>
> My APE files won't even play with APE-->FLAC or APE-->WAV.
>
> When I enable ONLY APE-->MP3 (LAME), there is a terrible hissing /
> "white noise" sound and hardly any music is audible.
>
> I've searched the forums for this problem, and found one thread, but it
> doesn't appear to have been solved.
>
> I've upgraded to the latest Slimserver, as well as the latest LAME.
>
> Any ideas would be appreciated.
> Reply With Quote
>
first, look for the convert.conf file. It should be located where you
installed slimserver.
Open that up with your favourite text editor (use wordpad instead of
notepad if you are on windows)
Find the line:

ape mp3 * *

remove the '-x' from the line following, save and close. Restart the
server and see if that helps.

For streaming in the other formats, go into server settings->debugging
and check d_source.
Find the link for the log at the end up the description text near the
top of the page, click on that to open a view of the log.

Watch the log when you try to play using the ->FLAC or ->WAV options.
See if there are any errors reported. If you have trouble interpreting
the log, you can paste sections of it here.

cheers,
kdf

steinwaytony
2007-05-15, 15:50
Thanks a lot for your reply. I deleted "-x" but now there is absolutely no sound at all. Any ideas?

kdf
2007-05-15, 18:03
On 15-May-07, at 3:50 PM, steinwaytony wrote:

>
> Thanks a lot for your reply. I deleted "-x" but now there is
> absolutely
> no sound at all. Any ideas?
>
You probably want to start looking at the logs, with d_source set as I
had described previously. At least that will confirm that the right
command is being used for transcoding, and likely hint at what might be
failing.

-kdf

steinwaytony
2007-05-15, 20:48
No problem, here's a chunk of the log.


openSong on: file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
openSong: duration: [673.427] size: [42322560] endian [] offset: [0] for file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
undermax = 0, type = ape, http = 127.0.0.1
checking formats for: ape-mp3-http-127.0.0.1
checking formats for: ape-mp3-*-127.0.0.1
checking formats for: ape-mp3-http-*
checking formats for: ape-mp3-*-*
Checking to see if ape-mp3-*-* is enabled
enabled
Found command: [mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9 --abr $BITRATE$ - -
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
Matched Format: mp3 Type: ape Command: [mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9 --abr $BITRATE$ - -
openSong: this is an ape file: file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
file type: ape format: mp3 inrate: 502.773 maxRate: 192
command: [mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9 --abr $BITRATE$ - -
Using command for conversion: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\mac.exe" "I:\Rachmaninov - Piano Concertos Nos.2 & 3 - Bronfman, Salonen (APE)\01 - Concerto for piano and orchestra No.2 in C minor, Op.18 1.Moderato.ape" - -d | "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe" --resample 44100 -x --silent -q 9 --abr 192 - - |
Launching process with command: "C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\socketwrapper.exe" -o 2929 -c "\"C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\mac.exe\" \"I:\Rachmaninov - Piano Concertos Nos.2 & 3 - Bronfman, Salonen (APE)\01 - Concerto for piano and orchestra No.2 in C minor, Op.18 1.Moderato.ape\" - -d | \"C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread\lame.exe\" --resample 44100 -x --silent -q 9 --abr 192 - - |"
openSong: Streaming with format: mp3
Pipeline reader connected
We need to send 0 seconds of silence...
sending 0 bytes of silence
We need to send 0 seconds of silence...
sending 0 bytes of silence
We need to send 0 seconds of silence...
sending 0 bytes of silence
We need to send 0 seconds of silence...
sending 0 bytes of silence
We need to send 0 seconds of silence...
sending 0 bytes of silence

kdf
2007-05-15, 22:27
On 15-May-07, at 8:48 PM, steinwaytony wrote:


> We need to send 0 seconds of silence...
> sending 0 bytes of silence
>

How long does this last bit repeat? It would explain the silence, but
it should move past that.

Since APE is a transcoded format, there may be a chance that the latest
socketwrapper might make a difference. It was checked in today, so you
could download tomorrow's build of 6.5.2 and give it a try. You'll
find it here: http://www.slimdevices.com/dev_nightly.html

-kdf

steinwaytony
2007-05-16, 19:32
yes, the "silence" continues for a very long time (the length the track, I would guess).

I will try the socketwrapper and get back to you.

steinwaytony
2007-05-16, 20:38
I updated, but it still doesn't work. When I uncheck APE --> MP3 under Server Settings > Filetypes (I'm trying to get it to convert to FLAC instead?), I get this:



127.0.0.1: Switching to mode play from stop
openSong on: file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
openSong: duration: [673.427] size: [42322560] endian [] offset: [0] for file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192
undermax = 0, type = ape, http = 127.0.0.1
checking formats for: ape-mp3-http-127.0.0.1
checking formats for: ape-mp3-*-127.0.0.1
checking formats for: ape-mp3-http-*
checking formats for: ape-mp3-*-*
Checking to see if ape-mp3-*-* is enabled
There are 0 disabled formats...
Testing ape-mp3-*-* vs ape-mp3-*-*
!! ape-mp3-*-* Disabled!!
******* Error: Didn't find any command matches for type: ape format: mp3 ******
openSong: this is an ape file: file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape
file type: ape format: ape inrate: 502.773 maxRate: 192
command:
openSong: Couldn't create command line for ape playback for [file:///I:/Rachmaninov%20-%20Piano%20Concertos%20Nos.2%20&%203%20-%20Bronfman,%20Salonen%20(APE)/01%20-%20Concerto%20for%20piano%20and%20orchestra%20No.2 %20in%20C%20minor,%20Op.18%201.Moderato.ape]
playmode: No more valid tracks on the playlist. Stopping.
127.0.0.1 New play mode: stop
Stopping and clearing out old chunks for client 127.0.0.1
Resetting song queue
Song queue is now 0
127.0.0.1: Current playmode: stop
Setting maxBitRate for home to: 192
Setting maxBitRate for home to: 192

kdf
2007-05-16, 20:52
On 16-May-07, at 8:38 PM, steinwaytony wrote:

>
> I updated, but it still doesn't work. When I uncheck APE --> MP3 under
> Server Settings > Filetypes (I'm trying to get it to convert to FLAC
> instead?), I get this:
>
>
> Setting maxBitRate for home to: 192
>

This line in the log says that you have a bitrate limit set for this
player. You have to set that to no limit to allow FLAC playback, as
long as APE->FLAC is also checked.

Look in player settings->audio

-kdf

steinwaytony
2007-05-17, 06:15
I'm in Player settings > Audio and there is no way to disable limiting -- only to limit to a max of 320.

bpa
2007-05-17, 06:37
Above 64k - there is a setting "no limit" - select this.

kdf
2007-05-17, 08:19
On 17-May-07, at 6:15 AM, steinwaytony wrote:

>
> I'm in Player settings > Audio and there is no way to disable limiting
> -- only to limit to a max of 320.
>
what model of player do you have?

one of the options should be "no limit" for SB1 through SB3 or
Transporter, only Slimp3 or a web client will be limited to 320 because
they only support mp3 output.

-kdf

steinwaytony
2007-05-17, 21:05
I have a web client -- Slimserver. My "player" is VLC, playing http://localhost:9000/stream.mp3.

Can web clients thus not play APE?

kdf
2007-05-18, 00:05
On 17-May-07, at 9:05 PM, steinwaytony wrote:

>
> I have a web client -- Slimserver. My "player" is VLC, playing
> http://localhost:9000/stream.mp3.
>
> Can web clients thus not play APE?
>
it should work, but will only do so via the APE->mp3 transcoding.

APE can be tricky. I've seen annoying inconsistencies among versions
of the codec.
I have some files on my system, but haven't re-installed mac since my
last OS upgrade.

Perhaps check that the version used to compress the files is the same
version of mac used to play back.
On osx and windows, this is found in the Bin folder under the
slimserver install folder. Otherwise it will be wherever you installed
the mac binary on your system.

-kdf

ocococ
2007-06-26, 14:09
I had the exact same problem (terrible hissing / "white noise") while streaming ape files with
http://localhost:9000/stream.mp3


I just changed ape mp3 configuration in convert.conf.

I replaced

ape mp3 * *
[mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9 --abr $BITRATE$ - -


by


ape mp3 * *
[mac] $FILE$ - -d | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -



And make sure to check Monkey's Audio MP3 in FILE FORMAT CONVERSION SETUP.

Hope this helps

Ocococ