View Full Version : M4A vs. Mp3 issue, Part II

Matt Shelton
2007-05-10, 07:47
After "upgrading" from XP to Vista a month or two ago, I was unable to play m4a tracks but could play mp3 tracks. We solved the issue by having m4a tracks convert to flac via mplayer rather than mov123. So, I am able to listen to all of my m4a tracks.

However, there is another issue specific to m4a: For an album of entirely m4a tracks, it will only start playing from the 1st track. If I want to play any other song from the album, if I select that other song, SlimServer starts playing from the 1st song. This happens to 100% of all m4a's that I'v tested.

In contrast, mp3's play "almost" fine, and the "almost" is what makes this additionally exasperating. Of my 812 album collection, 788 are in m4a and 24 are in mp3. Of those 24 in mp3, 22 of 24 are fine - if I want to start an album from the 5th song on any of these albums, I can do so with no problem. However, with respect to two mp3 albums, I have the exact same issue as with my m4a's.

Anyone have any thoughs? If I were to select a few debugging codes and post to the forum, which codes should I choose?

Mark Lanctot
2007-05-11, 14:12
Try d_source.

2007-05-11, 15:04
What are you using to play the file ?
If you are using an SB3 then d_directstream with d_source will provide some more info.

Matt Shelton
2007-05-13, 08:40
Thanks guys. I'm using a SB3. Here are two log files with d_source and d_directstream, one for an m4a file and one for a mp3 file.

Matt Shelton
2007-05-16, 07:32
Help! Could this be a "pipeline reader" issue?(I don't know what the pipeline reader is). From reading the debug log, I'm noticing that after accessing socketwrapper, the "pipeline reader" fails to open, so slimserver resets the song queue from song #5 in the album to song #1 and plays song #1 successfully (after opening the "pipeline reader"). Here is the applicable part of the log for each, starting from the same line:

Trying to play fifth song in album:

2007-05-13 08:23:19.4366 openSong: Streaming with format: flc
2007-05-13 08:23:19.4818 00:04:20:06:59:8a New play mode: play
2007-05-13 08:23:19.4945 00:04:20:06:59:8a: Current playmode: play
I SHOULD SEE "Pipline Reader Connected" RIGHT HERE
2007-05-13 08:23:19.4953 00:04:20:06:59:8a: Switching to mode stop from play
2007-05-13 08:23:19.4956 00:04:20:06:59:8a New play mode: stop
2007-05-13 08:23:19.4957 Stopping and clearing out old chunks for client 00:04:20:06:59:8a
2007-05-13 08:23:19.4977 Resetting song queue
2007-05-13 08:23:19.4978 Song queue is now 4
2007-05-13 08:23:19.4983 00:04:20:06:59:8a: Current playmode: stop
2007-05-13 08:23:19.4984 jumping to 0
2007-05-13 08:23:19.4985 Adding song index 0 to song queue
2007-05-13 08:23:19.4985 Clearing out song queue first
2007-05-13 08:23:19.4986 Song queue is now 0
2007-05-13 08:23:19.4988 00:04:20:06:59:8a: Switching to mode play from stop

Plays first song instead:
2007-05-13 08:23:19.5275 openSong: Streaming with format: flc
2007-05-13 08:23:19.5614 00:04:20:06:59:8a New play mode: play
2007-05-13 08:23:19.5744 00:04:20:06:59:8a: Current playmode: play
2007-05-13 08:23:19.5761 Pipeline reader connected
2007-05-13 08:23:19.8500 processing headers for direct streaming:
HTTP/1.0 200 OK
Server: SlimServer (6.5.2 - 11801)
Connection: close
Content-Type: audio/mpeg

2007-05-13 08:23:20.4346 Got a track starting event
2007-05-13 08:23:20.4347 Song 0 has now started playing
2007-05-13 08:23:20.4351 Song queue is now 0

2007-05-17, 01:59
The missing "pipeline" is a symptom that the file has been skipped rather than a cause.

I looked at this a bit but I can't see why the files are being played. Have you tried deleting the database and rebuilding it ?

I'm still working on socketwrapper and while testing it, I managed to get an Ogg file "marked" in such a way that slimserver just wouldn't play it and each time it skipped it. Rather than figure out what was wrong - I shutdown slimserver and deleted the whole "cache" directory (rebuilding database didn't work). Now it plays OK - no changes to the contents of the file.

Matt Shelton
2007-05-21, 05:53
Problem seems to be solved. I use iTunes extensively, and recently iTunes added a box to check for "gapless playback". I listen to a lot of live shows and electronic music, and I converted many to "gapless playback", although I was for all intents and purposes getting gapless playback without that setting.

It appears that - only for m4a songs, not mp3 songs - slim server treated an album of "gapless" songs as one long track. Once I took off the "gapless playback", I'm able to now play any track on an album.