View Full Version : Can't play my itunes files :-( ......and it's driving me mad. Please help!!

Julian Thompson
2007-04-24, 17:10
Thanks for reading!

I bought my SB3 a few months ago and fired it up straight away using a laptop to test it. Everything worked fine and my itunes files played (except the DRM ones, obviously).

The laptop then died - motherboard failure... so I whipped the hard drive out and rescued the itunes library.

Fast forward to now, with dedicated slimserver at the ready on XP pro with a SATA raid Z drive for music. I initially put the itunes on a (new!) laptop and the music on the Z. The itunes account was reauthorised with apple and works great. Slimserver scans and finds the music (server is on the C drive of the main computer where the Z is) but then when you try to play an apple song it just comes up with the title and won't play.

I then moved the whole itunes install to the server and reauthorised the account again. So now you have one computer, just like before, but with music on Z and slimserver on C.

It does exactly the same. I just simply cannot make it play ball. it plays Mp3 fine but not the bl00dy apple songs. I have put the LAME thing in the right folder, enabled the AAC jobby and tried innumerate combinations of use itunes/do not use itunes etc...

The only things different than last time, I suppose, are newer versions of itunes (this worked about 6 months or so ago) and new slimserver software (I have tried 6.5.1 and 6.5.2 to no avail.)

I hate to spit my dummy out but I am getting close to launching the SB3 into the dusty bin which would be a shame because I seem to remember it being rather good when it worked!!

I'd really appreciate your helo!!!

Julian Thompson
2007-04-24, 17:14
Added to say that if you leave it "locked up" with the title on the screen for about, say, 10 minutes on one song it will spring into life and play..... when you select another song it sits there for 10 mins again! VERY ODD!

Also to add this is not a wireless squeezebox, it's a wired one and the network is working fine....

2007-04-24, 17:22
1. Have you quicktime installed ? - if not then install it.
2. What security s/w have you installed (e.g. ZoneAlarm, McAfee, NOD32) ? Can you make Socketwrapper.exe a trusted network app.
3. If that fails then replace socketwrapper.exe by the one in this zipped file.

2007-04-24, 17:25
Are you using itunes update plugin? That can cause delays between
tracks if you are running slimserver as a service, and it cannot
connect to itunes running under a user id.

Julian Thompson
2007-04-24, 17:40
Hey cheers chaps.

I have done a bit more fiddling, installed the socket thingy and now it works off the remote but not from the slimserver webhost.

How do I check the apple itunes update plugin - should this be disabled?

Thanks for your speedy help!

Julian Thompson
2007-04-24, 17:46
OK - so I rebooted the machine and now it works fine...

...bl00dy hell I remember how good this product was.

Just a shame the software thing will always be a pain with the computer world (and apple!) all stampeding forward to confuse the issue!

Great forum too - thanks guys!

Julian Thompson
2007-04-25, 00:59
So just to recap - this seems a popular fault.

1) The Slimserver software worked fine and controlled the SB3.

2) The ordinary MP3 music files played.

3) The Apple files (m4a) did not play - instead the display would lock and not do anything with the song stuck at 0.00 time.

The actions I took were:

1) Installed latest version of SS - 6.5.2 - NO CHANGE APPARANT.

2) Tried to check all 3 AAC file format boxes in SS client file types settings which caused errors...

3) ...so I installed LAME decoder. - NO CHANGE APPARANT.

4) Deleted socketwrapper.exe and replaced it with the larger socketwrapper file offered to me here. - Now the music would play with apple tracks but only if you left it for about 10 minutes between tracks.

5) I then noted that if I use the SS remote handset it was working perfectly with no delay. This must have been the socketwrapper change because it didn't work before like that.

6) I then rebooted the machine and it works perfectly from either the web interface or the player.

I'm really sorry I can't just say exactly what I did to fix it so I thought this process might be constructive if you are having a similar fault.


Julian :-))

2007-04-25, 01:22
It's good to get a summary of what worked for you.

From 6.5.1 a change in Slimserver makes use of socketwrapper for formats that needs transcoding such as m4a. However some security s/w stops the distributed socketwrapper from working (usually they think it is a Trojan app) - this may be the case on your system.

What security/Antivirus/Firewall s/w have you installed.

It is hoped to change the distribution to use the new socketwrapper when it is shown to work in most, if not all cases - so understanding your system configuration is important to use a test case.

Julian Thompson
2007-04-26, 04:05
OK - great.

I am having a slight problem in that socketwrapper.exe occasionally closes due to an error on the PC. Nothing seems much to consequentially fail as a result but it happens quite regularly.

I am not using a firewall other than the Netgear router hardware firewall.

I am using AVG virus protection. AVG has not reported anything with reference to socketwrapper.exe

Is there another version of socketwrapper I could try to see if it helps stop the error?

Many thanks,


2007-04-26, 04:46
Socketwrapper will start and stop with each track. What is the error message you get or how do you know there is a problem ?

There is another version of socketwrapper but it only has more messages and error handling for debugging. It may be useful to install it and a debugging version of 6.5.2 which will give more details on the error if your above description doesn't help me.

Only Netgear firewall is active - so Windows firewall has been deactivated ?

Which AVG product and version have you installed - some antivirus s/w have side effects.

AVG Anti-Virus Free
AVG Anti-Spyware Free
AVG Anti-Rootkit Free
AVG Internet Security
AVG Internet Security Home Edition
AVG Anti-Malware
AVG Anti-Virus Professional Edition
AVG Anti-Virus plus Firewall
AVG Anti-Spyware

Julian Thompson
2007-04-26, 08:13
Hey thanks bpa for all your help - it's really appreciated!!

Bascially windows throws a "Socketwrapper.exe has encountered a problem and needs to close" error.

The windows firewall is off, yes, and the only firewall is on the router itself at the front of the system.

The anti virus is, predictably I suppose :-), the AVG Anti-Virus Free edition. (Though I have to say that it doesn't seem to be a bad program at all.)

The error occurs on the computer itself (obviously!) when I do a lot of browsing and playing using the SB3 remote. Basically the only symptom is that when the error has occured you know because there is a wait before the track starts again. Nothing like before - we're talking probably 10 seconds. If you then go to the PC and take a look the error message will be waiting for you. If you then just hit OK, log off and log back on again (or I suppose stop/restart slimserver) it is OK again)

Hope this helps!



2007-04-27, 01:37
I tested AVG on a test machine and it didn't seem to cause the original problem which replacing socketwrapper fixed.

Do you have any other special networking software installed such as a VPN client to access/use company network securely from home.

I did a little bit of testing with socketwrapper and flipping between songs but couldn't reproduce the crashes. If you can think of any more details it might help (e.g. you were playing snippets from many songs as you were browsing, while song was playing you were doing many long searches etc.)

Julian Thompson
2007-04-29, 00:53

I can't get it to fail again now either!

Nothing has changed on the system but I have come to the conclusion that it must be something to do with the fact that I run my machine on a stripped out set of services in services.msc to get maximum performance. Occasionally this causes me a problem where an app is trying to make use of something I have stopped.

I think this might be the issue here but I'd like to have a play to work out what services the slimserver relies on - do you have any starting points for this?

2007-04-29, 07:14
The sockwrtwrapper problem usually show because of additional s/w and not because s/w is disabled.

The following command (to be run from command line window) will show all the network s/w that is installed - it might show any non-standard stuff such as spyware !

netsh winsock show catalog

Can you do it and post the log - you may have to put in a txt file and zip it.

Julian Thompson
2007-05-06, 04:53
Hi again!

Well I did that but I couldn't copy the text to paste it unfortunately!

I have noticed though that the problem is in fact still there, but I have also noticed that what happens is that sometimes the end of a song is truncated and THEN you get the socketwrapper message when you go and look at the PC. This makes sense I think - your song is chopped short because socketwrapper fails but then the next song starts and you think everything is OK but when you check the PC you see the remnants of the problem with the error message.

It does not happen on every song!

I might try the old socketwrapper?

2007-05-06, 05:39
If you open a command prompt box and then issue the command

netsh winsock show catalog >netshlog.txt

The output will be in the file netshlog.txt

Regarding cutting short songs., This bug 4544 has been reported for a while but when updating socketwrapper to fix network problem, it was found that socketwrapper cause the problem - you have reached the same conclusion.

As we "speak" fixes are being developed from two points of view - (i) avoid use of socketwrapper where possible as it was before 6.5.0 and (ii) fix socketwrapper to stop loss of data at end of a song.

I am not sure about the socketwrapper crash but hopefully it will also be fixed when the above problems are sorted.