PDA

View Full Version : Slimserver will not start - player dark



kkottman
2007-04-16, 04:37
Hello-
I've been happily running 6.5.1 on XPpro SP2 for some time w/o any problems - no recent updates or changes that should affect anything. After using it all weekend to play music, I woke up this morning to find the player completely dark - I noticed because we use as a clock - and when I try to power on it says "Waking slimserver..." and then goes dark again.

I proceed to troubleshoot the server side and find the machine has been re-booted overnight (probably an automatic windows update). I find that the slimserver service cannot start and the browser cannot find localhost:9000. Further troubleshooting reveals the following:

EVENT VIEWER ERRORS:
-------------------------------
C:\DOCUME~1\KEVINK~1\Desktop\SLIMSE~1\server\Bin\M SWIN3~1\mysqld.exe: Incorrect information in file: '.\slimserver\tracks.frm'

For more information, see Help and Support Center at http://www.mysql.com.

---------------------------------
The description for Event ID ( 0 ) in Source ( Application ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Carp::Clan::__ANON__(): Error executing 'SELECT COUNT( * ) FROM tracks me': DBD::mysql::st execute failed: Incorrect information in file: '.\slimserver\tracks.frm' at C:\PROGRA~1\SLIMSE~1\server\CPAN/DBIx/Class/Storage/DBI.pm line 771.
----------------------------------

When I manually try to stop and start the mysql and slimserver services it fails wihin a minute or so and I get a message that states: "The SlimServer service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performenace Logs and Alerts service."

I've rebooted the machine a couple times and tried everything I can think of - anyone have any ideas? Thanks in advance-

mherger
2007-04-16, 05:02
> When I manually try to stop and start the mysql and slimserver services
> it fails wihin a minute or so and I get a message that states: "The
> SlimServer service on Local Computer started and then stopped. Some
> services stop automatically if they have no work to do, for example,
> the Performenace Logs and Alerts service."

Do you have McAffee running on your computer? It used to block MySQL
files. Or do you have a corrupted/full file system?


--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

kkottman
2007-04-16, 05:50
Thanks Michael- Negative on Macafee... the A/V on this machine actually does not run natively at all (scanned from another machine overnight only)

re: Corrupt/Full file system - not sure how to check this - I can tell you that the machine this is on is fairly overpowered for its use....its dual P4 3ghz with 2g RAM and ~300g disk and not running too much other than SS and a handful of other clientish things like outlook... the system partition of the disk is at 23G of 80G avail. If you can tell me where else to look for corruption or capacity I can get additional info...

Thanks again!

kkottman
2007-04-16, 05:53
Oops....one other thing - the machine is behaving completely normal - no other issues.... Event log does not list any other errors other than those related to SS or mySQL.

Rick B.
2007-04-16, 05:55
My SB goes dark every few weeks. I just unplug the power cord, wait 15 seconds, re-connect and it's O.K. again.

mherger
2007-04-16, 06:07
> Event log does not list any other errors other than
> those related to SS or mySQL.

Have you tried removing the MySQL data alltogether
(Slimserver/Cache/MySQL) and start from scratch? With your hardware specs
this shouldn't take too long :-).

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

kkottman
2007-04-16, 06:09
Thanks for the reply Rick- I have had *that* issue before too....I eneded up having to send the unit back for a new circuit board as after a while it completely died..... I think this issue is different only because outside of the device itself being dark (I am able to power on and get spash screen, config menus etc...) I simply cannot get the server side processes to start - which I believe the remote/player unit needs to run/connect to. Since I've made no changes, my assumption is that if I can get server processes started and running, the player will work fine. Thanks again.

kkottman
2007-04-16, 07:53
Thanks Michael - will try that and report back

kkottman
2007-04-16, 09:45
Michael - you win the prize - your suggestion seems to have worked like a charm - thank you very much.

To recap what solved this....

Issue: for no apparent reason SlimServer service would not start on the server and neither browser could bring up page nor could client device connect. Event log had errors (listed above) primarily: Incorrect information in file: '.\slimserver\tracks.frm'

Resolution: I stopped slimservermySQL service. Then I proceeded to blow away all of the mySQL data. To do this I went to Slimserver/Cache/MySQL - and deleted all directorys, data, files, etc... Then I restarted slimserver service and restarted slimservermsql service. It took about 5-10 minutes to recreate everything but presto! its all back working again and device turned itself back on and connected automatically.

Thanks again for your help!

gjrhine
2007-04-20, 17:04
I am having the same problem since clicking on the upgrade button the last time I successfully started Slimserver. Slimserver service cannot start and the browser cannot find localhost:9000 I called tech support and they said I must have changed something on my computer. I have no idea what mySQL is (some king of 3rd party app?) but here are some lines from a file called mysql-error-log.txt that look suspicious to me. Can someone make some sense of this?

Version: '5.0.22-community-nt' socket: '' port: 9092 MySQL Community Edition (GPL)
070412 12:20:21 InnoDB: Operating system error number 32 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/mysql/en/Operating_System_error_codes.html
InnoDB: File name .\ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
070412 12:20:26 [Note] C:\PROGRA~1\SLIMSE~1\server\Bin\MSWIN3~1\mysqld.ex e: Normal shutdown

070412 12:20:28 InnoDB: Starting shutdown...
070412 12:20:29 InnoDB: Shutdown completed; log sequence number 0 43655
070412 12:20:29 [Note] C:\PROGRA~1\SLIMSE~1\server\Bin\MSWIN3~1\mysqld.ex e: Shutdown complete

kkottman
2007-04-20, 17:33
Gary-
the mySQL is the database that runs underneath the slimserver server process (the piece of the software that runs on the computer). For whatever reason mine got corrupted. I recommend trying the remedy outlined above....however I am a bit of a novice myself.

y360
2007-04-21, 00:26
070412 12:20:21 InnoDB: Operating system error number 32 in a file operation.


32 (ERROR_SHARING_VIOLATION)
The process cannot access the file because it is being used by another process.

Maybe you already have mysql process running as part of a service ?
I would uninstall & install from scratch

gjrhine
2007-04-23, 14:20
I use Unlocker on ibdata1 and it says nothing has a lock on it.

I uninstalled everything, re-installed and no change.

I go to Administrative Tools/Services and start Slimserver and it says the service did not respond.

Squeezenetwork works fine but I have no idea how to get Slimserver working again.

gjrhine
2007-05-02, 12:49
All I know so far is I can get it started by refreshing the page that says "Internet Explorer cannot display the webpage". I still don't know what causes it.