PDA

View Full Version : Tag problems WMA



wellington
2007-04-01, 05:51
Hello
I wanted to know if somebody has a solution for the issue of Slimserver not adding the few WMA files I have to my music library.
The WMA files play fine if browsed from my Squeezebox 3, but there is no way to see them in the library.
I have mainly FLAC and MP3 files in the library and there is no tag issue with them.
Can anybody help me? I am running version 6.5.2.

Thanks a lot for your help.

Mark Lanctot
2007-04-01, 09:40
So you can browse to them but they don't appear in your library? That's strange, as soon as you browse to them, they should be added.

You've rescanned? Try the "clear everything and rescan" option.

Are the files properly tagged? Check them with a tag editor.

You might want to enable the d_scan debugging option in Server Settings - Debugging then scan, posting the text output here. This will show if the scanner sees them but ignores them due to tag issues, or if it just doesn't see them at all.

wellington
2007-04-01, 11:25
Thanks for replying to me.
Yes, I did rescan 3 or 4 times for the full library. No way to get the files in the library.
I tried to re-tag the files using mediamonkey and another editor, still SB does not "see" these wma files.
I did the debugging you suggested. The result is as follows:
Thank you again for your help.



__________________________________________________ _______________
ERROR: Slim::Control::Command::setExecuteCallback() has been deprecated!
ERROR: Please use Slim::Control::Request::subscribe() instead!
ERROR: Documentation is available in Slim::Control::Request.pm

Slim::Web::Pages::addLinks() has been deprecated in favor of
Slim::Web::Pages->addPageLinks. Please update your calls!
Backtrace:

frame 0: Slim::Web::Pages::addLinks (C:\Programmi\SlimServer\server/Plugins/XMRadio/Plugin.pm line 1326)
frame 1: Plugins::XMRadio::Plugin::webPages (/PerlApp/Slim/Utils/PluginManager.pm line 424)
frame 2: (eval) (/PerlApp/Slim/Utils/PluginManager.pm line 424)
frame 3: Slim::Utils::PluginManager::addWebPages (/PerlApp/Slim/Utils/PluginManager.pm line 197)
frame 4: Slim::Utils::PluginManager::initPlugins (/PerlApp/Slim/Utils/PluginManager.pm line 95)
frame 5: Slim::Utils::PluginManager::init (slimserver.pl line 413)
frame 6: main::init (slimserver.pl line 32)
frame 7: PerlSvc::Startup (perlsvc.pl line 1482)
frame 8: PerlSvc::_startup (slimserver.pl line 0)
frame 9: (eval) (slimserver.pl line 0)

Setup::rescan - initiating scan of type: [wipecache]
__________________________________________________ _______________

wellington
2007-04-01, 12:05
forgot to say I have noticed something else.
The albums do not show up in the "artist" menu, but the related albums do indeed show up if you search by "album" in SB.
I can then get the album, and SB tells me it is from the proper artist, but back in the artist menu the albums do not show up.
For example if I search for the artist "Anouk" it tells me there is just some mp3 files, but if I search for albums it tells me there is a "Graduated Fool" by "Anouk" coded in wma.

Very strange.

tyler_durden
2007-04-01, 17:08
Ever notice that few seem to have problems with .flac files showing up as intended? That's because they are almost all generated by the person placing them into their library and taking the time/expending the effort to tag them properly.

So many people post about problems with itunes and WMA files. The problem usually comes down to tagging errors. If you put itunes, mp3, or .wma files that you didn't generate yourself into your library you are putting yourself at the mercy of whoever tagged them. There are a lot of idiots out there who don't give a rat's butt about whether they get dates or genres right, USE ALL CAPS IN TITLES, misspell naamez and wurds, put labels into the wrong place in the tags, etc., and they especially don't care about whether the song shows up properly in the search/browse/display of YOUR squeezebox.

The band-aid solution to the problem is to download and learn to use a good tag editor to find and fix the problems. The best solution is to wean yourself from restrictive format music sources or DLing from questionable sources. If I were paying for files with restricted formats and the tags were wrong I would raise hell about the source's quality control. If they can't get the tags right, can you trust them to get the rip/encode right? As for DLs of questionable origin, you get what you pay for...

TD

wellington
2007-04-02, 12:40
I agree with what said in the last post, but as I already posted
I've re-tagged with 2 tag editors and the problem is still there.
If "Mediamonkey" and "Tag&Rename" are not good editors, please let me know of a better alternative and I will give a try.

Thank you

wellington
2007-04-05, 12:19
Any thoughts by anybody?