PDA

View Full Version : Cue file problem



code-breaker
2007-03-27, 21:05
SlimServer Version: 6.5.1 - 11206 - Debian - EN - iso-8859-1

I am a new squeezebox user, I use lossless (ape & flac) compression, whole albums ripped to a single file, and cue files.

Everything is working great, except one problem. The cue files are being parsed correctly, I know because track titles display properly. But if an album is playing, and I try to change tracks, SB starts playing the entire album from the beginning again. When I get info on individual tracks, they all have durations of 3 sec. Any suggestions? Here is a sample cue file:


PERFORMER "Frank Black and the Catholics"
TITLE "Pistolero"
FILE "Frank Black & The Catholics - 1999 - Pistolero.ape" WAVE
TRACK 01 AUDIO
INDEX 01 00:00:00
TITLE "Bad Harmony"
TRACK 02 AUDIO
INDEX 01 03:17:30
TITLE "I Switched You"
TRACK 03 AUDIO
INDEX 01 08:36:02
TITLE "Western Star"
TRACK 04 AUDIO
INDEX 01 11:46:37
TITLE "Tiny Heart"
TRACK 05 AUDIO
INDEX 01 15:16:50
TITLE "You're Such a Wire"
TRACK 06 AUDIO
INDEX 01 17:22:42
TITLE "I Love Your Brain"
TRACK 07 AUDIO
INDEX 01 21:09:62
TITLE "Smoke Up"
TRACK 08 AUDIO
INDEX 01 24:03:32
TITLE "Billy Radcliffe"
TRACK 09 AUDIO
INDEX 01 26:26:10
TITLE "So Hard To Make Things Out"
TRACK 10 AUDIO
INDEX 01 32:02:05
TITLE "85 Weeks"
TRACK 11 AUDIO
INDEX 01 34:36:32
TITLE "I Think I'm Starting To Lose It"
TRACK 12 AUDIO
INDEX 01 36:45:70
TITLE "I Want Rock & Roll"
TRACK 13 AUDIO
INDEX 01 39:46:30
TITLE "Skeleton Man"
TRACK 14 AUDIO
INDEX 01 42:56:72
TITLE "So. Bay"

Mark Lanctot
2007-03-28, 13:42
Turn on Server Settings - Debugging - d_source, play a few of these files until you get the problem, then post the output here. The log can be found using the "here" link at the bottom of the text paragraph in the debugging page.

code-breaker
2007-03-28, 19:31
I selected the third track from the album and hit play, which caused the album to be played from the beginning of the first track, and produced this output log:


2007-03-28 19:14:24.1275 Adding song index 0 to song queue
2007-03-28 19:14:24.1277 Clearing out song queue first
2007-03-28 19:14:24.1278 Song queue is now 0
2007-03-28 19:14:24.1281 00:04:20:07:96:40: Switching to mode stop from stop
2007-03-28 19:14:24.1282 Already in playmode stop : ignoring mode change
2007-03-28 19:14:24.1601 00:04:20:07:96:40: Switching to mode stop from stop
2007-03-28 19:14:24.1603 Already in playmode stop : ignoring mode change
2007-03-28 19:14:24.1604 jumping to 2
2007-03-28 19:14:24.1605 Adding song index 2 to song queue
2007-03-28 19:14:24.1606 Clearing out song queue first
2007-03-28 19:14:24.1606 Song queue is now 2
2007-03-28 19:14:24.1609 00:04:20:07:96:40: Switching to mode play from stop
2007-03-28 19:14:24.1689 openSong on: file:///home/code-breaker/Rock/Frank%20Black/Frank%20Black%20&%20The%20Catholics%20-%201999%20-%20Pistolero.ape#516.026666666667-706.493333333333
2007-03-28 19:14:24.1704 openSong: duration: [190.467] size: [23380819] endian [] offset: [63345080] for file:///home/code-breaker/Rock/Frank%20Black/Frank%20Black%20&%20The%20Catholics%20-%201999%20-%20Pistolero.ape#516.026666666667-706.493333333333
2007-03-28 19:14:24.1712 undermax = 1, type = ape, squeezebox2 = 00:04:20:07:96:40
2007-03-28 19:14:24.1714 checking formats for: ape-wma-squeezebox2-00:04:20:07:96:40
2007-03-28 19:14:24.1715 checking formats for: ape-wma-*-00:04:20:07:96:40
2007-03-28 19:14:24.1716 checking formats for: ape-wma-squeezebox2-*
2007-03-28 19:14:24.1717 checking formats for: ape-wma-*-*
2007-03-28 19:14:24.1717 checking formats for: ape-ogg-squeezebox2-00:04:20:07:96:40
2007-03-28 19:14:24.1718 checking formats for: ape-ogg-*-00:04:20:07:96:40
2007-03-28 19:14:24.1719 checking formats for: ape-ogg-squeezebox2-*
2007-03-28 19:14:24.1720 checking formats for: ape-ogg-*-*
2007-03-28 19:14:24.1720 checking formats for: ape-flc-squeezebox2-00:04:20:07:96:40
2007-03-28 19:14:24.1721 checking formats for: ape-flc-*-00:04:20:07:96:40
2007-03-28 19:14:24.1722 checking formats for: ape-flc-squeezebox2-*
2007-03-28 19:14:24.1723 checking formats for: ape-flc-*-*
2007-03-28 19:14:24.1723 Checking to see if ape-flc-*-* is enabled
2007-03-28 19:14:24.1724 enabled
2007-03-28 19:14:24.1725 Found command: [mac] $FILE$ - -d | [flac] -cs --totally-silent --compression-level-0 -
2007-03-28 19:14:24.1727 Matched Format: flc Type: ape Command: [mac] $FILE$ - -d | [flac] -cs --totally-silent --compression-level-0 -
2007-03-28 19:14:24.1728 openSong: this is an ape file: file:///home/code-breaker/Rock/Frank%20Black/Frank%20Black%20&%20The%20Catholics%20-%201999%20-%20Pistolero.ape#516.026666666667-706.493333333333
2007-03-28 19:14:24.1729 file type: ape format: flc inrate: 982.044 maxRate: 0
2007-03-28 19:14:24.1729 command: [mac] $FILE$ - -d | [flac] -cs --totally-silent --compression-level-0 -
2007-03-28 19:14:24.1739 Using command for conversion: "/usr/bin/mac" "/home/code-breaker/Rock/Frank Black/Frank Black & The Catholics - 1999 - Pistolero.ape" - -d | "/usr/local/bin/flac" -cs --totally-silent --compression-level-0 - & |
2007-03-28 19:14:24.1966 openSong: Streaming with format: flc
2007-03-28 19:14:24.2027 00:04:20:07:96:40 New play mode: play
2007-03-28 19:14:24.2131 00:04:20:07:96:40: Current playmode: play
2007-03-28 19:14:24.6805 Got a track starting event
2007-03-28 19:14:24.6807 Song 2 has now started playing
2007-03-28 19:14:24.6811 Song queue is now 2
2007-03-28 19:14:24.6817 Got a track starting event
2007-03-28 19:14:24.6818 Song 2 has now started playing
2007-03-28 19:14:24.6821 Song queue is now 2

I should note that track times are now correctly computed, although nothing has changed since yesterday, when they were not. But the problem of starting at the beginning of the album, whenever I select a new track persists. And looking at the log, it looks correct..."Pistolero.ape#516.02" is obviously the start time of the particular track in seconds, and this is correct, since from the cue file, the third track starts at 08:36:02. But for some reason, it plays from the start of the file, instead of the start of the track.

code-breaker
2007-04-02, 17:21
Well, problem avoided. I bought a qnap ts-101, and slimserver is working fine there.

Funny thing re this post: http://forums.slimdevices.com/showthread.php?t=34021, I plugged the usb drive into a usb port on the ts-101, and a shortcut showed up in the music directory. Don't know how that happened, but the ts-101 solved THAT problem too.