PDA

View Full Version : Wake on Lan wakes the wrong MAC



Graham
2007-03-18, 16:13
I've got a squeezebox 3 (firmware v72) wirelessly connected to a router and on to a pc in my garage. The garage pc connects wirelessly to the router too, via a client bridge (Buffalo WBR-G54 running DD-WRT). Everything works fine, except for Wake On Lan. I'd really like to get this going, so here's the reason it's not:

A bit of packet sniffing with ethereal shows that the SB is sending its magic packet to the MAC of the bridge rather than the MAC of the pc. WOL is fully enabled on the pc, and I can wake it up using my wireless laptop and a magic packet generator pointing at the correct MAC.

I can't see a way to tell the SB to use the correct MAC, as it seems to work it out from traffic. Interestingly, windows gets the MAC correct if you do a "nbtstat -a <garage>", but SB is getting it wrong.

Does anyone have any idea how to fix this? I'm sooo close to getting my system working!

Mark Lanctot
2007-03-19, 08:47
It's a bug:

http://bugs.slimdevices.com/show_bug.cgi?id=4664

You can vote for it and add your experience if you found anything new, but you have to create a new bugzilla account.

Graham
2007-03-19, 12:49
Thanks Mark! I didn't find that thread, but it looks the same problem. Not strictly a bug perhaps, but certainly an unnecessary restriction to the viability of WOL from a SB.

snarlydwarf
2007-03-19, 13:06
Can you turn off proxy-arp on your router? It really shouldn't need that.

Graham
2007-03-19, 14:11
I don't think DD-WRT firmware allows fully transparent bridging, or so it says in http://www.dd-wrt.com/phpBB2/viewtopic.php?t=68&postdays=0&postorder=asc&start=0
Replacing the wireless bridge with a length of cable would solve it but the route to that PC is tricky in my house. If it looks unlikely this SB limitation will be fixed soon, I'll have to get out the long drill. It's probably a relatively simple change to the firmware, but it may not be their highest priority.

(The drill will be applied to the wall, not the SB!)