PDA

View Full Version : How do I allow power-saving Standby mode?



Mike New
2007-03-16, 17:39
To cut down on the amount of energy I'm burning on useless things, I'd like my PC to enter Standby mode after a period of time. Within seconds of going into Standby, however, my "powered-off" Squeezeboxes wake it right back up again. If I unplug the Squeezeboxes from the network, the PC stays on Standby until I plug one in again. I'm guessing this might have something to do with the clock updates to the Squeezebox.

I'd like Squeezebox to reawaken the PC only if I use the remote control, or if the alarm clock function fires. Is there a way to do this?

The energy savings would be substantial. My PC burns about 100 watts when running (all the time), but only 3 watts on standby.

Thanks for the help.
Mike

gorman
2007-03-17, 04:35
After some pretty hefty electricity bills I've started wondering about the same thing...

Max F
2007-03-17, 08:08
After some pretty hefty electricity bills I've started wondering about the same thing...

Not to hijack this thread, but how can running a computer 24/7 result in a hefty electric bill? My bill is probably at least 80-90% influenced by the use of my AC or heater.

pfarrell
2007-03-17, 08:14
Max F wrote:
> Not to hijack this thread, but how can running a computer 24/7 result
> in a hefty electric bill? My bill is probably at least 80-90%
> influenced by the use of my AC or heater.

For most people, the biggest power user in their house is the
Refrigerator/Freezer. It runs all the time. In many climates, it uses
more power than the electric heat or A/C, because they are only used for
three or four months a year.

Now a hardcore gamer PC, with a 1000 watt power supply, might draw 250
watts all the time, so that can add up, altho not to what I'd consider
"hefty". Such a PC is silly as a SlimServer, I've run mine on cast off
computers for four (or maybe even five) years now.


--
Pat
http://www.pfarrell.com/music/slimserver/slimsoftware.html

Mike New
2007-03-17, 12:14
Looks like this thread did get hijacked.

The issue isn't the money. The issue is how much power I'm wasting on something that isn't bringing me or anyone else any reward. Having the PC consume 2.4 kilowatt-hours a day when I'm only using it for 2-3 of those hours is dumb - if not irresponsible. Whether or not you believe we're causing global warming , it only makes common sense to stop dumping CO2 into the air for no good reason.

I know, I can turn it off and be a good citizen. But I like to listen to music when I go to bed and I like the ability to wake up to whatever I want. If Squeezebox could wake up the PC only when *I* want, instead of every few seconds when I'm sound asleep, I'd feel better about myself.

So, is there a way to do this?

topa
2007-03-18, 01:28
Yeah, it works here.
But to be honest, I cannont tell you why that is.

Maybe you have some setting (plugins!!!) that recheck with the server every so-and-so. I don't know, stupid RSS feeds or alikes.

Maybe you should reset the whole thing? Or try and disable most of the plugins for a start at least.

Tobi.

bigjules
2007-03-18, 02:36
Sounds like you might have your slim server box set to wake on any network traffic rather than just a WOL signal.
You're squeezebox continually polls your slim server machine (dont ask me why.. still seems like a strange design decision to me, but that is the way it is)

Dont know what OS you are using though.. can we have more details?

mswlogo
2007-03-18, 08:50
Looks like this thread did get hijacked.

The issue isn't the money. The issue is how much power I'm wasting on something that isn't bringing me or anyone else any reward. Having the PC consume 2.4 kilowatt-hours a day when I'm only using it for 2-3 of those hours is dumb - if not irresponsible. Whether or not you believe we're causing global warming , it only makes common sense to stop dumping CO2 into the air for no good reason.

I know, I can turn it off and be a good citizen. But I like to listen to music when I go to bed and I like the ability to wake up to whatever I want. If Squeezebox could wake up the PC only when *I* want, instead of every few seconds when I'm sound asleep, I'd feel better about myself.

So, is there a way to do this?

Mike,

I'm totally with you. Just because we have other larger consumers of energy doesn't make it is an excuse to forget about everything that takes less. See my "Green" thread.

Just because your car/freezer wastes lots of energy does that mean you skip recycling paper and plastic? Stupid logic bringing the freezer up.

http://forums.slimdevices.com/showthread.php?t=33324&highlight=green

You can run a "green" server.

You need a network card/motherboard that can support wake on LAN. Which does use a small amount of power 24/7.

I do have my Server Running with WakeOnLan. Problem is it's not very user friendly because of a few bugs. See thread above.

I have made some progress by editing and understanding the "PreventStandby" plugin. I think I know what I need to do now to make it work more WakeOnLan friendly. Basically this plugin is dumb.

I just reread your post, your problem may be related to mine but not quite the same thing.

I have my server with a 1 hour sleep. But if SqueezeBox is running (i.e. playing music) the "PreventStandBy" plugin keeps the server awake. It checks like once a minute to keep it awake. If you Pause or Stop music. PreventStandby will stop preventing the server from sleeping and within 1 minute will shutdown. It appears to do this even if it just woke the server that has a 1 hour power management setting. But that does not matter.

The reason why they shutdown on "Pause" is that when you power off squeezebox the music is "Paused". I Plan to rework the script to shutdown only if paused for more than say 1hr.

By the way the squeezebox itself is never really off. It's just what ever slimserver decides to display to give you the impression it's off.

Hope this helps.

michel
2007-03-18, 10:02
As I understand Mike New's problem is, that his PC wakes up or does not go into standby as long as his SB's are connected to mains power.
Mike, try disabling clock screensaver (and all other screensavers too) so that the SB's display goes blank when powered down.
Additionally set WOL in device properties (WinXP) to magic packet only. This prevents your server to wake up from network activity other than SB's.
When I had clock saver active on my PC did not want to power down too. Now I have running it for a year or so and standby (in my case hibernation) works like a charm.

Mike New
2007-03-18, 12:45
First of all, thanks to all who threw in their two-cents worth on this.

After trying some of the ideas, and then a few of my own, I got this to work - pretty much.

Environment: Windows XP Pro, with a two-year old HP PC that has good power management options.

Action #1: Disabling the Clock Screensaver had no affect on the problem. The Squeezebox still re-awakened the PC seconds after going into standby.

Action #2: The device manager for my network card (Realtek Fast Ethernet NIC) had some fairly confusing settings for Wake on LAN functions, but by checking the box "Only allow management stations to bring the computer out of standby," I got the results I was hoping for. The computer would enter Standby mode as planned, and would not wake up until I pressed a key on the Squeezebox remote. If music was playing, the system would not enter Standby mode until the music stopped. Success!

An aside here - For testing purposes, I had the Standby Mode timer set to a minute, which worked great except the computer would go into Standby while the music was still playing. I finally figured out it was because enough music was being buffered ahead that Squeezebox wasn't asking for more before the timer expired. (FLAC files) I upped it to 2 minutes and cured the problem.

Action #3: I'm halfway there. The PC will enter standby after the music stops playing and wake up when I press a Squeezebox remote button, but the Squeezebox alarm function won't work. Presumably the alarm is controlled by Slim Server, which is peacefully slumbering in Standby. I cured this by setting a Scheduled Task in Windows to wake up an hour or so before the alarm is set to fire. (My Standby mode is set at 2 hours.) Sure enough, the PC wakes up and the alarm fires as scheduled and Slim Server begins playing.

Unfortunately, the fact that Slim Server is playing doesn't necessarily mean any music is coming out. After being in Standby, SS occasinally seems to forget where the volume is set, which means it's either muted completely or so low I can't hear it. Touching the volume button on the remote immediately cures the problem - assuming I'm awake.

Other than this niggly problem, however, everything works exactly as I hoped. When I'm not using it, my PC now draws 3 watts instead of 100, and tomorrow morning I'll feel like an environmental giant - if I'm awake.

Cheers - Mike

deadkenny
2007-03-18, 20:09
Whether or not you believe we're causing global warming , it only makes common sense to stop dumping CO2 into the air for no good reason.
That depends how your electricity is generated. It might not be a CO2 generating kind. Could be nuclear (which is very clean when it comes to global warming) or even a green source such as wind if you're lucky.

Anyway, you could do like the airlines and politicians and just buy "credits" to offset it ;) (and no I don't think that's actually a great idea as it's doing nothing to actually address the pollution).


What about the Squeezebox itself though? How energy efficient is it when not in use?

I'm thinking of sticking all my gadgets that don't need to be on 24/7 onto a separate power strip with a switch I can power on when needed. Just leaves the TiVo and Sky box on all the time (oh and plus the web/mail/file/p2p server in the cupboard :-D )

MrSinatra
2007-03-22, 13:05
hey Mike New,

i'm with you on this, great work. its not a money or GW issue, its simply avoiding wastefulness.

i think you should consider turning all this knowledge you've gained here into a SD Wiki article.

it would make things easier for others to find and add their knowledge to.

sunset-squeeze
2008-03-24, 07:12
There is a known issue with Intel Viiv "Quick Resume" which can prevent a PC from timing out to Standby when using a Squeeze Box.

If "Quick Resume" is enabled, and you wake up the PC from Standby via a Wake on LAN by turning on a Squeeze Box, it will never go back to Standby after the Squeeze Box is turned off.
(The only way to get to Standby is to use do something on the PC itself.)

http://downloadmirror.intel.com/12128/ENG/Release_1523.htm,

"The system will not timeout to Hibernation or Standby via the system inactivity timer if the system has awakened to Quick Resume mode from Hibernation or Standby from a programmed video recording or a wake on LAN event .
Workaround: Wake the system to S0 via the mouse or keyboard and then allow the inactivity timer to expire or manually put the system in to Hibernation or Standby."