PDA

View Full Version : SlimServer won't start in OSX after upgrade to 10.4.9



Zach Anthony
2007-03-15, 01:28
Hello,

Yesterday my existing SlimServer install stopped working - it will no longer start. This happened directly after updating OSX to 10.4.9, so I'm wondering if this is the cause?

I tried un- and re-installing Slim but to no avail.

Here is the contents of slimserver.log - I'm hoping it will help someone to diagnose the problem for me:

------------------------------------------------------------
MIME::Base64 object version 3.05 does not match bootstrap parameter 3.07 at /System/Library/Perl/5.8.6/darwin-thread-multi-2level/XSLoader.pm line 92.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Async/HTTP.pm line 39.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Async/HTTP.pm line 39.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Scanner.pm line 44.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Scanner.pm line 44.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Commands.pm line 40.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Commands.pm line 40.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Request.pm line 415.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Control/Request.pm line 415.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Client.pm line 19.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Client.pm line 19.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Common.pm line 44.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Common.pm line 44.
Compilation failed in require at ./slimserver.pl line 115.
BEGIN failed--compilation aborted at ./slimserver.pl line 115.
--------------------------------------------------------

Has anyone else experienced this? I've had a look through the Forums and the only thing that seemed likely to help was deleting the SlimServer cache, followed by an un-install, neither of which helped.

Thanks in advance for any help that is offered.

Cheers,

Z.

DrArchaeo
2007-03-15, 06:00
I too have experienced an inability to reconnect to my Slim Server after upgrading to Mac OS X 10.4.9. Hopefully, someone can come up with a resolution to this issue or confirm there is a problem with this latest version of OS X -- I would rather not downgrade to OS X 10.4.8, but I will if I can't get my SLIMP3 to work.

andyg
2007-03-15, 06:12
That's odd, MIME::Base64 is fine here on 10.4.9. Try replacing the file /System/Library/Perl/5.8.6/darwin-thread-multi-2level/MIME/Base64.pm with version 3.05 from this link (http://search.cpan.org/src/GAAS/MIME-Base64-3.05/Base64.pm).

Alternatively you can install 3.07 from CPAN, but this will require the Apple dev tools to compile.

Zach Anthony
2007-03-15, 06:56
Thanks andyg.

I'm attaching a copy of the misbehaving Base64.pm in case it should help you diagnose this.

Cheers,

Z.

andyg
2007-03-15, 07:01
Did using 3.05 fix the problem?

Maybe what happened is that you (or something) manually installed a newer version of MIME::Base64 and the OS upgrade replaced only the binary bundle part and not the pm file.

Zach Anthony
2007-03-15, 07:06
Sorry, I should have been more specific.

I downloaded the v3.05 file you linked to and replaced the one on my system with it. SlimServer started up fine after that.

Cheers,

Z.

Steven Moore
2007-03-15, 10:23
Upgraded to 10.4.9 yesterday, ss and sb working fine.

Zach Anthony
2007-03-15, 10:28
Not surprising I guess - if everyone upgrading to 10.4.9 had been effected I don't think mine would have been the first post about this!

It must be something like andyg described - I've installed something at some point that messed with the .pm file, and its only become evident when the update happened?

Z.

Steven Moore
2007-03-15, 11:33
Very probably, try repairing permissions after the update?

Zach Anthony
2007-03-15, 13:57
Nope, and prob too late now as the problem is fixed anyway. Good idea though.

dmcnamara
2007-03-15, 22:49
Upgrade to 10.4.9 and slimserver will not connect to the squeezebox. Works fine with SoftSqueeze. Trying the PERL fix now although I am unable to get slimserver to start after making the change.

danco
2007-03-16, 03:08
Is everything else working, including connection to the internet? How is the Squeezebox connected?

I just upgraded to 10.4.9, and almost the first thing I did was try the Squeezebox. It would not connect.

I then used Airport Admin Utility, and found my Airport stations were not recognised, even after unplugging and replugging, so of course the SB would not connect.

I started wondering if my router connection was ok (both my Mac and the Airport station are wired in to the router), and found that when I tried to use Safari I got told I was not connected to the internet.

At that point I restarted my Mac (it had, of course, restarted a couple of times after the upgrade).

And now all is well.

MORAL: It's always worth restarting the Mac if you are having troubles.

heegard
2007-03-23, 13:38
I believe I had updated to 3.07 at some point; when I upgraded by mac-mini (PPC) to 10.4.9, the slimserver stopped working. Manually downgrading the file:
/System/Library/Perl/5.8.6/darwin-thread-multi-2level/MIME/Base64.pm
from 3.07 to 3.05 fixed the problem. It's interesting to note that on my intel MacBook Pro, this is not a problem. (I have a perl script that calls:
use MIME::Base64;
this was also broken on the mac-mini, but not the macbook.)

-Chris

heegard
2007-03-23, 14:27
Another fix is to reinstall v3.07 of MIME::Base64
this updates:
/System/Library/Perl/5.8.6/darwin-thread-multi-2level/auto/MIME/Base64/Base64.bundle

-Chris

davidmac27
2007-04-11, 13:58
I am new to Macs so go easy on me. I installed 6.5.1 on my new Mac Pro that I just updated from 10.4.8 to 10.4.9. When I click start slimserver, it turns itself off after a few seconds. I tried downgrading to 3.05 but I don't even have that directory as shown above. Any suggestions??? Is there something else I need to install to make this work?