PDA

View Full Version : 6.5.2 scans end up with title-less albums



TimothyB
2007-03-02, 01:39
It seems like every time I try updating Slim Server past 6.3.1, I run into something that sends me back.

The slimtray was leaking handles so badly it crashed my machine. I'd stopped using it until bpa posted a custom one that doesn't do that.

I have almost all my music in FLAC images + cues, none of them would play - they'd just sit stuck at 0:00. My couple random MP3s would play, though. From trawlling the forums I found out about a 3rd party socketwrapper.exe. That let me play my flac files.

Now, I have a scanning issue. Once the scan is finished, about a dozen albums - out of 1090 flac/cue pairs - lose the album title. It's weird - during the scan, the album "The Christmas Rose" by Patrick Ball shows up properly, but by the time the scan finishes, the album title is gone.

What can I do to diagnose/fix this?

-- Timothy

WinXp Pro SP2
I installed 5.6.2 (2007-02-28) into a fresh directory.

SlimServer Version: 6.5.2 - 11542 - Windows XP - EN - cp1252
Server IP address: 192.168.1.101
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt

TimothyB
2007-03-13, 23:11
I did yet another install - this time of the 03-13 build. I changed my music folder to just scan a subset of my albums for testing. I also happened to check my playlist folder, and noticed two playlists, one for an internet radio station and one of Christmas music. The .m3u of Christmas music referred to the albums that weren't being scanning correctly in SlimServer! So I renamed it to .m3u.txt and lo and behold The Christmas Rose scanned correctly. Now trying a scan of my entire collection.

Apparently there is a scanning bug when playlists contain songs in FLAC images.

Any other gotcha I should know about playlists?

-- Timothy