PDA

View Full Version : slimserver memory usage



John Rakestraw
2007-02-22, 20:10
Hi --

I'm running SlimServer 6.5.1 on a Fedora Core 6 box (512Mb RAM, Pentium
4 CPU 2.66GHz.) SlimServer finds all of my music and streams it just
fine to 3 Squeezeboxen, but slimserver.pl uses an increasing amount of
memory the longer it runs. When I start it up, top shows it to be using
about 12.5% of memory. Right now top shows slimserver.pl has been
running just under 3 and a half hours and it's using 38.8% of memory. I
first noticed the problem when we weren't able to play any music at
all. Web access to the SS interface was very, very slow -- I ssh'ed
into the box and saw that slimeserver was using virtually all the
memory. I restarted SS and it dropped back down to 12.5%. One other
time I noticed that SS was not running and the logs indicated that the
system had killed the slimserver process because it was using all the
memory.

I'm dealing with the problem now with a cron job that restarts the
slimserver service twice a day, but that's rather less than elegant.

When I first noticed this I tried running slimserver without any
plugins, and the problem persisted.

Perhaps it's relevant that this is a recent FC-6 install following a
reformat of the drive. This 6.5.1 is the only version of slimserver
that's been on this system installation, and it was a fresh install.

The server is not used for much else -- a file server for occasional
backups and a print server for occasional print jobs. And I've not
generated a music scan in weeks.

I don't know which debugging settings might be relevant here -- could
someone here suggest some settings that might reveal what's going on?

Thanks.

--John