PDA

View Full Version : Random tracks not displaying properly in web UI



dbls
2007-02-21, 09:26
Some tracks in Random Mix aren't being displayed properly:

- In the Nokia770 skin, the track name is missing from the "Now Playing" screen, and clicking the track in the playlist produces a page with no track information. The track names DO appear on the right, where the previous, current and next tracks are shown.

- In the default skin, track name appears, but artist name is missing; clicking track in either Now Playing or the playlist yields the page with no information.

Closer inspection reveals the wrong item number in the track links. Oddly, the item numbers for the CDs in question are sequential except for the problem tracks, and Random Mix seems to use the missing value in the sequence. It PLAYS the track correctly, so it must be using different item numbers for playback and display.

I had one CD with three such out-of-sequence tracks, and when I created a playlist from that CD, only the odd tracks displayed correctly, but at least the item numbers in the playlist were correct. So I suppose it's not only Random Mix that's going strange.

I don't think I've made any changes to the database since my last wipe and rescan.

[Firefox 2.0.0.1 - SlimServer Version: 6.5.1 - 11206 - Windows XP - EN - cp1252]

Mark Lanctot
2007-02-23, 15:38
I don't think I've made any changes to the database since my last wipe and rescan.

I've seen this when there were changes made.

Sometimes I think they happen even when no changes are made, the database seems to corrupt itself after a while. It's quite random for me, so it's not repeatable enough for me to make a bug report.

Clear library and rescan.