View Full Version : Squeezebox3 and Belkin G+ Mimo wireless modem router?

John E Boy
2007-02-14, 10:45
Hi all.

I've just come back from holiday and whilst away I powered down my Squeezebox3 in an attempt to do my bit for global warming :D

Anyway - once I came back I wanted to listen to a bit of music again so plugged my Squeezebox back into the power only to discover that it will no longer connect to my wireless access point. It was working before I went away too - it still works via the wired ethernet but that's not why I bought it.

So - is there anyone reading this forum using the same modem/router and if so does it work for you?

For info:
I'm using version 6.5.1 of Slimserver with firmware 72 for the squeezebox.
My router has hardware version 1 and is running the latest (and only) firmware available which is 1.0.4. The exact router model is a Belkin F5D9630uk4A.
I've tried changing WEP settings/channel/UPNP/Firewall settings etc for my router. Unfortunately there isn't a setting on the router for me to downgrade the wireless to normal wireless G or B so I've not been able to try that.
I've done a factory reset of the Squeezebox several times.
I've reloaded the Squeezebox firmware several times.
My wireless network still works with my other devices (PDA/tablet PC/Xbox etc) so I don't think it is my router.

I've consulted the Slimdevices knowledge base and this forum.

Does anyone have any idea what else I can try (and yes I've opened a support ticket too) or does it sound like my Squeezebox is faulty?

Yours in silence :(

2007-02-14, 11:41
I would think it is highly unlikely for an unplugged device to fail over time. It is effectively suspended animation for electronics. Though the power-up/power-down may be trying, I would still look at the most common thing: passphrase wrong.

Try turning off all encryption on the router, and on the SB. That should work (though obviously not the way you want it to be). I would just do a factory reset of the SB, and change the setting on the router, should take only a couple minutes to test. Make sure you don't have MAC filtering on as well.

If that works, then it is the fun of trying to play match-the-keys and type them the same on both ends.

If that doesnt work (or since this is easier), just for grins: check the MAC address of the SB on the bottom of the box and the MAC address it has in the network settings. They should match.

Mark Lanctot
2007-02-14, 12:43
Also - does the SB still see the SSID of the router? Are you using a unique SSID?

John E Boy
2007-02-15, 04:13
For info in case this helps anyone else.

I had my reply from Logitech support yesterday evening. It suggested I fix the problem by opening up my network by turning off WEP.

I tested with this and it worked.

Needless to say - when I turned it back on the squeezebox didn't connect once again. So I'm going to change my SSID/WEP key to see if that makes a difference.

Otherwise if it does need WEP off I will see if it will connect with MAC filtering on. I am not going to open my wireless network to all and sundry - I'll return the squeezebox as "doesn't do what it says on the tin" first ;)

I assume that there is some bug in the Squeezebox firmware WEP implementation possibly introduced with firmware 72. Can anyone confirm this?

I'll post another reply once I experiment with different SSIDs, keys and Mac Filtering.


Mark Lanctot
2007-02-15, 07:49
You have to be exact with the WEP/WPA passphrase. Off by one character and it won't work. This includes capitalization as well as leading or trailing spaces that are hard to spot, see http://wiki.slimdevices.com/index.cgi?NetworkProblemsBeginnersGuide

Also WEP is not much better than no encryption at all. Go direct to WPA or WPA2. Start out with a really easy passphrase like "a" or "1" or something. If it will connect with easy passphrases, it will connect with longer, harder ones.

John E Boy
2007-02-15, 17:35

Well I tried a new SSID on the network and new WEP key.
The squeezebox won't connect if I have a 128 bit WEP key active on the network.
I conclude that for some reason there is a bug in the WEP implementation and yes I have double checked and triple checked the keys. In fact I have entered the keys so many times I can almost remember them!

As for the comment about wep keys and case - be serious - we are talking about hex here. 0xa or 0xA is decimal 10 no matter what ;)

Fortunately despite having to turn off WEP I've been able to get the squeezebox connected with mac filtering on the router.

I'm going to reply to my fix email from Logitech suggesting the WEP implementation in the latest squeezebox firmware might be flawed.


John E Boy
2007-02-15, 17:50
Oh and I have a bunch of legacy devices on the wireless network so unfortunately WPA is something I cannot use. :(

Mark Lanctot
2007-02-16, 16:53
As for the comment about wep keys and case - be serious - we are talking about hex here. 0xa or 0xA is decimal 10 no matter what ;)

Sorry - I'm used to WPA. Haven't played much with WEP due to it not being very useful to me.

2007-02-17, 04:28
Strange, I'm running 128bit WEP on my SB with the latest firmware with no issues.

1 thing spings to mind. I use static I.P.s for my player and server. I'm wondering if you have found a combination of a DHCP/WEP bug.

The lease on your I.P. would have expired while you where away, and tried to re-negotiate the lease.

John E Boy
2007-02-17, 13:18
My home network has a mixture of static IP addresses and dynamic IP addresses, so I am running DHCP from the router.

I'll try another experiment - I'll attempt to assign a static IP address to the Squeezebox and see what happens with WEP off and on.

I post my results tonight or tomorrow :D


2007-04-25, 02:18
Looks like the firmware is bugged on your router. Belkin have released a pre release firmware update (untested) that states it fixes a problem with Apple Airport connectivity using WEP on this version of the router...


Should imagine its the same for a squeezebox