View Full Version : Using MySQL 4.0.24 with SlimServer 6.5.1

2007-02-12, 09:48
I recently installed Solaris 10 x86 and want to run SlimServer on it. Since I had to install the tarball sans MySQL I thought I'd use the MySQL that came with Solaris (more on why in a minute). After following some how-tos on setting up MySQL and SlimServer I can't get it to work. I followed the Wiki page on using your own MySQL instance and SlimServer can log into the database but that's when I get an error.

But first, why I am not using a newer version of MySQL. I tried using the Solaris binary from MySQL and when I tried to use that I couldn't get one of the perl modules to compile (mysql-dbi-3.0002 IIRC). I even tried compiling MySQL on my own and had problems. I am using Sun Studio 11 as my compiler (I also compiled perl 5.8.8 myself using Studio 11). Basically, no other version of MySQL has been able to get me this far, and I feel things are really close to working.

The error I get is:

# ./slimserver.pl --cachedir=/usr/local/slimserver/cachedir --user=slimsrv --group=slimsrv --prefsfile=/usr/local/slimserver/cachedir/slimserver.pref --pidfile=/usr/local/slimserver/cachedir/slimserver.pid
2007-02-12 11:31:20.6701 Warning: Migrating from 6.3.x used with MySQL!
Database error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 8 at /usr/local/slimserver/CPAN/DBIx/Migration.pm line 115.
2007-02-12 11:31:20.6985 ERROR: forceCommit: Trying to commit transactions before DB is initialized!


Any ideas as to what I can do?

2007-02-12, 10:20
I believe you will need minimum version 4.1 of MySQL with SlimServer 6.5.1. To get an older version of MySQL to work you will at least need to patch and rewrite SQL statements in various files, it will probably be a lot of work.

Do you need 6.5.1 ?
Maybe you can run the 6.3 release of SlimServer which doesn't use MySQL ?