View Full Version : Listen Again on AlienBBC Stops

2007-02-09, 12:52
Hi All

I really hope that somebody can help. I have just purchased a SB3 and have utilsed the AlienBBC plug in. However, Listen again stops at around 4 mins after starting, this happens every single time. The normal live BBC stations work perfectly and my signal strength is 85%.

I am not techie minded, but know enough to reset my MTU settings as advised elsewhere on this site. I am running the latest versions of squeeze software and alien (so the bandwidth tweak doesnt apply)both these solutions do not work.

I am listening from the UK and one of the main reasons for buying a SB3 was to listen to 'listen again' in my lounge. Can somebody please help, i'd be so grateful.


2007-02-09, 13:37
The reason for this is usually on Windows changing the default TCP settings in the registry or having a link with a long transmission delay (e.g. satellite link).

If you are on Windows, you can do either of the following:

1. If you have changed the TCP registry settings - changed them back and delete the ones added.


2. In the Plugins/Alien directory there is a file called custom-convert.conf.alt. Do the following:
A. Rename the current custom-convert.conf to something else say custom-convert.conf.old
B. Rename the custom-convert.conf.alt file to something else say custom-convert.conf
C. Restart slimserver

Solution 2 will result in Listen Again taking about 15 secs rather the 2-3 secs to start.

2007-02-09, 15:21

I tried solution 2, but i now get a RTSP error and it wont connect.

Can you help

2007-02-09, 15:51
I see my instructions were unclear - I cut & pasted too much text.

That error might happen if there is no file called custom-convert.conf, if it can't be read by slimserver or if it is empty.

Can you double check that the name of the "alt" file is now exactly "custom-convert.conf".

2007-02-09, 15:53
I have the same problem on two different XP installations. Very frustrating as I'm missing Just A Minute.
Is it the same / related to what could be an mplayer issue reported in this http://forums.slimdevices.com/showthread.php?t=32572 thread?

2007-02-09, 16:09

Yes the Alt file is called 'custom-convert.conf and the conf file has been renamed with old suffix

2007-02-09, 16:10
At present there are two frequent problems with AlienBBC streams stopping. There problem are not related and affect different types of streams.

1. Live Stream only stops
This is related to mplayer version - BBC has changed something and live stream stop if is it being played by a version of mplayer older than 1.0pre8

2. "Listen Again" streams stops usually between 2 - 4 minutes after starting. This usually happens with Windows and usually something has changed the default TCP settings or else a link with long transmission delay is being used.

The problem is associated with the mplayer "bandwidth" option which is an implementation of RealPlayer Turboplay. Turboplay enables quick startup of streams such that "Listen Again" streams start within2-3sec as opposed toi 15 secdon without using "bandwidth". The fix is either reset the TCP settign or remove the "bandwidth" option from the entries in custom-convert.conf file. The "alt" version of custom-convert.conf file has the "bandwidth" option removed to save users editing the file and possibly making errors.

2007-02-09, 16:12
Ok just tried it again and i'm still getting the same message -

RTSP convert error - check file types

I have a normal broadband connection - 8M speed

How do i reset the TCP settings?

Thanks for your help so far

2007-02-09, 16:14

Just to make sure something else hasn't happened. Can you rename the files back (i.e. current conf to alt and old to conf ) and restart slimserver.

If AlienBBC works OK with the original file back in place, upload and attached the alt file to a post.

2007-02-09, 16:21
Here is the Alt file mate

I just noticed that the icon for the alt file was already a wordpad icon - could this be the problem???

# AlienBBC - windows version
# Alternative with no -bandwidth option

# Default for mplayer pre7 or later
rtsp wav * *
[mplayer] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$
rtsp mp3 * *
[mplayer] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
rtsp flc * *
[mplayer] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -

# Alternative for mplayer up to pre6
#rtsp wav * *
# [mplayer] -really-quiet -vo null -cache 128 -af resample=44100:0:1 -ao pcm -nowaveheader -aofile #PIPE# $FILE$
#rtsp mp3 * *
# [mplayer] -really-quiet -vo null -cache 128 -af resample=44100:0:1 -ao pcm -nowaveheader -aofile #PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
#rtsp flc * *
# [mplayer] -really-quiet -vo null -cache 128 -af resample=44100:0:1 -ao pcm -nowaveheader -aofile #PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -

# Edit the above lines for the following options:
# - To enable socketwrapper debug mode change #PIPE# to #DEBUGPIPE#
# To boost volume, change resample=44100:0:1 to volume=x:sc,resample=44100:0:1, where x is a number e.g. 8

2007-02-09, 16:32
The wordpad icon should be no problem as that is what you should use to edit it. Did you edit this file ?

Separately, I asked for you to attach the file because that way I could examine it without any format changes which happen with a cut & paste into a post.

Attach is a clean version of the alt file. Download, unzip and then go through the rename & restart again with this file to be renamed to custom-convert.conf

2007-02-09, 16:39
Just triedit again and have the same RTSP error as before.

At the moment i have the alt file labelled 'custom-convert.conf' and the conf file renamed as 'custom-convert.conf.old'

I have restarted slimserver every time and have saved your clean alt file.

Really appreciate your effort on this, i'm desperate to get this to work.



2007-02-09, 16:50
I'm not sure what is wrong but we'll try a different tack - editing the working conf file.

1. Stop slimserver
2. Rename the old conf file back to custom-convert.conf, restart slimserver and check that slimserver behaves as before (i.e. plays live streams, Listen Again stop after 4 mins).
3. Stop slimserver
4. Save a copy of custom-convert.conf as another name
5. Open the file custom-convert.conf with Wordpad (not Notepad) and remove the text "-bandwidth 1000000 " from the 3 RTSP lines.
6. Close the file and save.
7. Start slimserver and test AlienBBC again.

2007-02-09, 17:32

It's worked!!!!

My friend, you are a genius! And more importantly a very kind and patient genius.

Thanks very much for your help, its vvvvv much appreciated.



2007-02-09, 17:35
Good to know that worked - not sure what's wrong with the alt files.

For completeness, it is useful to know what triggered this problem on your PC
- did you modify the TCP registry values on your PC or run some app which might have "optimized" the registry values.

2007-02-09, 17:43
I ran a MTU optimizer ages ago. I think this changes the TCP settings too.

Thanks again

2007-02-10, 04:17

Thanks, your advice has sorted me out too.